Razer Kiyo Stopped working after turn ring light on | Razer Insider
Solved

Razer Kiyo Stopped working after turn ring light on

  • 28 April 2023
  • 33 replies
  • 3088 views


Show first post

33 Replies

HELP - Been working ok but during a call today  the ring light started flickering and the camera started making a loud hissing noise and the stopped working.
If I disconnected the USB and reconnect I can make it work for 2sec then it fails again

Can you help me fix. This looks like a common issue with all on this thread

I’m having the same issue I’ve barely used mine in the last year I’ve only used it for streaming a couple of times and now that I have a bit more free time I wanted to start streaming again and it stopped working it was pretty much in the same order the light started flickering even though I had it turned off then it started making a buzzing noise then went dead and I can’t even get it working now.

Same for me.

Worked flawlessly then loud sparking noise and then it died.


If I disconnected the USB and reconnect I can “make it work for 2sec then it fails again”.

Probably the LED driver pulling more power then the USB specification allows...

 

 

Similar issue started happening to me today.  I have had a Kiyo for ~1.5 years, and its been great.  Mid-call with my boss, the ring light started flickering and the camera started making a loud hissing noise.

 

I am running the latest firmware, and tried reinstalling Synapse to no avail.  I also switched which port the Kiyo was plugged into, also to no avail.

 

How can I fix this?

Just bought one today brand new out the box and got this issue within 10mins of use. for sure just going to return it, even the firmware update is locked.

The exact same thing happened to me. I own it for a year and have used it like 15 times. Never dropped it or anything and today that i needed it after turning the led on it started a buzzing sound the led stuck on full brightness and it does not work anymore. Tried everything to no avail. Last razer product for me.

Userlevel 7

Hey guys,

 

I’m sorry to hear about your experience with using the Razer Kiyo camera. I would love to lend a hand and see what options we have for addressing the issue. Please PM me the serial number of your device so I can validate its model and check for other model-specific steps. Thank you!

Yeh I feel your pain Bro. My Kiyo has just done exactly the same, flickering, buzzing then dead. Cam was a bit warm. Cooled off then worked for 10 mins, before buzzing and flashing and dead again. Help!

 

Reply