Razer Kiyo Stopped working after turn ring light on | Razer Insider
Solved

Razer Kiyo Stopped working after turn ring light on

  • 28 April 2023
  • 33 replies
  • 2937 views

Hello everyone,

I just bought a razer kiyo 1,5 years ago, I'm using it as my daily camera to work. I do meetings and thats all, usually the camera is turned on at most for 1 hour for each meeting. Most of the time it is turned on only for 15-30 minutes.

Today I was in a call and decided to turn the ring light on, which is something that I haven't done in while. It turned on normally, however some minutes after turned on the right light started to flicker, so I tried to turn it of, but it didn't turn off.

So I disconnected the USB cable from the hub connected again, after doing that the camera was recognised by the google meets meet, however after trying to choose it and turn it on, it turned the "on/off" LED on the image popped, but a few seconds later the on/off LED started turning off, but different from normal, it was turning off like a capacitor discharge.

Then the computer doesn't recognise the camera anymore, I tried different USB ports, tried let it disconnected for sometime and connect again, I also tried to connect to a different computer. Currently I was using it with a Mac Silicon chip connected though a TP-Link hub, connected to a USB-A to USB-C adapter connected to the Mac. I tried to connect it directly to the USB-A from my windows machine. When I open razer synapse on it, the camera was recognised, however after trying to open it and access, the same behaviour happened, the camera turned on for a few seconds, and became unreachable.

Windows showed me a message informing that the USB device presented a malfunction and can't be reached anymore. After that looks like the camera was connecting and disconnecting from windows, this error message was popping a lot of times, and that sound of connecting a USB device to windows was sounding repeatedly.

Any clue? The camera is just broke after 1,5 years of usage? 

Best regards

icon

Best answer by Razer.Zionzedd 2 May 2023, 08:08

View original

33 Replies

Happened to me a few days earlier too. Mine is only 11 months but it’s already broke.
I’ll try to claim warranty but if it doesn’t work, I’ll try GuppieGreenzoneaero241’s solution.

 

I couldn’t claim and get it replaced. They said they’re out of stock.
So, I took it back and try this and it works!

I am having the same issue so glad to hear I am not alone. On the plus side, I have been looking for an excuse to move all my hardware to Logitech. Thanks Razer 👌

bye RAZER hello logitech!

Agree with this whole thread. Very disappointed. Exact same issue 6 months after warranty expired. Went back and forth with them for over a week (including spending an hour on the phone with them), only for them to tell me it was out of warranty (which I already knew and stated as much when I first called) and offer me 10$ off my next purchase if I subscribed to their newsletter. Absurd. Have been a loyal customer for several years and have multiple Razer products.

So my Razor Kyro Camera which I have had for over a year and really like started doing the same thing...Flicking, buzzing, etc. Did updates nothing. So, I followed the instructions from GuppieGreenzoneaero241’ however I don't have a soldering gun, so I simply firmly pushed the F1 transistor on both sides and the middle. Pretty skeptical that it would not work, I put it back together and what, so you know, it lit up like a charm and is working normally. 

I do agree that a web camera should last more than a year and I was 2 steps in going to a Logitech, but I like the light ring on this camera and have overall been pleased.  So we see how long it last from here. Hope this helps someone. 

I went through the same issue. Bad experiences with Razer products so for.

 

I'm having the same problem and it is absolutely frustrating. Went into a client meeting only to find the camera stopped working but the ring around it remained on. Felt like an idiot. I tried uninstalling the driver and razer synapse but nothing helped. 

 

And this one is just over a year old...

Just updating this thread, bought the camera in 2021, after almost daily use when working at home, now almost daily it just stopped working. Flashing and my is switching to different camera’s. I’ve been only using Mac OS and it worked perfectly until today.

 

Luckily found this post and the description to bridge the F1, the camera lives again! 

 

For all of the people coming from google, don’t be afraid to open the camera and get out you solder iron, the camera is broken but can be fixed!

Reply