Razer leviathan v2 turns on but will not work | Razer Insider
Solved

Razer leviathan v2 turns on but will not work


Userlevel 1

My leviathan v2 speakers have been working great for a while now and all of the sudden, stopped working, they turn on and the source light is green, but my pc no longer detects the speakers whatsoever. i also cannot change them to bluetooth to connect my phone to them. i just cannot get anything out of them. i have tried updating the firmware but in order to do this, the device needs to be in bluetooth mode so i cannot update, i have tried reinstalling synapse and restarting my pc but still no luck. i left it a couple of days and suddenly the source light was solid red and pressing the buttons or holding them did nothing, i switched it off at the wall and then back on and im back to them being able to turn on and off but still cannot get them in bluetooth mode or cannot get my pc to recognise them.

icon

Best answer by EpikkVanilla 8 September 2023, 18:29

View original

51 Replies

I have the same issue… speakers work but suddenly no sound. Source light blue for me though. Trying to update whatever I can now and see what happens later. 
 

Razer support team please answer us on why this is happening…..

Hi guys, I just had this same issue, tried different USB ports, no fix. Tried bluetooth connection which resulted in a solid red light. What did fix it was trying a different cable than the Razer one, as soon as I tried this my pc detected the device. Unplug the power if you get in the red light state, but try a new cable then connect to your pc. It seems to be an odd issue with the firmware update getting stuck and changing the cable corrects this. My device is now working again after I change cable and unplugged the power to exit the red light state. I then also tried the original Razer cable and this works too. I hope this helps you guys! P.S My issue was caused by a brown out power surge at my house for a minute, device didn’t lose power but my oven etc did, it seemed to be enough voltage disruption to prevent the firmware check from power cycling - or whatever the exact technical term may be. Good luck and hope this helps.

I have the same issue… speakers work but suddenly no sound. Source light blue for me though. Trying to update whatever I can now and see what happens later. 
 

Razer support team please answer us on why this is happening…..

Hi guys, I just had this same issue, tried different USB ports, no fix. Tried bluetooth connection which resulted in a solid red light. What did fix it was trying a different cable than the Razer one, as soon as I tried this my pc detected the device. Unplug the power if you get in the red light state, but try a new cable then connect to your pc. It seems to be an odd issue with the firmware update getting stuck and changing the cable corrects this. My device is now working again after I change cable and unplugged the power to exit the red light state. I then also tried the original Razer cable and this works too. I hope this helps you guys! P.S My issue was caused by a brown out power surge at my house for a minute, device didn’t lose power but my oven etc did, it seemed to be enough voltage disruption to prevent the firmware check from power cycling - or whatever the exact technical term may be. Good luck and hope this helps.

Hey, mine has the same issue, but changing cable doesn't help, I tried 3 PCs, I tried multiple cables, and no reaction from OS whatsoever 

Userlevel 7

Hi guys, 

 

Thank you for raising your concerns here in the support board. If the problem persists across multiple PCs with using different cables, it’s highly likely hardware-related. Nevertheless, please PM me the serial number so I can verify its model and check my resources for best resolutions to address the issue. 

I have the same issue, now it is only good as a lamp because of the LED, I cant play music via bluetooth or usb anymore 😥

I also have this same issue, occurring just today. I have tried 3 different cables, and also turned the power off to everything, and reconnected one by one, but no joy.

I am having same issue. Having power surge few days ago and still unable to get the speaker back alive.

Going to try to change the cable and hopefully it will revive the speaker…

 

Hi, i have the same issue here. i tried eveything you said before, still doesn’t work.

I am having same issue. Having power surge few days ago and still unable to get the speaker back alive.

Going to try to change the cable and hopefully it will revive the speaker…

 

Speaker is back alive after changing the ori cable (which facing power surge previously) to another usb-a to usb-c cable. I am only can update the latest firmware with this method even red light on power source button. The ori cable seems like not working when I reconnect back, but just work OK if connected to another lighting device...

I’m facing the same issue, sometimes this is working and sometimes no. I hate this product, I’m  not going to buy any Razer products in the future. I bought it, without extend warranty and  now after only 6 months this garbage is not working.

same problem. Replacing the USB cable didn't help. Windows does not see the device, Bluetooth playback also does not work (although pressing the volume buttons changes the volume on the phone - everything else does not work)

I do not know how - but it came back to normal after connecting to another computer with synapse installed. Then, after connecting to the original one, there were no problems. The USB cable is the same

i have same issues but im going to msm razer support still not working 

Hello, I too am experiencing the same issue. Attempted to switch cables and no fix. Any updates? 

 

Hello, I too am experiencing the same issue. Attempted to switch cables and no fix. Any updates? 

 

bro me too this leviathan v2 is too sux broooo

I suspect that disconnecting the device from the power supply for more than 15 minutes helped me. Now it is working, but the synapse still does not see it

Same issue

 

I've been going back and forth with support and they're telling me I have to buy a new one with 15% off.  I just want this one to work.  It's ridiculous I can't even do an update on my own because the BT button doesn't function.

Tried new cables.  Multiple ports. Powered off n on etc

 

Very unhappy 

Userlevel 1

UPDATE…. Slight fix i have found…

 

So when i posted this, i had fixed it before i saw any replies, managed to fix with changing the power wire that goes to the power brick… since then it was fine (once i got it back to PC mode) but then i took it in to the garden to use with my phone for bluetooth and then same again, would not go back to pc mode and would not play with bluetooth.

 

I tried for hours with switching cables and nothing worked, i then found a cable from a back massager that i have, that had the same size plug for the speaker end and it has the same specs as the power brick from the original one… Input: 100-240v - 50-60Hz so i removed the original power brick and plugged this into the speaker, turned it on, and it was able to switch to pc mode instantly, i then turned it off and plugged the original power wire back in and its working perfect on my pc… for me this is fine because i just wont change back to bluetooth again… i feel like this issue is initially down to the power brick from razer just being iffy / broken and probably requires a new one, but as long as its in pc mode and not switched, it works.

 

Thanks fort all your replies, hope this can help you all.

Man, that is not a real solution, you should be able to work connecting this speaker to your usb c port. The problem is the quality of this devices. If someone is reading this post, before to buy it. Please, don't buy this garbage. 

Userlevel 1

its defo not a real solution no, but yeah thats the only way i got around it, its a shame because im out of my warranty and they work great… when they work, but yeah unless i wanna part with the couple hundred i spent on them to buy something else, thats the best i have for now unfortunately🤣

I have the same problem and Razer does not offer a valid solution.

I have the same problem and cannot seem to get it working. Other sound devices work.

 i have the same issue since a year now , no veiled solution from Razer.

same problem… buy high end speaker for got problem only…. if u only replace the unit = useless.. 

Reply