Peripherals (Mouse/Keyboard) disconnect many times | Razer Insider

Peripherals (Mouse/Keyboard) disconnect many times

Show first post
This topic has been closed for comments

179 Replies

Had to uninstall synapse 3 because my mouse, mouse mat and keyboard keep disconnecting every 10 seconds. What´s the point then?
Been having this problem on a Blackwidow keyboard currently waiting for razer's dev team to get back to me ill update here if they come up with a fix
Update: I went to the store i bought the keyboard from and got a replacement and the new keyboard has worked perfectly. It might have been a hardware problem if you can still return it try and get it replaced
Thanks @HammerheadH but I don't think this is hardware issue as I use the same keyboard, mouse and mousepad in my macbook pro without seeing the mentioned problem just that synapse behaves bad in mac but the peripherals don't suddenly disconnect
I just bought my first ever Razer products, a Cynosa Chroma keyboard and Naga Trinity mouse. I also have the same disconnect problems everyone else is having. Happens randomly, sometimes every 30-60 seconds... sometimes goes 5 minutes before doing it again. Mine just makes the Windows alert sound and the keyboard and mouse go black a few seconds then come back online. This problem has been happening long enough to show me Razer doesn't care about their customers once they have their money. This should have been fixed long ago! Back to Walmart to return non working junk I guess because I won't go through the proper hoops like others have done in reporting it to Razer, only to still not have a replay several months later. What a joke.
ive had this same problem for a while and can confirm none of the above fixes have worked for me to this point
Hold up. I thought the newer USB ports (blue) would have more power than the older ones (black) which is why I had my keyboard and mouse plugged into the blue ones while having this problem. I figured before I take these items back to Walmart for a refund I'd try the older USB ports. THAT WORKED! I had problems every few seconds or minutes before with the keyboard and mouse losing power and going black for a few seconds, then coming back online. Since I plugged them into different USB ports they have worked flawlessly (for over a month now). So in MY case anyway, the keyboard and mouse do work fine, so it had something to do with the USB ports I was using... Hope you all find a fix!
USB 3.x (the blue one) does provide more power than the older USB 2.x (the black one). For some strange reason the Razer Huntsman Elite keyboard that I just got says it needs to be connected to USB 2.0. Most newer computers are coming equipped with USB 3.x since its the current standard with higher power output as well as higher data transfer rates. I find it funny that a gaming hardware company would design a new keyboard that needs to use an older standard that is being phased out.
i just started having this issue, my motherboard only has 2 rear usb2 and 4 rear usb3.

Cynosa Chroma plugged into USB2 as well as Deathadder Elite, Goliathus is in USB3. Keyboard randomly goes black and does not respond, Devicemanager doesn't show any yellow exclamation points when its disconnected either so windows thinks its still there. This has to be a software issue like many of these posts say. Come on razer.
also anyone else get like random turbo mode on a single key when typing? like i'll be typing something and the next thing i know there is 25 of the last letter i typed.
Also started having this issue recently. I have a Dell G3, so only three USB ports, two USB 3.1, one 2.0. When I have my 3 devices, Ornata Chroma, Lancehead TE, and Firefly, plugged directly into these ports, I have no issues. However, it got a bit annoying to have to unplug the Firefly anytime I wanted to use a flash drive, controller, etc. So, I purchased a well-rated, powered USB hub. Nothing but disconnects. My keyboard has disconnected 4 times so far just in typing this. The only "solution" is to turn off the ports on the hub and then turn them back on, essentially equivalent of just unplugging everything and plugging it back in. I'm assuming it's a Chroma issue, as the effects I'm getting are the same as all of those described in above complaints. In addition, I did have the hub, which is USB 3.0, plugged into a 3.1 port. After reading some of these posts, I moved it to the 2.0 port, as 2.0 ports seem to better support Chroma devices (for whatever reason). Same issues are present no matter what port is used, however. I've done all of the suggested things, including disabling the computer's ability to turn off devices for power saving both in the USB and HID sections of device manager. Currently, I have turned off Synapse, and I don't seem to be getting any more disconnects. It's just annoying to not be able to use the one feature these products boast, especially since the Firefly's lighting flickers any time the spectrum cycles to a shade of blue. Hopefully a fix is available soon. This is just plain obnoxious honestly.
I also have the same issue on a Lenovo laptop with a Lenovo docking station. I have an Ornata Chroma, a Mamba Tournament Edition and a Firefly Hard Edition. I am not a gamer, just liked the keyboard click and bought the mouse and mat for the "coolness" factor.


However, the user experience is awful. I have the same issues reported in the thread, tried the work-arounds suggested here and in other fora, opened a ticket with the Razer user support but at the end of three weeks email exchange I did not get a solution, only generic suggestions (update the OS, reinstall Synapse etc) and finally an invite to replace my docking station (it is brand new) or to connect the peripherals directly to the laptop. .....


In my very personal opinion, this might be a known issue, possibly limited to a relatively small number of users, which they do not intend to fix especially if this possible "non-standard" use of the USB protocol is what actually enables the majority of systems to work as they do.


A short update: the docking station has been replaced. Due to another, independent issue the laptop mainboard has been replaced as well.

Same keyboard, the problem keeps occurring. Also the problem must be in the Razer hardware or in the drivers.

I am still convinced that the issue must lie in a "non-standard" use of the USB protocol which allows the magic and does not give any problem to 99% of the systems under typical conditions.

Such problem could also lie in the Razer hardware itself - could it be a USB controller embedded in a certain series of Razer peripherals which could be defective, or not working as expected under certain circumstances. Could also be a compatibility problem with the counterpart USB hardware on the PC side.

In any case, I guess we'll never know...
Currently, I have turned off Synapse, and I don't seem to be getting any more disconnects. It's just annoying to not be able to use the one feature these products boast, especially since the Firefly's lighting flickers any time the spectrum cycles to a shade of blue. Hopefully a fix is available soon. This is just plain obnoxious honestly.

I also confirm that killing all the Razer "management" :big_grin_: software decreases significantly the frequency this issue occurs.
Anybody knows to solve? Also for me all peripherals disconnect many times (every 30 seconds) on laptotp and desktop with a usb switch. The problem appears only when synapse is installed
So i have these problem a year ago, random disconnection every 30sec to 5mins. I found out that many razer accessories is not compatible using usb hub/switch, even using their own usb hub which is razer rgb headset stand it doesnt work. For them to function perfectly they need to be inserted on the main usb slot of the motherboard or laptop. Trust me bought dozen razer accessories includin mouse, keyboard, speaker, headset, mousemat, mousepad, keypad and webcam. They all need to be inserted direct to the main usb slot, using usb hub/switch they wont work properlt, even it its connected to thunderbolt or using usb hub powered.

Since i cant use them all together, i ended up replacing them with different brand and they all work together now.

Heres my rig now. No random disconnections and all of them connected to laptop using usb hub powered.
Anybody knows to solve? Also for me all peripherals disconnect many times (every 30 seconds) on laptotp and desktop with a usb switch. The problem appears only when synapse is installed


I returned my keyboard from where i got it and got a new one and the new keyboard works fine. It seems to be a hardware issue with the keyboard
Had this problem for so long! If I exited out of Razer Synapse the disconnecting problem went away, however this defats the purpose of owning this stuff if I can't use all the cool features. I eventually found a solution that worked for me. I plugged in my Blackwidow V2 Tournament Chroma keyboard and my other Razer periphs into the available USB 3.0 (and 3.1) inputs directly into the back of my PC and the disconnecting problems vanished! It appears some of these products either need more power or bandwidth (not sure) than USB 2.0 can support sometimes. Hope this helps.
In my opinion it's cause is faulty Razer software or some kind of incompatibility of the software with some of the USB controllers.

My main OS is Linux in which I use Openrazr to control lighting etc and never had a single issue with any of my Razer hardware.
I use Windows occasionally for gaming and usually have to turn off Razer Central to get my mouse and keyboard stable. Everything is plugged directly to USB 3.0 ports on the back of my motherboard. I have no other USB peripherals plugged in.

My hardware: BlackWidow X Chroma (white), Lancehead Tournament Edition (also white) and Goliathus Extended Chroma. Mobo is Asus X99-S with 1200W SuperFlower power supply - including that to discard any claims about not having enough power on the USB ports.

If anyone from Razer wants to troubleshoot this properly - I'm willing to do that. Just contact me directly
Userlevel 7
Same problems occurs to me with Msi laptop and razer chroma stand, but I think its chroma/synapse issue. Cause if I`m using static lightiing on my stand/naga/firefly everything is fine, but if I try to switch to some even basic effects disconnects start to occur.
Same problem here, looking high and low for solution for years.

Using BlackWidow Chroma V2 and razer mouse

Using Razer synapse vs

Razer devices keep disconnect and reconnect. Wouldn't be buying Razer keyboard any more, cursed product.
I recently did a full reinstall of windows and this issue has started happening since. I have had both a software developer and a hardware developer (colleagues) look at it and they have both concluded that the razer software itself (and/or drivers) are at fault.

Considering how detrimental this issue is, it's quite concerning that there has been no fix or confirmation from razer yet.....
Wanted to post an update of sorts here. Since my last post a few months ago, I have been solely using Synapse 2. Zero disconnects. This is clearly a Synapse 3.0 issue, so I would avoid using that for now. Only drawbacks are limited customization compared to 3.0, but hey, I’ll take working devices over that any day. I currently have my Ornata and Lancehead directly connected to my USB ports, with my Firefly connected to a USB hub. One Chroma device per port seems to work the best, and I have 4 other things connected to the hub with no issues (unless I try to use an external hard drive but that’s another story). The fix that works for me is Synapse 2. Not sure if it’s universal, but I thought I would share.
I only use razer orbweaver, it disconnects randomly, and when this happens, I'm in shit, because even when changing USB port the Razer ORBWEAVER forgets the macro, and only a restart the reconnect to the razer cloud.
it's been 2 years that this hard .. rzer wake up.
ps; sorry for my basic english
I just rifled thru all the USB settings and turned off the power management feature mentioned earlier on in this thread, and the problem seems to have vanished. I do have my BlackWidow Chroma plugged into the primary USB ports on my mobo.

edit: spoke too soon. still does it, albeit a little less.

Chiming in to say - exact same situation. Blackwidow Chroma Keyboard, FireflyV1, and I have both a Razer mouse that's corded and cordless.

Can't use any of them on any USB hub, be it Razer's own, or any mid to high grade USB hub. Gaming laptop I have has only 2 USB ports, so if I wanted to actually get use of my Razer products I had to sacrifice all other components. Ridiculous.

This has been a known issue for well over a year at this point.

So that means if I wanted to use my other components, like USB DAC, HD Webcam, etc; I literally had to go buy non-Razer products just to compensate and be able to use the USB hub.

I wound up putting my Razer stuff on my Mom's PC, and stuck with the new stuff bought. I can't see a reason why I'd want to buy Razer again in the future at this point. Obviously it's something they can't, or don't care to fix, despite the issue being completely software/firmware based.

None of this used to happen pre Synapse 3.
So, I believe I just solved this issue.

Then I went to the power management and usb settings and disabled the "usb selective suspend" for both on battery and plugged in.

This alone fixed my issue. Thank GOODNESS you figured this out!