Synapse not reconizing devices | Razer Insider

Synapse not reconizing devices

  • 2 February 2019
  • 58 replies
  • 401 views

So I have a Naga Trinity and a Black Widow chroma v2 and my synapse just recently stopped detecting them. They still work the lights cycle but they are on different timings and there is no why to sync them with each other in synapse. If anyone has any idea how to fix this it would be great! Thanks in advance.

This topic has been closed for comments

58 Replies

Userlevel 7
Did you try to unistall and reinstall synapse ?
Аfter the last update, the Synapse 3 application stopped detecting all my Razer hardware. I have Nommo Pro, Deathadder Elite, Firefly, Chroma HDK, Nari Ultimate, Base Station Chroma. Before that, everything worked fine. Reinstalling the application did not help.
I also uninstalled synapse and it did not change anything.
Userlevel 7
I assume you uninstall every razer softwere not just only synapse 3 and delete the files in appdata and programfiles ? You can try to go to device menager and one by one remove device and unplug it when everything will be remove and unplug reboot pc and when windows boot plug one by one this way windows will download and install device driver.
i installed and uninstalled my synapse and until now it not detect my blackwidow as well ...
just can detect my Deathadder and Kraken ...

im done with it so i dont do the setting to my keyboard ..
I have completely removed the Synapse 3 software. Manually deleted all Programm Files, Temp, AppData.
Disconnect all my hardware, than plug only Deathadder...nothing happens.
Аfter the last update Synapse 3 stopped detecting all my Razer hardware as well... (Cynosa, Abyssus, Goliathus).
After the lat update, my Razer devices keep disconnecting and connecting randomly.
Den_ver
I have completely removed the Synapse 3 software. Manually deleted all Programm Files, Temp, AppData.
Disconnect all my hardware, than plug only Deathadder...nothing happens.

I did the same and also it not help.
my devices are also not connecting after this last update
Still no answer from support? Not fun...
yea I'm starting to wonder why i pay a premium for these peripherals.
Userlevel 7
Try to remove razer devices from device menager menager in windows to force driver reinstall. When you remove device from device menager unplug device then reboot pc and plug back.
BlackFireDragon
Try to remove razer devices from device menager menager in windows to force driver reinstall. When you remove device from device menager unplug device then reboot pc and plug back.

Thats not helping, im start to think it is related to windows 7, but im not sure.
Why don't give us standalone installer of previous version Synapse 3 ???
Userlevel 7
Neozgred
Thats not helping, im start to think it is related to windows 7, but im not sure.

Can you connect your devices to difrent pc and cheack if the issue is also there ?
greatGARNET984
Why don't give us standalone installer of previous version Synapse 3 ???

First of all synapse 3 is a beta softwere older versions have many bugs so the new is always more stabile then previous. Installer of synapse also works as downloader with get the current version of softwere from razer server.
Anyone found solution for this? I can not get any of my devices to work on any Windows 7 PC that i have. Every time its ends like on that screenshot that I and that other person post before. For me its looks like drivers do not installed properly and nothing can be done about it. Even on clean windows 7 installation is the same.

Before update i had a lot of problems with that software but at least i could change colours, now i can not change anything and my computer slowdown at start for 2 minutes.

For now i unistalled all Razer software, thats the only way my pc running fast like always, im waiting until there will be some software update.

i7-4790, 16GB RAM, GTX 1080, 240GB SSD.
No solution, no answers...absolutly nothing.
Yea mine is still not working either. Well the way its going when I replace my keyboard and mouse I will be getting someone elses product. 😞
I started new topic under support section:

/synapse-3-not-reconizing-devices-under-windows-7.46942/
Kenserky
Did you try to unistall and reinstall synapse ?

да тока у меня проблема с razer kraken pro 7.1 программа synapse 2.0 перестала видеть ее переустанавливал пару раз все четно
I am absolutely disgusted by what's happening , been a razer fan since the diamondback series and this was my week back into the game with some new gear, Blackwidow Chroma Tournament V2 and Naga Trinity ..

Imagine my surprise the keyboard can be seen and only works on synapse 2.0 while the Naga Trinity ( which i replaced today coming from the Naga 2014 which still works awesome under synapse 2.0 ) cannot be seen at all in synapse 3 or synapse 2 alongside the keyboard. After 20 OS resets and reinstalls and CC cleanups I just gave up.

Is this what razer has become ? I literally wanted to go tomorrow and refund all my gear but after reading this forum idk what do anymore wait it out or just be done with this company...

P.S running on Windows 7 , x64 , Ultimate SP1. which truly seems to be culprit.
is anyone having problems login in to synapse I've created 3 accounts already and no luck, I also uninstalled and reinstalled.
Toland84
is anyone having problems login in to synapse I've created 3 accounts already and no luck, I also uninstalled and reinstalled.

I can't log in either. I can log in and change info/password just fine on the RazerID site, but when I try to log into the Synapse software so that I can re-sync my peripherals, it just gives me the stupid 'Oh Snap' error message. :|
Is the DeathAdder Expert able to changed colors, if not does any one have a close date to when it will be added to synapse 3