Leviathan V2 subwoofer not working | Razer Insider

Leviathan V2 subwoofer not working

  • 25 December 2022
  • 6 replies

Just got my Leviathan V2 with the subwoofer and got it plugged in and everything, but you can barely hear any bass coming from the subwoofer. I've seen online that the THX driver that automatically gets installed causes an issue with it work, so I uninstalled that, but nothing. Also saw the Synapse causes an issue with the subwoofer working also, so I uninstalled that, and it still doesn't work. I can put my ear up to it and I barely hear sound coming from it. Any thoughts?

6 Replies

I’m having the same issue. It just started this evening. I’m getting frustrated with the whole thing. It hasn’t worked properly since Feb 16th. I’ve been going back and forth with Razer support and they just want me to send synapse logs. Whatever happened to tech support staying on the line with you to help.

Same. My subwoofer has no sound, but I can see the vibration. I'm thinking that it's a driver issue. No idea how to fix it

The way I was able to get it working was to disable and uninstall all the speakers through device manager after running the audio trouble shooter.and I didn’t reinstall synapse. Good luck 

Just try one thing you could try is checking the connection between the subwoofer and the main unit. Make sure the cable is securely plugged in on both ends and that there are no loose connections.

If the connection looks good, you may want to reach out to the manufacturer's customer support for further assistance. They may be able to offer some additional troubleshooting steps or even a replacement if the subwoofer is found to be defective.

I figured out a solution. It may or may not work for the rest of you but uninstalling Razer Chroma did the trick for me. The subwoofer straight up wasn’t connecting for me so I decided to repair Chroma and during the repair process, the subwoofer reconnected at full volume but once Chroma was done repairing it disconnected. I decided to just uninstall it after that. I wasn’t a big fan of Chroma to begin with

Extremely disappointed.  I FINALLY got my Leviathan working with the Synapse… THX Spatial and all that jazz… But I should have just saved my money for the X version that doesn’t come with a sub since this one doesn’t even push out to the sub at all!  It’s like it wants the bar to be the sub, and that’s not what I spent my money on.  This is a driver/software issue.  If Razer doesnt want to fix, then I doubt that I’ll by the Nommo Pro V2 especially if it is THX Spatial.