My Razer Nari only works on the right side ( no sound on the left side ) | Razer Insider

My Razer Nari only works on the right side ( no sound on the left side )

Userlevel 1
Hi, i just got my Razer Nari Wireless today. i realized that my left ear didnt produced any sound when i plug in my wireless usb + aux 3.5mm chord. I already check the Left and Right volume on the sound, but still not working. i also tried to use 3.5mm aux chord with my phone. still only the right side that produced sound. the left still dead quiet. Do you guys have any suggestion what i can do to fix this?

**PS* this is my first expensive gaming headset.

my Razer Nari only works on my right side. (left side dead silence)

This topic has been closed for comments

31 Replies

Bro, I punched the earcup from the inside and the outside and I swear it just started working, I had this problem for months but razer never helped, thank you so much holy crap

literally spent 4 hours trying to see if the software on my computer was the problem and this worked in no time at all wtf
OMG above answer about punching the air cup worked! I'm not kidding.
It just got wrong suddenly and now reading at this forum found the solution.
Para los que son hispanos. Prueben con palmar las almohadillas del audifono que no funciona. haganlo suave o fuerte con los dedos y se va a arreglar!. Me acaba de solucionar a mí
Bro HAHAHA thank youuuu, you were of better help than anyone, I punched the not working earcup from the outside and it started working.

this fixed it for me, thanks.
I got this problem probably two weeks after I got them I looked around and found that you could punch the left earcup that had a problem... It worked. Two years later I probably punch them every time I use them and it works. Wierd how it works perfectly on the right side tho something very weird.

Can someone help me because I am having the same issue with my Razer Nari and I am working on apkarc so perhaps that's why it's not performing well because normally it works fine.
Ok but why does punching it fix it? I tried out of frustration and it did indeed work. I just want to know why.
Just spent an hour trying to fix it, and not recommending this, but I got desperate and knocked the left outerside inwards and it must have set something back in place because it started working again.

I saw this and started to knock on the inside of it and it started to work again? maybe a pin can get loose or something idk but the most stupid answer worked thanks OP