Unable to connect Razer Basilisk X Hyperspeed using bluetooth? | Razer Insider

Unable to connect Razer Basilisk X Hyperspeed using bluetooth?

Show first post
This topic has been closed for comments

32 Replies

I am also having the same issue and the BT function is not working and my both computers Bluetooth at home cannot detect the mouse Bluetooth. Please help! thanks,
I got the mouse about 2 weeks ago and it worked perfectly fine. yesterday I tried to connect it to my pc using Bluetooth and it kept saying to try connecting again I tried to connect it with my mac and same thing it just would not connect. I tried to replace the battery with no success and updating the firmware. nothing worked. 2.4 works fine but no matter what I do it just won't connect using BT. can someone help please?

Same issue with mine! Cannot discover by computer Bluetooth.
Same issue of the bluetooth connection in my 3 windows devices(two win7 and one win10), cannot pair or found by windows.
However, it works alright when I tried to paired with osx of my macbook air(which is same hardware of win7 is installed but cannot pair) and android phone, it is weird.
I have been utilizing the remote connector and it has been working fine this while yet yesterday it unexpectedly quit dealing with remote connector and must be utilized on bluetooth upsers.
I'm also having same issue for the bluetooth (Razer Basilisk X Hyperspeed), It showed paired inside the pc bluetooth setting but blue light signal never stop blinking and keep jumping between "paired" and "connected" mouse point cant even move.

Please looking into this issue and solve it. This is the 1st time I bought Razer product, hopefully razer response it , otherwise,it will be the very worst experience to me and not going to have others razer product for the next time.
I also am having the same issue with the bluetooth mouse. I can see it's paired fine, but then I can get it to pair when pressing the three buttons. The blue light never stops blinking twice.
Hi i have the same problem. Already contacted support, without any response.
Basically I cant even enter the pairing mode.
I also realizedthat when you update the firmware you have to update two seperate parts:
1. the 2.4 Ghz mode (which can only be done while in this mode)
2. the bluetooth mode (which sadly can only be done while the mouse is connected to the computer via Bluetooth)
This does seem like a very obvious issue to me (since I need to pair it via bluetooth to fix the problem which stops me from pairing via bluetooth).
I can see that its been a while since you posted this. Have you found any solution?
Thanks a bunch.
Ps. razer please look at this thread. It seems to me that this is quite a common problem as ive also seen other people mention it.

Also I should say that the mouse doesnt help me at all in 2.4 Ghz since I bought it specifically due to the lack of USB ports on my laptop. If I can/t find a solution I will probably need to return it within the next week.