FIXED :: Blade 17 - external monitor via USB-C/Thunderbolt 4 not working

Discussion in 'Systems' started by Ribsletics, Jul 6, 2022.

  1. ScottySTL

    ScottySTL New Member

    That is the model I have (or rather just had). Shipping it back to Amazon tomorrow. Let me know if any of you guys get any resolution to this....
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I've checked your case. The investigation is still ongoing, and the team is coordinating with our Internal Team/devs regarding the laptop's behavior. I've cascaded this thread to the team. Hopefully, a resolution will be available as soon.

    Can you send me your case number so I can tap our Support Team?

    Please submit a case too so we can collate all the users that are experiencing this USB-C port concern.
     
  3. What is the schedule? I can't use my computer until then. I absolutely need a second monitor and that is really not a special requirement. Especially not for a 4,600€ notebook. If there is no immediate solution here, the notebook will go back within the return period.
     
  4. ScottySTL

    ScottySTL New Member

    I heard back from Razer support, but they want me to go through the stupid stuff like I am a non-technical idiot (after I told them I repair laptops for a living).

    They said the following:
    "
    Though you may also check our support page link that may help fix the issue on the laptop

    * https://mysupport.razer.com/app/answers/detail/a_id/1802/~/how-to-connect-multiple-monitors-to-a-razer-blade-laptop


    We just want to set your expectation that this laptop model does not yet have any BIOS update created since this is a new model release. No worries our product developer team is aware of this matter and is working hard to be able to generate one in the future though.
     
  5. Cranberry307

    Cranberry307 New Member

    I'm having this issue as well. There seem to be very brief, occasional flickers where it seems like the connection is working, but it never lasts more than a second or so.
     
  6. I am not taken seriously by support at all. I was now asked if I can connect my monitor via HDMI..... I will now return the notebook. And I would recommend that to everyone here! Extremely poor performance from razer.
     
  7. Cranberry307

    Cranberry307 New Member

    Razer.Speedcr0ss likes this.
  8. ScottySTL

    ScottySTL New Member

    Wow, yeah that is terrible
     
  9. ScottySTL

    ScottySTL New Member

    Ribsletics likes this.
  10. Ribsletics

    Ribsletics New Member

    Got it working!!! The support rep told me to uninstall my latest drivers. And roll back to version 512.95 or lower. I am asking him when it is OK to update my drivers for game ready drivers and such. Will let you know when he replies! =)
     
  11. Ribsletics

    Ribsletics New Member

    Rollback your NVidia driver to version 512.95 or lower. This worked for me! =)
     
  12. Ribsletics

    Ribsletics New Member

    Rollback your NVidia driver to version 512.95 or lower. This worked for me! =)
     
  13. Ribsletics

    Ribsletics New Member

    This is the ticket! Rollback your NVidia driver to version 512.95. This worked for me! =)
     
  14. Ribsletics

    Ribsletics New Member

    Rollback your NVidia driver to version 512.95 or lower. This worked for me! =)
     
  15. ScottySTL

    ScottySTL New Member

    Damn, which I knew that before I shipped back my unit...oh well
     
  16. plakstra

    plakstra New Member

    I can confirm that downgrading to 512.95 or older DOES WORK!!
    So I don't know if it is a razer exclusive problem or a Nvidia thing. But hopefully it will get fixed asap.

    P.S.
    I'm using the Razer Thunderbolt 4 Dock with my RZ09-0423x NED3-R3E1
    on the Alienware AW3423DW. happily I am able to use a Thunderbolt 3 to DisplayPort 1.4 cable.
     
    Razer.Speedcr0ss likes this.
  17. It also solved the problem for me but it would be better use the newest driver. When will Razer solve the Problem completly?
     
  18. BudgeMagraw

    BudgeMagraw New Member

    None of these downgrades seem to work for me? Am I missing something?
    I've been doing a clean install of the graphics driver, and tried a few different versions....still no USB-C video from Thunderbolt 4 on the Razer Blade Pro 17..?
     
  19. BudgeMagraw

    BudgeMagraw New Member

    **FIXED..!!**
    Spoke to the lovely chap at Razer Store in London, and he suggested a BIOS update for my 2021 Blade 17 Pro, and I updated from BIOS version 103 to 106 and it worked..!!
    So, I'm running latest Nvidia drivers, latest Thunderbolt 4 drivers, latest Synapse and this BIOS update was the final key to the mystery :))
    USB-C Touchscreen now works on Thunderbolt 4 port with a single cable.
     
    Razer.Speedcr0ss likes this.
  20. uncleropeadope

    uncleropeadope New Member

    Reporting the same problem.

    Blade 15 12800H + 2080ti.

    • Connecting to the Thunderbolt 4 Chroma dock using the supplied Thunderbolt 4 cable (Right side, Port L, per the manual, I believe).
    • 1080p monitor connected to the dock with a Thunderbolt-to-hdmi cable.
    Worked for a few weeks, with the exception that it only pushed the monitor at 120hz and not 240.
    Then the usb dongle for my wireless mouse completely failed and is no longer recognized on any computer.
    Then the monitor stopped being recognized unless I connected the dock to the USB Gen 3.2 Type C port (Q) on the other side.

    Will open ticket soon. I really hope this is something that can be easily resolved. Beautiful laptop, but can't keep it with a Thunderbolt 4 port that isn't fully functional, per spec.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >