Huntsman mini broke my windows

Discussion in 'Razer Support' started by aaccensi, Nov 11, 2020.

  1. wizezjj

    wizezjj New Member

    O my good!!! I am a really happy, I have this problem for months with amd cpu ( ryzen 3600xt ) but with my old pc I have zero problems ( intel )
    Now I am fine, this fix the issue for me, thank you and thanks razer!!
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for confirming! I'm glad that it help. Cheers.

    Hi @polyKenyanCopperclub810. Please send me a PM as I need to get details from your computer so I can send it to our Support Team/devs.
     
  3. santivander

    santivander New Member

    Hi. Ryzen system here but using b450 chipset, so not related to AMD recent issues. Also never had an issue before having this keyboard
     
  4. Riskerino

    Riskerino New Member

    Sad update from my side. The keyboard worked flawless for 2 days with the new firmware 1.12 but has now again problems with e.g. the key P and G not being recognized at all or lagging behind.
    I changed the USB port, reinstalled Synapse driver (could not reinstall the firmware though) checked for new Windows update - nothing worked. I unplugged the keyboard and tried it on my laptop. Worked perfectly there.
    I plugged it back into my AMD PC and it worked fine for the first minute! Then the issues returned.
     
  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    That's noted, santivander! Please send me a PM as I need to get information from your keyboard, computer, and the Synapse logs.

    Thanks for sharing Riskerino! Sorry to hear that the firmware didn't fix the issue for your setup. Please send me a PM too.
     
  6. thewanderer521

    thewanderer521 New Member

    Blackwidow V3 here with same issues

    TR 3970x
    Strix TRX40
    Win10 latest build

    Hope to get a fix soon
     
  7. ChillyRide

    ChillyRide New Member

    Guys need some feedback. Does anyone, during playing, expirience rare random key stuck? Im trying to reproduce it but its very rare, character moving in 1 direction, like Im pressing W key, pressing another button fix this.
     
  8. Yeah i have similar issues, sometimes some keys just wont work.
     
  9. retroAlmonddaily823

    retroAlmonddaily823 New Member

    Works for me too
     
  10. Yep getting occasional certain keys not registering on intel 8086k setup. The firmware change helped but it did not fix everything.

    Its also not a mechanical issue with the keyboard because the keyboard can work fine when plugged into new systems for a while.
     
    Last edited: Feb 28, 2021
  11. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! Thanks for the feedback. For those who are still experiencing the issue, please send me a PM together with your computer's Razer Synapse 3.0 logs. Ensure to save the files via Google Drive or to any online drive and paste the shareable link in your message. Also, for those who are non-AMD system users, refrain from installing the firmware as it can brick your device.
     
  12. jamji

    jamji New Member

  13. marthofdoom

    marthofdoom New Member

    I experienced unexpected behaviour with the new firmware. Previous issue was definitely gone, however I still experienced system lockup after some time. I have submitted most recent logs using synapse, and have unplugged keyboard and stopped synapse form running to test if it is indeed the keyboard that has caused it.
     
  14. MattF1

    MattF1 New Member

    Anyone else come across an issue following updating the firmware where the fn keys are not registering the fn function when clicked? Eg the left arrow key when pressing fn inputs a j rather than moving left
     
  15. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi marthofdoom! Do you have a support case number? Feel free it to me via PM so I can check its updates.

    Hey MattF1! Are you using a system with AMD chipset and Razer Huntsman Mini? Please send me your computer Razer Synapse 3.0 logs via PM. Ensure to upload the files via Google Drive or to any online drive, then paste the link in your message.

    Hey santivander! Which switch version does your keyboard use? Is it the linear optical switch? Please send me your Razer Huntsman Tournament Edition's serial number together with the computer's Synapse 3.0 logs and upload it via online drive just like the steps I mentioned above.
     
  16. van_streek

    van_streek New Member

    I have the same problem with my Huntsman Tournament Edition. Is there a firmware fix available for my keyboard as well?
     
  17. MattF1

    MattF1 New Member

    Thanks for your reply, you should now have a PM from me. If you need any more info or later logs seen as I've had both the issues again today please let me know :)
     
  18. yamilsze

    yamilsze New Member

    Same situation here, opened RMA case yesterday at my local reseller, because we don't have official Razer support on Argentina.

    In my case, It's a Huntsman Mini w/Purple Switches. Explorer taskbar was fixed after firmware upgrade but I've repeatedly noticed sticky keys or multi keys registered or even none keys registered when pressed.
    It's very annoying because I mostly use this keyboard to competitive csgo, I'd to change back to my old blackwidow keyboard :slightly_sad:

    Any assistance you can provide would be greatly appreciated
     
  19. ChillyRide

    ChillyRide New Member

    I think we all have this issue for now. I can confirm having smth like that to. waiting for another fix.
     
  20. So I join the club, I got a Huntsman Mini from Razer official store in Mercadolibre (which is like a latin ebay), as soon as I plugged the Mini the taskbar froze, keys I and O don't work, randomly they start working, some days they do some they just simply don't register. Plugging this thing makes my PC go crazy, I also have an AMD CPU.

    I tried all the steps Razer provided but did not work. Now the store does not want to honor the warranty and now I have a beautiful paperweight.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >