Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Kraken Tournament Edition - THX Spatial Audio not working.

Discussion in 'Audio' started by Davidier, Feb 14, 2019.

  1. Davidier

    Davidier New Member

    I've already chatted to a representative on support, and after everything he/she has offered to help with, nothing worked.
    I've tried every solution on the internet including his support, and he eventually said I should get a replacement since it was from Amazon... It arrived today and to no avail, THX is still not working.

    I've done everything in the book and looking for any advice, I've already tried restarting, reinstalling, plugging into another USB, resetting my PC, it just isn't working.

    It worked before and to be honest I really don't want to return them... Not after I experienced the difference between normal stereo & THX.

    [​IMG]
    I have Chrome and other Apps open that can use THX yet it's not displaying.
    EDIT:
    Also, none of the other equaliser options, voice clarity, sound normalisation works
    It works on other PCs, namely my laptop
     
    Last edited by a moderator: May 15, 2019
  2. TediousTasks

    TediousTasks New Member

    Same issue here. It worked at first so I'm assuming it's an issue with Synapse still being in beta.

    I really wish I would have known that they wouldn't even support this device in the OG Synapse. Mic issues galore and now this. The whole reason I bought it was for the THX Spatial Sound.

    By the way, if you're having any issues with the mic crapping out, I found that if I turn it all the way down to 32000Hz keeps it functional. I still have to toggle the mic sensitivity any time i wake the computer though. Super annoying.

    Report back if you find a solution to this issue. It's driving me crazy.
     
    RuggioShaggy and pancholr like this.
  3. 0V3R_K1LL

    0V3R_K1LL Well-Known Member

    Try uninstalling Synapse using CCleaner so it removes all registry edits. Also uninstall the driver for the headset inside device manager and plug it back in so it installs the driver again. Then install Synapse to try again.
     
  4. ItzD3Lux

    ItzD3Lux New Member

    Try uninstalling Synapse using CCleaner
     
    pancholr likes this.
  5. BlackFireDragon

    BlackFireDragon Well-Known Member

    You can try few things first is create new profile with factory settings and see if work but remember to turn on THX and then player or webbrower sometime synapse have issue with recognize the app for THX. If you still have issue try to remove all razer softwere from your hard drive them go to appdata nad programfiles delete all files that stay after uninstall go to device menager remove the headset unplug and reboot pc when windows start go to razer website download new freash installer for synapse 3 and install just this next thing is plug the headset when everything will be ready reboot one more time pc to make sure changes are save and load. Try one more time and write back here if this help.
     
  6. directMiddleBlue659

    directMiddleBlue659 New Member

    I am having the exact same issue on my new Kraken TE headset. I will try these suggestions and report back. If it doesn't work, I suppose I'll attribute it to an issue with the Synapse software and wait for a fix.


    No joy. So I guess I wait for them to fix the Synapse 3 software.
     
    Last edited by a moderator: May 15, 2019
  7. ihebzv2

    ihebzv2 New Member

    hello guys , i just got mine a week ago it was working fine this happened same issue just like you i did everything ccleaner and every single method you can possibly imagine but still with the same issue , i guess i will have to use it without the razer synapse 3 :slightly_sad: feelsbad no EQ no THX no Mic settings just the Default .
     
  8. directMiddleBlue659

    directMiddleBlue659 New Member

    Synapse updated a couple days ago on my computer to version 3.4.331.31119. THX Spatial is still not working. **sigh**
     
  9. puggyy1

    puggyy1 New Member

    still same...

    its been 3 months since this post opened still doesnt work
     
    Last edited by a moderator: May 15, 2019
  10. beerwithbatman

    beerwithbatman New Member

    You have to go to windows sound options, right click on your headset, and turn on windows spatial sound as well.
     
    DRIFT_IT likes this.
  11. puggyy1

    puggyy1 New Member

    nothing changed.. still the same
     
    DRIFT_IT likes this.
  12. EmulatorsParadise

    EmulatorsParadise New Member

    I'm having the same issue just worked the night before. shut down my computer and turned it on today and now nothing when using thx spatial through synapse
     
    kekelokki1981 and 0V3R_K1LL like this.
  13. TediousTasks

    TediousTasks New Member

    Somewhere between updating to Windows 10 1903 and the latest Synapse update resolved this issue for me. Applications are now listed again and I can toggle surround settings.
     
  14. This worked!! Thanks my dude, it was so annoying not having it for a few weeks.
     
    dspBuckle likes this.
  15. God_Haplo

    God_Haplo New Member

    I am getting and error code 10 on my Windows drivers for the THX Spatial - Synapse. Tried every single method with no avail. Mic and audio works 100% but as soon as Synapse is up and running sound works 100% but no Mic.. Nothing. even doing mic tests does not work. Any advice?
     

    Attached Files:

  16. MattyIce598

    MattyIce598 New Member

    Hey guys so I don't know if this will work for yall but I have tinkered around with this for quite some time and I simply plugged the usb controller into a usb 2.0 not 3.1 and everything seems to work just fine
     
    dspBuckle, jenniefurrrr and ZeddBread like this.
  17. innerperception

    innerperception New Member

    Hello,
    If you are still having this problem I have the solution.
    Open up Razer Synapse 3.0 and click on the RAZER USB AUDIO CONTROLLER.
    Go to Mixer and there should be a list of apps. Go down a bit until you see Set as default. Go ahead and click that option and your audio should be back to normal.
    Hope that helped.
     
  18. erm I don't know if this is going to help anyone,but apart from the clean reinstall what worked for me is go to the sound settings on playback and on the Razer Kraken TE-Game i changed the default format from 24bit-96000Hz to 24bit-48000Hz.Is that a bug? How can increasing the Hz bug the spatial audio?
     
  19. Kaelath

    Kaelath New Member

    If I set mine to 48000Hz zero sound is produced by the headsets, if I set it to 96000Hz I get sound but it won't allow 7.1 to be tested in the configure section of windows settings. I'm honestly sick and tired of having all of these issues ALL related to Synapse 3 and it's software, I'm also sick and tired of the developers working on the software being extremely lazy and not even bothering to fix the products they're supposed to be selling to consumers and just praying people repeatedly buy new shit.
     
    Last edited: Oct 12, 2019
  20. TheOldGregg

    TheOldGregg New Member

    I haven't been able to get 96000hz to work but I was able to get spatial sound to work at 48000hz. Go to:
    Audio devices>Properties for thx spatial speakers>Spatial sound>Windows sonic(or whatever you may use)>Apply. Be sure to use the USB dongle and shift it to gaming as far as you can. For some reason this worked, even though I enabled windows sonic from the playback devices. Applying it through the sound manager seems to be the trick.
    Screenshot for convenience. Let me know if it worked!
     

    Attached Files:

Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >