Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Blade Pro 2020 can't update Nvidia drivers

Discussion in 'Razer Support' started by nyichiban, Jun 23, 2020.

  1. nyichiban

    nyichiban New Member

    Can't update it and tech support has no clue how to get this fixed. It is going to be escalated. Let's see how long it takes to get this resolved.
     
    4K2HD, sleekspot921 and pancholr like this.
  2. autoFawnPERIDOT525

    autoFawnPERIDOT525 New Member

    I second this, i finally got the DCH 451.58 notebook drivers to install, and now i can't use my laptop screen at all when not in optimus mode. Really need a tech to address this.
     
    pancholr and 4K2HD like this.
  3. nyichiban

    nyichiban New Member

    I reached out to razer via reddit and they said they will look into it. Apparently there was an email sent to me on the 23rd of June to help troubleshoot but that email never got to me. I use gmail and there wasn't a server outage so....
     
    pancholr and 4K2HD like this.
  4. kevinjohnwimberly

    kevinjohnwimberly New Member

    I third this. I have done a lot of discovery for why this is an issue. The video is unique in that Razer owns the hardware ID, since it was pieced together by their engineers, so that ID is not within the driver packages from NVIDIA. I have called, tried chat, and actually have an outstanding ticket in with Razer with no response. I have no idea how often Razer submits their driver package to MS for Windows Update for us to get the drivers, but that method is SO inefficient we will never get the latest DX 12 optimizations. I have even tried hacking the INF to program in my hardware ID to force it to install, but it didn't work, and it is likely good that it didn't work since their drivers fine tune how the entire laptop works in symphony with the all components. But this is super frustrating given that this is a very top end, expensive laptop and their are no current driver updates supported on it.
     
    Jeffyu82 and 4K2HD like this.
  5. autoFawnPERIDOT525

    autoFawnPERIDOT525 New Member

    What sucks is the HWID exists in the 451.58 DCH drivers, so it does install. That's great and all but you lose access to the laptops 120hz display when in dedicated GPU mode.

    I went back to 446.14 by just instaling the inf manually and forcing it with devmgmt have disk install for both the gpu driver and typ c driver then just installed the control panel. The drivers seem stable, but it's kinda a shame.

    I'm all about being an enthusiast and having to do some heavy lifting for good perf from time to time, but this is a bit rediculous.
     
    4K2HD likes this.
  6. nyichiban

    nyichiban New Member

    I'm 2 days away from my return window for this. I guess if I don't get a resolution from them then I'm just going to return the laptop.
     
  7. nyichiban

    nyichiban New Member

    success!!! So i figured out how to get it working on my razer blade 15! Now I'm about to try it on my Razer Pro 17. But these are the steps I took:
    1. Use DDU to remove the drivers and make sure you tick the box that stops windows update or windows to auto search the drivers and remove the DCH control panel needs to be ticked as well.
    2. Reboot and when back in download the geforce experience app from the nvidia site it iis the one called automatic driver update with the download now beneath it.
    3. Once the nvidia experience app is installed then it will automatically download the latest drivers and I chose express install and now it is working on my blade 15!

    Update: same steps didn't work on my blade pro 17 2020....
     
    Last edited: Jun 25, 2020
  8. nyichiban

    nyichiban New Member

    The latest update from Razer supprt is that since I upgraded to windows 10 pro from windows 10 home that I need to talk to microsoft about why the nvidia drivers are not updating..
    https://imgur.com/u7id8WG
     
  9. Dekades

    Dekades Community Cowboy Staff Member

    Hey folks, this is being looked at. I don't know specifics and there are no details to be announced, but this is being investigated. Thank you for your patience.
     
    ssipster and JulianKapa like this.
  10. nyichiban

    nyichiban New Member

    Well won't be having this problem anymore as I am on my way to the store to return it. Shame because it's a really well built machine but customer service saying it's on Microsoft now since I updated to windows 10 pro. You have lost me.
     
  11. sleekspot921

    sleekspot921 New Member

    Same issue here
     
  12. 4K2HD

    4K2HD Member

    Yep. This issue is real.
    I own the 2020 Pro 17 4K 120hz and the drivers haven't updated since 4/15/20
    I also tried to update directly through NVIDIA but also got a black screen and had to revert to older drivers through Windows Recovery.
    Given that this is a 4000$ laptop, one would hope RAZER will get on this ASAP.
    Thanks
     
  13. cjjacobs

    cjjacobs New Member

    I'm in the same boat. I got the new drivers to install but ended up with a black screen. A quick trip into recovery mode solved that issue. Hoping Razer solves this ASAP!
     
  14. autoFawnPERIDOT525

    autoFawnPERIDOT525 New Member

    FYI for anybody installing 451.58. You will lose dedicated GPU with the laptop screen, and will need to enabled optimus in the bios.

    This also means you lose 4k 120hz! I'd refrain from this driver for the time being.
     
  15. 4K2HD

    4K2HD Member

    So did you loose undervolting when you updated the BIOS?
     
  16. autoFawnPERIDOT525

    autoFawnPERIDOT525 New Member

    Sure did. I got XMP with the memory, but when i set it the machine wouldn't boot and i had to open it up and clear the cmos by pulling power and battery to get booted again.

    In terms of perf loss with my -125 undervolt vs this bios with no undervolt i lost about 400 points in cinebench r20 bringing my score from 3804 to 3400ish.

    A memory upgrade isn't going to get me back the performance i've clearly lost over losing undervolting. I haven't try to see if this bios can be modified but even if it can, it's not worth the risk at this point.

    Honestly, i wanna roll back to the 1.0 bios and just go without the XMP.

    Not very enthusiast friendly of Razer at all. This kinda defeats the purpose of shelling out this kind of money for a machine meant for power users.

    Still though, not going to lie that it's a fantastic machine. I just wish they'd at least build in a default undervolt of -110 or something.
     
    Hermanator likes this.
  17. Jeffyu82

    Jeffyu82 New Member


    You paid a premium for their product to solve their shit..
     
    Hermanator likes this.
  18. Ljcastellano

    Ljcastellano New Member

    I want to downgrade the bios. There is not way to go back to the BIOS 1.0 right?
     
    Hermanator likes this.
  19. jeong747

    jeong747 New Member

    I am in the same shoes, I flashed the 1.03 version and want to revert the flash to 1.01
     
    Hermanator likes this.
  20. autoFawnPERIDOT525

    autoFawnPERIDOT525 New Member

    I haven't honestly looked into whether or not i can downgrade the bios. Perhaps Razer support will chime in on this thread and help us out.

    I really think we deserve a bios that gives us the option to enable undervolting, even if the plundervolt fix is enabled by default. It really isn't fair. The performance penalty is high enough where they effectively neutered the product after we paid upwards of 4300 bucks for these things and left us high and dry.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >