Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Huntsman Elite Volume Wheel problem

Discussion in 'Razer Support' started by BaltasarHenderson, Aug 7, 2020.

Thread Status:
Not open for further replies.
  1. BaltasarHenderson

    BaltasarHenderson New Member

    When I twist the volume wheel, I feel the normal clicks it made before the problem started, but it doesn't work properly.
    The volume level either skips 20 levels, go the other way, or sometimes it won't even change.
    I tried changing the action the wheel has on Synapse, but the problem persists.
    I ruled out any software problems since I tried updating Synapse, updating Windows, updating the keyboard's firmware, changing usb ports and different pc's.
    My early guess is that the volume wheel got dirty on the contact points. I tried blowing some air to the wheel but there was no effect.

    I was hoping to get some instructions on how to open the keyboard, or clean the wheel, since I can't send the unit to RMA since I live in Uruguay.

    I miss changing the volume levels :slightly_sad:
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Do you get the same results with and without Synapse running in the background? If so, you may be right that this is a hardware issue. That said, I hope performing a clean installation of the app and drivers would improve your experience with the volume wheel.
     
  3. BaltasarHenderson

    BaltasarHenderson New Member

    Either Synapse is running or not, the problem persists.
    I also read that somehow, detaching the wrist rest could have an impact, but no changes whatsoever.

    Just tried with the clean installation on both my Razer Blade 15 and my desktop PC, and there where no changes.

    This room gets a lot of dust and I cleaned the keyboard every 2 months to prevent it from collecting too much dirt under the keycaps. Maybe dust made it through the wheel...

    Any other ideas?
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    You can try to clean the keyboard, but PM me the serial number so I can give you the firmware updater. Let's go from there.
     
    BaltasarHenderson likes this.
  5. Hi I'm having the same problem with my blackwidow elite, the volume dial will not register properly, when i adjust it by 1 click, the volume level will go up or down randomly, sometimes no changes at all.
     
    BaltasarHenderson likes this.
  6. BaltasarHenderson

    BaltasarHenderson New Member

    Just sent it, but as I mention in the conversation, I tried the firmware update some months ago.
     
    Razer.Caziel likes this.
  7. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Please PM me the serial number of your keyboard, so I can help you isolate the issue. Let's go from there.
     
  8. Maddogz

    Maddogz New Member

    I am also having the exact same issues.. been living with the massive annoyance for a year. I'll PM my serial number also
     
  9. Predator150

    Predator150 New Member

    Im having exact same issue. Did the firmware update help?
     
  10. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Most of the people on this thread had a faulty rotary encoder, so we had to resort to RMAs. Do send me your serial number so you can update to the latest firmware version. I can always help you submit a warranty claim if necessary.

    *Locking thread to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >