Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Unable to connect Razer Basilisk X Hyperspeed using bluetooth?

Discussion in 'General Discussion' started by DeepRubytruckbyte800, Jul 7, 2020.

  1. I got the mouse about 2 weeks ago and it worked perfectly fine. yesterday I tried to connect it to my pc using Bluetooth and it kept saying to try connecting again I tried to connect it with my mac and same thing it just would not connect. I tried to replace the battery with no success and updating the firmware. nothing worked. 2.4 works fine but no matter what I do it just won't connect using BT. can someone help please?
    thanks!
     
  2. Hi i have the same problem. Already contacted support, without any response.
    Basically I cant even enter the pairing mode.
    I also realizedthat when you update the firmware you have to update two seperate parts:
    1. the 2.4 Ghz mode (which can only be done while in this mode)
    2. the bluetooth mode (which sadly can only be done while the mouse is connected to the computer via Bluetooth)
    This does seem like a very obvious issue to me (since I need to pair it via bluetooth to fix the problem which stops me from pairing via bluetooth).
    I can see that its been a while since you posted this. Have you found any solution?
    Thanks a bunch.
    Ps. razer please look at this thread. It seems to me that this is quite a common problem as ive also seen other people mention it.


    Also I should say that the mouse doesnt help me at all in 2.4 Ghz since I bought it specifically due to the lack of USB ports on my laptop. If I can/t find a solution I will probably need to return it within the next week.
     
  3. rebekahcastiello

    rebekahcastiello New Member

    I also am having the same issue with the bluetooth mouse. I can see it's paired fine, but then I can get it to pair when pressing the three buttons. The blue light never stops blinking twice.
     
  4. I'm also having same issue for the bluetooth (Razer Basilisk X Hyperspeed), It showed paired inside the pc bluetooth setting but blue light signal never stop blinking and keep jumping between "paired" and "connected" mouse point cant even move.

    Please looking into this issue and solve it. This is the 1st time I bought Razer product, hopefully razer response it , otherwise,it will be the very worst experience to me and not going to have others razer product for the next time.
     
    Haquin likes this.
  5. Justin126

    Justin126 New Member

    I have been utilizing the remote connector and it has been working fine this while yet yesterday it unexpectedly quit dealing with remote connector and must be utilized on bluetooth upsers.
     
  6. karenakurenai

    karenakurenai New Member

    Same issue of the bluetooth connection in my 3 windows devices(two win7 and one win10), cannot pair or found by windows.
    However, it works alright when I tried to paired with osx of my macbook air(which is same hardware of win7 is installed but cannot pair) and android phone, it is weird.
     
  7. nfarhani40

    nfarhani40 New Member

    Same issue with mine! Cannot discover by computer Bluetooth.
     
  8. nfarhani40

    nfarhani40 New Member

    I am also having the same issue and the BT function is not working and my both computers Bluetooth at home cannot detect the mouse Bluetooth. Please help! thanks,
     
  9. StrangerThan

    StrangerThan New Member

    Bump. Same issue. Windows recognizes it as a bluetooth device but there is no wireless functionality. It is only functioning as intended when connected via usb cable to my Blade laptop. Even though windows sees it as a bluetooth device and it looks paired, the mouse doesn't work at all without a wire.

    I also cannot complete product registrations as the product # and serial #'s return an error that says they don't match, even though I am inputting the information as it is written on the product box. Please help!
     
  10. TurboTacho

    TurboTacho New Member

    Try completely removing the device from Devices and printer. And then re-pair the Bluetooth device.

    Should be able to refresh the connection.
     
  11. TheDoctor07

    TheDoctor07 New Member

    I had the same problem thanks
     
  12. epicgoose9

    epicgoose9 New Member

    same problem
     
  13. johnnyc2pi

    johnnyc2pi New Member

    I have the exactly same issue with Basilisk X Hyperspeed, raised the ticket since Jun 2020 but till date couldn't resolve by Razer Support. I have personally tested most of the Dell Vostro, Inspiron will failed but working find for Acer Aspire / Surface pro machine. Hopefully Razer support team will read this thread.
     
  14. Sye_The-Vie

    Sye_The-Vie Well-Known Member

    Just like old software becoming redundant, BT technology is also the same

    I had a Galaxy Note 5 which uses BT 4.2, which is incompatible with Hammerhead which needs a BT 5.0.

    So for BT technology, both receiver and transmitter vice versa need to be same version otherwise it will not sync

    This is why wired tech is the best
     
    Last edited: Nov 23, 2020
  15. johnnyc2pi

    johnnyc2pi New Member

    At least Hammerhead specifically stated it require BT 5.0 while Basilisk X Hyperspeed I couldn't find any information on BT version require. Did a test on older laptop which use Intel AC 3160 BT 4.0 on Dell Inspiron, it was working well though. For my current laptop which having the same issue is BT 5.0 on Intel AC 9560 (Clean format my machine twice).
     
  16. Sye_The-Vie

    Sye_The-Vie Well-Known Member

    I assume you have updated the BT driver on your current laptop?

    If BT tech is still a mess, try using 2.4 GHz wireless connection after the BT has been turned off.
     
  17. johnnyc2pi

    johnnyc2pi New Member

    Yes, updated driver after engage support from both Razer and Dell technical support.

    There's no issue with 2.4 Ghz wireless which I'm connecting to my Desktop while my laptop I choose to use Bluetooth. Another reason why I like this Basilisk X Hyperspeed.
     
    Sye_The-Vie likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >