Wireless & bluetooth connection - Deathadder v2 Pro

Discussion in 'Mice and Surfaces' started by jointojoint, Apr 13, 2022.

  1. jointojoint

    jointojoint New Member

    Hello,
    I just bought new DAv2 Pro. For some reason mouse do not work in wirless (2.4) neither BT mode. I had installed Synapse software. Mouse works perfectly fine while connected via cabel.

    Wireless 2.4 case:
    1) When I connect dongle to PC I can see that "HID-compliant mouse" and "Mouse compatible with HID" shows up in Device manager (previously there was also (or instead of, Im not sure) the second "Razer DeatAdder V2 Pro" device but I uninstalled it while debugging). As soon as I unplug the cable from the mouse and switch toggle to 2.4, the mouse stops working. Windows and Synapse can not see it.
    2) I tired to download and use Razer Mouse Pairing Utility. The pairing process went without any problems.
    3) I checked other USB ports. I'm 100% sure that they works fine.
    4) I do not own any other computer with USB port to check if it related to my PC or the mouse itself.
    Razer-DeviceManager.png Razer-Pairing.png

    BT case:
    1) I tried to connect my mouse to MacBook M1 but I can not set mouse to pairing mode. Ofc I moved toggle to BT mode and pressed&hold 3 buttons at once (both side buttons and upper button) for 3 or more seconds just like it is shown there but my mouse doesn't blink.

    I run Windows 10 21H1 on my PC. Let me know if you need more specific information about my hardware or software.


    EDIT:
    I uninstalled the devices from Device manager. I manually installed drivers from official site. I reinstalled Synapse. Problems still occures. Mouse is charged to 100%.
    Razer-DeviceManager2.png
     
    Last edited: Apr 13, 2022
    pancholr likes this.
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Have you tried connecting/pairing the mouse dongle to another Windows computer? Try uninstalling the Razer Synapse 3.0, restart your pc and go into the Windows program data and delete the synapse folder. Once done, restart the computer and reinstall the Razer Synapse 3.0. Also, update the Windows .NET Framework to version 4.8. Otherwise, the dongle has a possible hardware issue and needs a replacement. Feel free to send me a PM anytime or visit our self-help options should you have other questions or concerns.
     
  3. jointojoint

    jointojoint New Member

    No, as I write before I do not own other PC with USB port. I will try to check dongle with other PC in upcoming days.

    I did it today despite the fact that I did it yesterday as I wrote before. Nothing changed. Problems still occurs.

    My .NET Framework is 4.8.4084.0. Do you recommend to install older version (>=4.0.0)?

    I'm not sure about that. As I wrote, Windows "can see" the dongle (ofc this does not rule out wireless connectivity issues). The thing that worries me the most is that I can not set my mouse to pairing mode which may mean problems with the mouse itself.
     
    Last edited: Apr 13, 2022
    pancholr likes this.
  4. jointojoint

    jointojoint New Member

    UPDATE:
    I manage to pair my mouse with MacBook via BT, kinda. First of all I could not turn on pairing mode with the step shown in instruction, but I notice that while I'm holding 3 buttons (2 side buttons and upper button (change to higher dpi/sens) I can turn toggle back from BT to OFF and then to BT (while still holding buttons!). After that Razer logo started to blink. I quickly connect it with my Mac and... it disconnect for no reason. I did not change the toggle, I did not change any BT settings in Mac. Just after few seconds my mouse decided to not work with Mac anymore.
     
  5. jointojoint

    jointojoint New Member

    I have another question related to Synapse software.
    While I'm connected via cable and my toggle is set to 2.4 should Open Pairing Utility option be available? Mine is not. Ofc when I disconnect the cable from the mouse Deathadder disappear in Synapse.

    Open pairing utility.png
     
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for updating the thread. Is the Razer Deathadder V2 Pro's battery level good when you did the pairing? Also, does toggling the switch from being turned off to either 2.4 or Bluetooth not trigger the pairing mode? And yes, holding the three buttons initiates the Bluetooth pairing mode. The Razer logo should blink twice at repeated intervals to indicate that it is connecting and goes to static blue when paired. Also, the mouse should automatically reconnect to your devices when it is on Bluetooth mode and within range. For additional info, please check the screenshot from our FAQs below:

    upload_2022-4-14_4-21-19.png
     
  7. jointojoint

    jointojoint New Member

    First time when I tried to connect via 2.4 mode battery was around 50%, secend time it was almost fully charged.

    To force bluetooth pairing mode I had to hold 3 buttons, turn toggle switch from BT to Off and to BT again (while still holding 3 buttons). I did not try to hold buttons while connection via USB dongle because there is no information about that in manual.

    Does this rule apply for 2.4 connection too? My Razer logo did not glow up when I tried to connect it to my PC in this mode.

    I turned off WiFi in my flat to test 2.4 connection one more time. Unfortunately I did not help. RazerMousePairingUtility_v1.00.02_r1 says that my mouse is connected to PC (both via cabel and USB) but when I plug off the cable and set toggle switch to 2.4 I does not work.

    I don't think it is important but I reinstalled my Windows 10 few days ago. It is pretty clean. My business MacBook 2022 with which he is trying to pair the mouse via bluetooth is almost brand new.
     
  8. jointojoint

    jointojoint New Member

    I think I found a clue. I tried to pair my mouse to MacBook one more time, but this time I really hard pushed toggle switch to BT connection. It worked! Kinda actually. For some time it was working but I decided to switch toggle back to Off and BT one more time to test if it was the case, and yes... I think that my device is has factory issue. It is working in BT mode only when I'm pushing the toggle switch to BT hard. When I take off my finger from toggle switch connection breaks :slightly_sad:

    I tried to set toggle switch to 2.4 really hard too but it does not help.

    My guess is that my mouse has some hardware problem with toggle button.
     
    Last edited: Apr 14, 2022
  9. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member


    The LED indicators only work with Bluetooth pairing. Once you toggle the mouse button to 2.4GHz mode and connected the dongle to a computer, the device should automatically look for the dongle and pair.

    Oh no. Sorry to hear that. Did you try the recommended steps from my screenshot showing how to troubleshoot when there's an issue pairing via a 2.4 GHz connection? Try changing your modem's WiFi channel (non-overlapping channels are 1 to 1, 6, or 11). Also, it's good to connect your computer to a 5GHz WiFi connection and dedicate the 2.4 GHz for your peripherals. Otherwise, link the PC via an Ethernet cable to avoid wireless traffic/interruption. If your device's warranty is still up, please request a replacement from your reseller or send me a PM if you've bought it from the Razer Store (razer.com).
     
  10. jointojoint

    jointojoint New Member

    Yes, I totally turned off my WiFi modem to test 2.4 connection. My PC is connected by ethernet cabel all the time.

    I bought it (from reseller) few days ago so I guess my warranty is still up. Please let me know if I should register this mouse at Razer site to get a refound or it is unnecessary/not related to third party shops?
     
  11. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member


    Regrettably, the mouse does show a hardware issue since the recommendation was exhausted, and the problem remains. And yes, if it's from a local reseller, you can return the device with its original packaging and present its receipt. If you bought it from an online reseller, please contact them as they may have a process for returns or refund.
     
    jointojoint likes this.
  12. jointojoint

    jointojoint New Member

    I just want to inform you and everyone who is looking for a help at this forum that I got new copy of DAv2 Pro. This one works flawlessly out of a box. As I wrote before I think that previous mouse had a problem with toggle switch button. The one in new device feels different, much smoother.
     
    covani19 and FiszPL like this.
  13. covani19

    covani19 New Member

    Have the same issue with my V2 Pro. It just stopped working with Bluetooth after I removed the mouse from my M1Pro MacBook 14'. I don't have the USB dongle, so I cannot try but the LED indicator is on when its on 2.4 Ghz. It's also working on cable as well. But when turning on Bluetooth by switch button, it goes dark. Nothing happen with pressing any combination of buttons. Totally black, no LED. %100 Battery. Works fine on cable.
     
  14. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    That's good to know. Should you need additional assistance, don't hesitate to send me a ping.

    Hi covani19! Please send me a PM, including your device's serial number, so I can check its details and available updates. Let's continue our conversation privately.
     
  15. MariOkudoduma

    MariOkudoduma New Member

    Wondering if any fix was found?

    I had one that did this and it was replaced under warranty.

    Second one just did the exact same thing. Mouse was low power, so plugged in overnight. Take if off the charging dock and no lights to pair back to Mac.

    I have also noticed every single time I charge the mouse, i have to delete and re-pair with my mac. Annoying AF.

    I am wondering if there is an issue with charging it while omegle in Bluetooth mode?
     
    Last edited: Oct 19, 2022
    covani19 likes this.
  16. denzeo

    denzeo New Member

    I'm on my second Deathadder Pro v2 (first one was replaced under warranty with this problem) that now has the same issue. Toggle to BT, no power, no response. Toggle to 2.4 and there is power and it works. Off mode with a cable works too. I don't know how to recover the BT and don't know what triggered this, it just suddenly stopped working - just like my first mouse.
     
    covani19 likes this.
  17. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey MariOkudoduma and denzeo! Sorry to hear that your devices are also experiencing the same behavior. Ensure that the device's firmware is updated. Should the issue persists, please submit a case so our Support Team can further assist. You may also send me a PM so I can help you kick-start a support ticket on your behalf.
     
  18. covani19

    covani19 New Member

    It seems Razer DeathAdder v2 Pro has a serious problem with Bluetooth. I never go to buy another Razer pro mouse again. And I will tell everyone about this serious problem and the way that Razer and Support Teams handle with it.
     
  19. kaption123

    kaption123 New Member

    I see you found pairing software it very cool so it did pair the mouse and not some other hardware to dongle like a headset. Also did you try upgrading mouse firmware.
     
  20. FiszPL

    FiszPL Well-Known Member VANGUARD

    It can be also problem with BT module in your PC or the drivers for it.
    Check if you have the newest BT drivers installed, if not - update it.

    You can also check if the mouse works correctly (or not) on the other PC.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >