Wireless & bluetooth connection - Deathadder v2 Pro

Discussion in 'Mice and Surfaces' started by jointojoint, Apr 13, 2022.

  1. covani19

    covani19 New Member

    Already mentioned before that I've tested it with different computers as well with a PC laptop and desktop.

    The mouse is totally dark. Not working when you switch to BT. Thats not a drive issue of any computer.
    Thanks for your reply though.
     
  2. mithwick93

    mithwick93 New Member

    I am also experiencing the same behavior. The mouse worked fine until I connected it to Macbook pro M1. It suddenly stopped working on Bluetooth mode, and the mouse is entirely dark when switched to BT mode.

    I tried updating the mouse firmware. But after the update also, it is the same issue.

    It works fine in Wired and 2.4 GHz modes
     
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Did you able to replicate the concern while pairing the mouse to a Windows-operated computer? Please send me a PM so I can help you kick-start a support ticket on your behalf or submit a case here.
     
    mithwick93 likes this.
  4. mithwick93

    mithwick93 New Member

    Hey, thanks for the quick response. I did try back on a Windows machine as well. The upgrade to firmware was done on the Windows machine. But still irrespective of the host OS, the mouse would go completely dark on BT mode.
     
  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for confirming. I may need to point this out to our Support Team. If you have submitted a support ticket, please drop the case number in my inbox so I can cascade it to the team. I appreciate your cooperation.
     
  6. I just had the same issue with mi DAv2. I could not connect it by 2.4ghz at the beggining, it worked by cable and with BT. Doing a lot of things ( Updating synapse, re-installing it, lot of programs ) I realize that if I really hard pushed toggle switch to 2.4ghz it works, at first I tried it and notice that the light was turning on, but after some seconds dissapears. I tried pushing it harder and worked, so seems it is a hardware issue and not software.

    However I used to have other software problems that I could fixed, but definitely this mouse gaves the user a pain in the neck than solutions. Now I am having problems with razer synapse as it is not detecting the mouse using it on 2.4 ot BT
     
  7. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Sorry to hear that you are experiencing the issue. Please send me a PM so I can help you initiate an investigation. Your immediate response is valued.
     
  8. dlarasound

    dlarasound New Member

    Hello, I have the same problem. I am a user of Mack Book Pro M1 and suddenly my mouse has stopped working in BT mode, it only works in 2.4 and USB cable mode. When I try to activate the BT mode the mouse stays black and does not give any signal. I have performed a Firm update and I have tried on a Windows device and the same thing happens, is there a solution? Thank you so much.
     
  9. kaption123

    kaption123 New Member

    The only problem I have is remember button to press after turning it on to Bluetooth. If nothing happens I try to rebind the device. https://mysupport.razer.com/app/ans...r DeathAdder V2 Pro,device is in pairing mode.

    Once you hit the 3 button the lights blinks most of the time. The other times it's binds quick and starts working. If after you follow instructions and can not get it working I try contacting support or check website for other tips.
    Did you try putting into binding mode and reminding to Bluetooth.
     
  10. dlarasound

    dlarasound New Member

    Yes, I have tried pressing the 3 buttons, the 2 sides and the PPP increase button as indicated in the manual and the mouse does not react at all, no lights come on and it seems to be completely off when I put it in BT mode.
     
  11. kaption123

    kaption123 New Member

    Well if you tried on different hardware then something differently wrong. The firmware or hardware is having a problem. If you can plug in or connect with wifi a technician person might be able to connect and test it. They can also check if it's sending a Bluetooth signal with scanners. But that's more bench work done at factory manufacturing and quality control testing. I report what software and firmware your running and what you tested it on to technology support. With serial number of mouse. Hopefully the firmware is ok and they don't need to release a quick update.
     
  12. dlarasound

    dlarasound New Member

    The firmware that I am using is v2.03.00 and the system tells me that there is no newer update for my mouse. The Software I use is MacOS BigSur 11.4, I hope this can help you. Thank you so much
     
  13. kaption123

    kaption123 New Member

    No I don't do that job anymore you would have to contact razer support site and see what they can do for you. https://support.razer.com/
     
  14. Sheikhm007

    Sheikhm007 New Member

    I am also facing an issue with the 2.4 GHz mode in my DeathAdder v2 Pro, The Bluetooth and Wired connections are working fine, Everything including the drivers and Mouse are in the latest firmware, I tried this with wifi turned off,
    When i put the slider in 2.4 mode it doesn't turn on the rgb and the white profile light blinks after few second but it doesn't connect with the dongle, Can you tell me how can I fix this problem with the 2.4ghz mode ?
     
  15. kaption123

    kaption123 New Member

  16. Sheikhm007

    Sheikhm007 New Member

    I did this 2 times but it doesn't work the mouse disconnects when i remove the wire and doesn't connect in 2.4 mode. It only works on bluetooth or wired and when i move to 2.4 mode it blinks the white profile light after few seconds and nothing happens. What should I Do to fix this ?

    And could you tell me how the mouse should usually behave when moved to 2.4 mode ? Are the rgbs supposed to turn on automatically on that mode ?
     
  17. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    It needs further investigation. I recommended submitting a case here or sending me a PM so I can help you create a support ticket. Thanks for your cooperation.
     
  18. kaption123

    kaption123 New Member

    Rgb depends on setting I contact razer technology support. They should have technical members that can help support team. It been 30 plus years since I did the job myself.

    But reporting any information and pictures of equipment should help them.
     
  19. kaption123

    kaption123 New Member

    Only other information I can think of right now is wireless adapter is not one from razer. Did the pair software give an error.

    Hopefully you get it working.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >