BlackWidow V3 Pro spamming nonsense macros | Razer Insider
Question

BlackWidow V3 Pro spamming nonsense macros

  • 5 March 2023
  • 4 replies
  • 297 views

Hey, as the title says, my BlackWidow V3 Pro started spamming macros I never assigned. I just came back to my computer and keys like “d” now type “dfrc”, “a” opens some Window stuff etc. I’ve tried reinstalling Synapse, updating the keyboard FW, testing on other PC, always the same. Any idea what might’ve caused this and how to fix it? Luckily I could swap to my old keyboard but this is genuinely one of the most annoying things that ever happened to me, related to my HW.


4 Replies

It sounds like your BlackWidow V3 Pro keyboard may have a malfunction or a software issue that is causing it to spam macros that you did not assign. This can be frustrating, but there are a few things you can try to resolve the issue.

First, make sure that your keyboard firmware and Synapse software are both up to date. Check the Razer website for any available updates and install them if necessary. You can also try resetting the keyboard to its default settings.

If these steps do not resolve the issue, it is possible that there may be a hardware problem with your keyboard. You may want to contact Razer support to see if they can help diagnose and resolve the issue. If your keyboard is still under warranty, you may be able to get a replacement or repair.

In the meantime, using a backup keyboard is a good temporary solution. It's always frustrating when technology malfunctions, but with a little troubleshooting and patience, you should be able to get your keyboard back to working order soon.

After going through all the possible steps with the Razer support, it seems to be a hardware failure. Not even a year after getting the keyboard.

When I type V,’ it displays “v5t g” and when | type  B it displays “b00:46 30-11-20236yhn”  all last row keys are working like this and I press shift key I’m getting  similar issue.

This was newly purchased  three months ago. This malfunction started two days ago , All the recommended updates have been carried out.

Really disappointed.

When I type V,’ it displays “v5t g” and when | type  B it displays “b00:46 30-11-20236yhn”  all last row keys are working like this and I press shift key I’m getting  similar issue.

This was newly purchased  three months ago. This malfunction started two days ago , All the recommended updates have been carried out.

Really disappointed.

 

Wanna know what helped me in the end? I bought a new, non-Razer keyboard after having the broken one in my closet for 8 months or so and just for fun tried Razer again (didn’t work a month before). And voila, it works. I have no idea if it’s some magical version of Razer SW or something but yeah. Wait about a year and it might solve itself, although I’m still paranoid that it will start again.

Reply