Razer Basilisk X Hyperspeed 2.4GHz dongle does not working | Razer Insider

Razer Basilisk X Hyperspeed 2.4GHz dongle does not working

  • 6 April 2023
  • 34 replies
  • 11811 views

Hello, I have problems with 2.4GHz dongle, it does not see the mouse and the pair is not making. The mouse is NOT visible also in Razer Synapse 3 when is set to 2.4GHz, only when is set on Bluetooth.

The mouse is working on Bluetooth mode (but is a bit slowly).

I mention that I updated the drivers, restarted the laptop, updated Windows, reinstalled Razer Synapse 3 and the problem persists, the mouse is working only on Bluetooth mode, with 2.4GHz the mouse is not visible and is not connecting to the dongle.


34 Replies

Userlevel 7
Badge

When you plugin the dongle, do you hear the new device connect sound? Is it visible in Windows device manager?

Yes

Hey, I have the same exact issue, my mouse only works when on Bluetooth, and when i used to plug in the dongle the device detected sound used to come one but not anymore.

No one knows what you can do?

Userlevel 7
Badge

You can do clean Synapse reinstall, so it’ll remove any Razer drivers, and they’ll be downloaded again.

  1. Uninstall Synapse
  2. Download & run this tool: https://rzr.to/Tf53xj to remove any razer drivers/leftovers
  3. Then restart your PC
  4. After reboot install Synapse again (as administrator).

Still does not working! Dongle is connected (with sound at connecting), mouse is on 2.4Ghz (green light flashing), the mouse is not visible at devices in Razer Synapse 3 and is working only on Bluetooth mode.

I have exactly the same problem… There is a solution?

I don’t know.. is there a solution guys? Or maybe to buy another razer x hyperspeed dongle, can match with the mouse?

my Basilisk  mouse wasn’t a great mouse to begin with with all inconveniences and disconnects here and there. I used to remove and plug back in the dongle to work around but now it completely stopped working on regular 2.4ghz wireless. It now only works in bluetooth. Nothing helped. I dunno why.

So many people with the same problem and no solution, really Razer…?

I recently changed my laptop and now facing the same issue( I didn’t really check if it was detecting in razer on my old laptop). I have the same issue as well. The mouse works over dongle and bluetooth to be used but over dongle it’s not detecting in Razer Synapse to check my battery or to adjust the settings. I can do over bluetooth but I don’t know if it’ll remain the same when I change it to 2.4Ghz dongle to game. I honestly think it’s an issue with the Razer Synapse but Razer what the hell?

Same here.
And this reddit thread is three years old!
That’s my first and probably last experience with Razer.
Such a good mouse, tho 😭😥

I had the same problem. The 2.4 wasn’t working until I updated the software. It works fine now. I hope this helps.

Can you tell us software version? Or maybe a link with your version? Thanks

Go here:

https://mysupport.razer.com/app/answers/detail/a_id/6076/kw/dongle

 

Download the dongle utility and follow the instructions. This is what helped me. I had the same issues and I heard the dongle notification when plugged in and I was already on the latest. Once I got the utility installed it was pretty straight forward.  

Hi, for me pairing with utility under this link helped

https://mysupport.razer.com/app/answers/detail/a_id/6376/kw/basilisk%20x%20hyperspeed

(Second download)

Thanks, I used RazerMousePairingUtility_v1.00.03_r1 from How to use the Razer Mouse Pairing Utility and it works

I had the same issue recently and all I could figure out after taking the dongle apart was that there are some electronics on the dongle that broke off. I suspect it broke of from pushing it it to hard or bumping the dongle..

 

simply go to the settings>RESET> and reset everything the mouse. It will delete everything u have done to the macros and stuff but 2.4Ghz will work
at least it worked for me:)

Hi, I had the same issue currently, Who can let me know which the resolve?

it sounds like your dongle is history same as mine, it’s not detected by both my PC and Mac, when I investigated further I’ve found that the dongle cannot stand heat, will not purchase a new dongle for 22$ so I’m using it only for Mac on Bluetooth, shame how Razer product’s quality is on decline! 

I had the same issue recently and all I could figure out after taking the dongle apart was that there are some electronics on the dongle that broke off. I suspect it broke of from pushing it it to hard or bumping the dongle..

 

no it’s because of heat, mine is the same, shame on Razer

meu dongle está com erro no driver, quando conectado fica conectando e desconectando , alguém sabe como resolver ? tem algum driver específico para esse problema?

 

ja mudei de porta USB, desliguei PC, atualizei drives pc, mas na Razer não encontrei informações de atualização driver de mouse

I had a problem where the mouse light would come on and then disconnect and mouse was unresponsive but the dongle made the sound when connecting. I suspected a physical issue, took the mouse apart, applied some pressure to the sockets where the wires connect to the battery and it started working. Probably a contact issue when I dropped it or something, might be worth a while. Since the wires didn't come off entirely it work sometimes and sometimes didn't. It is an easy disassemble with youtube guides. Give it a try.

SAme issue, updated Dongle firmware but mouse only connects to bluetooth, not via the Dongle, also cannot get the green light flashing by pressing the 3 buttons, only by turning off and on again

Reply