GameDog [v2.4] - Chroma for CS:GO and DOTA2

Discussion in 'Razer Chroma' started by WolfspiritM, Oct 26, 2015.

?

Is it useful and would you like to see more from this Project?

  1. Yes

    490 vote(s)
    96.8%
  2. No

    16 vote(s)
    3.2%
  1. WolfspiritM

    WolfspiritM Active Member

    So that means there is no green loading animation?
    If the Device doesn't react at all it usual helps to uninstall Synapse AND the SDK and reinstall.
     
  2. No green loading animation.
    As said, I already tried uninstalling Synapse & the SDK. I'll try it again. Will post results in a few minutes.
     
  3. WolfspiritM

    WolfspiritM Active Member

    Sorry I missed that.
    If there is no loading animation at all you can try a few other Chroma Apps like Snake for Chroma to check if it's a gamedog issue (usually it's not). Sometimes it's fixed by moving GameDog to the top (or moving GameDog at all) in the Chroma Apps list.
     
  4. Seems to work now. After reinstalling everything again I finally get the loading animation.
    No idea what caused the problem. Maybe there where some files left after uninstalling everything last time.

    Thanks for the help!^^
     
  5. .iveL

    .iveL New Member

    Did you manage to find the problem with Deathadders freezing?

    Read somewhere above that someone reset to default and it stopped freezing? I did change some keys around to accommodate better the Blackwidow TE... I might try with defaults and see if it still freezes.
     
  6. WolfspiritM

    WolfspiritM Active Member

    No sorry. For me it doesn't freeze. I played with the Deathadder for hours without issues.

    I suggested to try to reinstall Synapse and the SDK earlier but didn't get any response.

    Export your current configuration before restoring the default and upload it to pastebin to share it with me so I can check if it has something to do with custom profiles. Even so I also tried to move things around it might be one special setting that is causing it.

    Was wondering if it might freeze when animated (many changes) like walking through Flash/Smoke/Fire in CS:GO or Last hit/Deny in Dota 2? I know that's hard to catch.
     
  7. .iveL

    .iveL New Member

    Let me try reinstalling my Synapse and SDK, and see if that fixes.

    I just tried the default settings and it didn't fix it. I was thinking the same while playing Dota2, that maybe it was due to the last hit/deny... however while in CS:GO, it froze while walking around normally (not through Flash/Smoke/Fire).

    Let you know how I go with reinstalling Synapse and SDK.
     
  8. Thilyon

    Thilyon New Member

    Looks and works pretty sick.
    Making one for Smite would be pretty dope :3
     
  9. WolfspiritM

    WolfspiritM Active Member

  10. .iveL

    .iveL New Member


    Woops yes there is! Sorry! After uninstalling synapses and SDK, reinstalling from razer's website, the problem didn't exactly go away but I can now play on dota2 longer before the mouse freezes...

    So, the problem is essentially still there and I can't think of any other reasons for this issue...
     
  11. WolfspiritM

    WolfspiritM Active Member

    I am wondering if there are people here who are using Philipps HUE Lamps like the Living Color together with a HUE Bridge so it can be controlled by Apps.
    I just implemented HUE into GameDog as a prototype and would like to know if that's something people would be interested in :)

    That's really bad :/

    As the Deathadder isn't freezing for me, it would be nice if you could try a few things.
    I made a small "Benchmark" application that does nothing else then playing an animation on the Mouse. Can you run this App and see if that freezes after a while, too?
    Just unpack whereever you want, start it and click on the "Start" button which will do nothing else then playing a simple Red animation on the mouse. Just leave it playing for a while.
    If it freezes, then replug and adjust the update rate slider to the right and see if that causes it to freeze, too? Maybe you can figure out a point where it won't freeze anymore for you.

    http://gamedog.chromatin.eu/ChromaMouseBenchmark.zip

    Thanks!
     
  12. So I have been having an issue, and can't seem to find a solution. I start up the app, and get the green loading animation, but when I start dota the only keys that work are my F9 through "pause break" keys. I really love the idea, and would love to see it in action, but I cant get the keys to react with my game. For more information I have a Razer Blackwidow Chroma, and am currently only trying the default settings, as changing them seems to do nothing for me.
     
  13. WolfspiritM

    WolfspiritM Active Member

    So as you get the green loading animation does it go over the whole Keyboard and light up all Keys?
    The only time I've seen only part of the Keys lighting up where by a faulty update which was resolved by uninstalling Synapse and the Chroma SDK from Programs and Features and reinstalling from the razer website.

    Are the other Keys staying black or at least give the team background color?
     
  14. Yes, the green loading animation goes over the whole keyboard.
    I will try uninstalling the synapse and chroma SDK now, and will get back to you.

    And the other keys are just all staying black.

    Edit: I'm now noticing that whereas its supposed to go back to my original setup until I start a game, the keys stay black. I reinstalled the synapse, the SDK, and gamedog and it is still not working
     
    Last edited: Mar 11, 2016
  15. .iveL

    .iveL New Member

    Let me give it a go and let you know
     
  16. zeroseeds

    zeroseeds New Member

    I will give a try for that :D
    just chat me on steam if you remember me :stuck_out_tongue_winking_eye:
     
  17. Balkhan

    Balkhan New Member

    No way for me, i tried to unistall synapse and SDK but gamedog doesn't work for me. Neither on DotA2 nor on CS:GO, what shall i have to do? Help please :slightly_sad:
     
  18. WolfspiritM

    WolfspiritM Active Member

    Sorry for the late response. So you say F1-12 are working correctly showing health and mana? Actually I've never heard of any issue like that to be honest. Maybe you can contact me via steam so we can check this out any further: http://steamcommunity.com/id/kiba
    If it stays black after the loading animation you might have "Keep Chroma Focus" checked in settings.



    Sorry. I'd love to help but "It doesn't work" isn't really helpful most of the time. :/
    Check out the FAQ here: https://gitlab.com/Chromatin/GameDog/#faq
    If that doesn't help please give me more informations like what devices you are using and if you get a green loading animation.
     
  19. Milkitosh

    Milkitosh New Member

    Hello Wolfspirit, im having the same issue as Levi, my deathadder chroma mouse get freezed while im playing too, its kinda annoying, the only way to fix this is restarting the computer. Right now i will try to change the settings and try dota 2 again. ill give you a reply soon, thanks!
     
  20. WolfspiritM

    WolfspiritM Active Member

    Hi!
    @jongri had the same problem and messaged me earlier and told me that he and @njbmartin might have found a fix for this! You could try if that fixes it for you, too!

    Open Synapse, Select your Deathadder and in the top row click on Stats. Wait for it to load. There click on the Cog at the top right. In there disable the "Data Tracking". I don't think it's needed but to make sure the service isn't causing issues anymore I'd restart the computer and try again afterwards.

    I really hope that fixes it!
     
    njbmartin likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >