Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Kraken Tournament Edition - THX Spatial Audio not working.

Discussion in 'Razer Support' started by Davidier, Feb 14, 2019.

  1. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey @puggyy1! Thanks for sharing what you've found out after uninstalling Steam. By the way, the team wants to check your latest Synapse logs after the uninstallation of Steam. I'll wait for your follow-up via PM.

    Hi @Meisner57! Were you able to replicate the issue after uninstalling Steam? I understand that the step is not a fix. I want to gather the information that can help the investigation held by the Support Team. Feel free to update this thread or send me a PM if anything comes up.
     
  2. Meisner57

    Meisner57 New Member

    @Razer.SpeedCr0ss Just tried if for you. uninstalled steam and issues remains the same.
     
  3. puggyy1

    puggyy1 New Member

    hey did u uninstall with bcuninstall or some program like that? It will remove all regedit datas etc everything. I tried to install again and thx gone as soon as i opened apex legends on steam. After uninstalling immediatly started working again. Its so annoying that cant use thx
     
  4. Meisner57

    Meisner57 New Member

    I just did a normal uninstall. I will do a more througher one tomorrow.
    I use to have apex installed, don't remember if it was via steam. Will let you know how the deeper test goes.
    Are you saying the issue comes back as soon as you install steam or apex?
     
  5. puggyy1

    puggyy1 New Member

    Apex legends came to steam like 10 days ago. This issue comes back as soon as install apex through steam. Now im playin apex legends via origin and its all okey. I used to have csgo i didnt have any problem tho
     
  6. Meisner57

    Meisner57 New Member

    So the cause for you isn't steam it's apex legends installed via steam?
     
  7. puggyy1

    puggyy1 New Member

    True, but still i think u should make a clean uninstall with bcuninstaller. After that i think ur problem will be solve
     
  8. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey guys! Thanks for doing all the isolation and for checking our other user's recommendation. I have coordinated with our Support Team. They are currently investigating all the information I gathered from this thread and PMs. I appreciate your cooperation.
     
  9. Meisner57

    Meisner57 New Member

    i tried removing steam with the uninstaller you suggested.. no change issue still remains.
     
  10. Itegnis

    Itegnis New Member

    THX Spatial - Synapse not working, no sound. The drivers are installed for the first time on this laptop. Game and chat drivers works
     
  11. Baxta2004

    Baxta2004 New Member

    My Kraken TE works on my Blade Pro but not my desktop and I dont see a difference
     
  12. EmaxD787

    EmaxD787 New Member

    Hello everyone, I'm having the same issue here. I have the Razer Kraken TE and THX Spatial - Synapse doesn't work. My headphones are just working with Razer Audio Control - Game. This issue occured since I have updated Windows to its latest version, but I can read that I'm not the only one having this problem. Do we just have to wait for drivers to be upgraded? Thanks in advance

    All the best,
    EmaxD787
     
  13. thejerabek

    thejerabek New Member

    Oh my god thank you. That switch sucks anyway.
     
  14. Thokkiano

    Thokkiano New Member

    Same problem with Nari essential headset.
    Any solution?
     
  15. Nicholas9

    Nicholas9 New Member

    Lmao this is still happening lol, I own the Razer Nari Ultimate and I've been having this problem for over a year. Contacted Razer several times, going through all sort of steps just to end up with hearing it's a third party problem and the issue isn't on their side. Such bs tbh. Equalizer just stops working completely randomly and sometimes when I start an app (Usually with a game) my sound quality changes.
     
  16. Nicholas9

    Nicholas9 New Member

    Feels like my sound has a suppressor on it, suppressing what it's supposed to sound like, everything's so quiet
     
  17. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey everyone! Our Support Team wants to gather a new set of Razer Synapse logs as they want to get a data sample from the logs of the affected users by following the steps on this link. Save it via Google Drive or to another online drive account, then include its link in your PM or paste it in the feedback section after submitting a case. Let's continue from there.
     
  18. Thokkiano

    Thokkiano New Member

    Fixed!.
    1.uninstall device.(device manager)
    2.uninstall synapse
    3.delete any razer folder.
    4.restart computer.
    5.install synapse.
    6.plug device.

    It is very important,to plug device when synapse is installed.

    Hope it will help you.
     
    Razer.SpeedCr0ss likes this.
  19. Jarskaaja

    Jarskaaja New Member

    I am having this problem with the Blackshark V2. The Mixer tab lists no programs and no modes, all the boxes are empty. If I tick on the Spatial Audio switch to "on", nothing happens and it will switch off as soon as I navigate to another tab.

    If I manage to get a fresh profile somehow (through logging in as a guest or pressing quick start before profiles are synced) the Mixer tab will list programs and work for a minute but then fail shortly afterwards. It's like the THX driver stops accepting all Synapse input and won't allow any of the Mixer tab contents to load.
     
  20. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Thanks for sharing your workaround. This is helpful for the other users on this thread.

    Hey @Jarskaaja! Thanks for posting your Razer Synapse 3.0's behavior here. Please send me a PM together with your computer's Synapse 3.0 logs so I can assist you in submitting a case. I'll wait for your follow-up.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >