razer kitty headset disconnecting | Razer Insider
Question

razer kitty headset disconnecting

  • 26 February 2023
  • 61 replies
  • 18419 views

Userlevel 2

I’ve had my razor kitty headset since Christmas 2021 and they’ve recently started disconnecting a lot with a popping noise. I’m not sure if it’s a razer synapse issue because it’s everytime I move my laptop slightly it disconnects like there’s an issue with the usb/wire that’s broken ?? Is there a way I can fix this if it’s a wire issue ? Kinda upset they’re not even that old and they’re already showing signs of wear and tear :(


61 Replies

i had exactly the same problem   send them back got new ones  same thing..  The Razer Kitty Kraken headset has never worked properly  no mater how many  tips  and steps i took  to try to fix this problem so got a new set dif  one from razer   they where really  nice about this but i wish they could have fixed this problem cus i really did like the headset   it was so totally cute

a temporary fix that worked for me is to unplug the headset before launching the PC, and plugging it after synapse etc has launched completely

Exact same is happening with mine and my friends kraken kittys too… legit disconnects every few seconds and they are un usable.

It came back… I used to be on and off starting from maybe half a year after buying it, then about a year ago it got unusable, and I found the lights fix. It was working with minimal issues, only sometimes some crackling in the sound which curiously always was fixed by… rubbing the cord with my hand a bit. Now few days ago the disconnects came back, and they’re happening more often now. sometimes it seemed like it happened every five minutes, but sometimes it seems to go away for a long time.

My lights have been off the whole time too so whatever it is seems to be caused by something else.

The disconnects feel like they tend to happen when i move my head/body in some way, but i can’t ever seem to get them to happen “on command”, like by moving the cable, headset, body, trying to gently push and pull on it...

Having this same issue and it’s driving me insane. I keep this headset on a holder, only use it for two games that I need surround sound for. Tried reinstalling synapse, other usbs, my laptop, doesnt matter. Nothing I try works and it disconnects and reconnects with a loud pop over and over again. Endlessly. No matter what I try. I’m losing my mind and want a fix. This headset is barely a year old and not even my MAIN headset and its still working like ive been throwing it around and keeping it on 24 7

 

Same thing happens to me recently,  i purchased mine 1 year ago and i cannot use synapse properly, it used to happen once in a while but now it happens rapidly. I even uninstalled my synapse out of my computer and it still happens, disconnecting and reconnecting continuously for 7,8 times, then stops for about 5-10 mins, then starts again. It makes my experience with razer’s products turn out so bad.

i’ve been having the same exact problem now after like 2- 2 ½ years of no problems, i don’t know if i just have to get a new one or this is still and ongoing thing that happns all the time.

I am having these same issues. Tried software updates, connecting on different computer, etc. Audio cuts in and off with a popping sound. Really liked them but stopped working well about 6 months in. Have owned them for a little over 2 years. And were still usable but two weeks ago they completely crashed. Could use them again but the audio cuts off about 1 min in. Horrible. I really liked them when they worked well in the beginning.

I have this problem too. It happens pretty much since the beginning. Pretty much with the switch to the new Synapse. I’ve already reported this problem a few times but never got any help. 
It seams to happen to all direkt USB headsets. 
I have a normal Razer Kraken 7.1 V2 and a Kraken Kitty. Both have the same problem. 
Most of the time they are unusable because the constant restarting/disconnection. In combination with a hurtful loud clicking sound. 
The only one that runs perfectly is the Kraken Tournament Edition. 

It has to a driver/software problem, since the headsets runs normal under MacOS. But under Windows it’s omnipresent. I’ve tried it on countless computers (Win 10 and 11), since I work in IT. 
My friend also has the same problem with his Kitty Edition. 

Sometimes it seams to to help to completely disable all razer processes. 

I’ve seriously considered gutting the Kitty edition and converting it to a Tournament Edition. 

https://www.youtube.com/watch?v=cGLAXA8ex_I

guys, give this a try. found it after long research

I have the same problem here.. I can’t no longer use the free support because my warranty time is over.

I don’t want throw away my headset like this… after few years.  Razer, please DO something.

Is there any sort of solutions? 

thanks in advance <3 

 

this used to happen to me too, with a pair that i had for like 2 years. started off randomly and then became unusable. i couldnt stream on discord or even play my games because it would lag completely. i talked to customer support and they got me a new pair at the start of the year? maybe in feb.? tried playing a game and it had an episode of popping in and out for like 10 minutes straight. its definitely not a “its only my headphones” problem. wish they came up with a solution for it.

Hey guys, I seem to have found the solution!!!!
seeing I was not covered by the warranty anymore i took it into my own hands to figure it out. I knew from the beginning it wasn't an issue with software so I looked at the headset itself. I found the issue to be with the USB input. So I ordered some cheep 5-connection USB-connectors (5th one is for the ground cable) on aliexpress and replaced the USB-connector DIY style. IT WORKS LIKE A CHARM!!!! crazy how razer hasn't found this solution or shared it with the community. anyway, hope it helps!

 

edit: 
I believe this will work with all razer/kraken headsets with the same problem!

I have been having the same issue for the last few months, it is incredibly frustrating.
Done the driver re-installs, tried with every USB port that I have and it continues to do the same thing.

Razer can you do something about this??? I got this headset thinking it would last!

i have the same problem

Tried all USB-Ports, re-Install Synapse - nothing works!

Same here, after 2y working fine, have the issues since several month. 

No answer from Razer ?!

It sounds like there might be an issue with the USB connection or the wire that connects the headset to your laptop.

Here are a few things you can try to troubleshoot the issue:

  1. Check the USB connection: Make sure that the USB cable is securely connected to your laptop. If it feels loose, try plugging it into a different USB port.

  2. Inspect the wire: Check the wire for any visible damage or wear and tear. If you see any damage, it's likely that the wire is the source of the problem.

  3. Contact Razer Support: If the above steps don't solve the issue, it's possible that there's a hardware problem with the headset. You can contact Razer support to see if they can provide any assistance or repairs.

Overall, it's frustrating when a new device starts showing signs of wear and tear, but it's important to remember that these things can happen with any product. Hopefully, one of the above steps will help you get your headset back in working order.

Same disconnecting issues here.  My keyboard and mouse are both working fine, fortunately, but the headset will repeatedly disconnect/reconnect with that popping sound.

Can’t seem to find any solutions online and Razer is not responding either.

Same issue here. I’m getting really upset that this is happening because I had just the Razer Kraken headset and used to drag those poor headphones around with me in a laptop bag for transport for years. That headset literally started to fall apart (the padding on the top and around the actual headphone). Which is what made me want to purchase another pair of Kraken headphones, but cuter this time. It’s making me reconsider purchasing Razer products in the future which is really upsetting because I’ve never had an issue with my keyboard or the original Kraken headset, just the Kitty Kraken headset. I really wish there was an official answer and advice on this, since no matter what trouble shooting, uninstall reinstall, different USB ports, updates etc none of it actually fixes the issue since it always returns. 

Keeps on happening to me too. I was initially using it with my laptop and it was fine but using it on my PC makes it disconnect and reconnect and even sometimes mid-game or stream and it makes my whole PC lag. I tried switching ports too since I use a Razer mouse but any other port does the same disconnection issues. Using it on my laptop seems fine tho. Both are updated, on Win10. I’m seriously considering switching to another device if this keeps happening even though I really like the headphones because it is extremely inconvenient

Happening to me too, just started doing it with probably an 8 month old headset. Did the same with my old headset. Probably just poorly made… Idk. 

I have the same issue. It is driving me insane!

I had uninstalled and reinstalled synapse which seem to do the trick for about an hour or two, but then it started again. Now the only to make it stop with the noises is by ending all tasks related to razer. It sucks cause I have a lot of razer stuff and I now all my lovely lights and stuff won't work or my headset keeps popping.. It is obviously a software issue. I really hope razer will fix it soon!

I have the Razer Kranken kitty headset too and the same problem happens to me.. I even went back to the store i bought it in here in denmark and even got a replacement but same problem with this one… i have tried following every single test/thing on this thread that could be the problem but still with no result… the Kranken kitty headset is super comfy and nice but the problem with it is just not making it worth it at all I have had contact with support and with again no succes… I do not know what to do and atm im really seeing this as a thing I lost money on.. If anyone have a fix or anything i might havent tried yet please lmk bc if this is how the headset just is then it shouldnt be sold…

 

Yeah, had the same problem. Sent it in for fixing, it worked for a few months then did it all over again. Doesn’t matter where I plug in the headphones, the problem persists. Honestly, the razer kitty headset suckd, don’t buy from here again.

Bumping this issue. Happening to me too, loud clicking and popping noises as though there are connectivity issues. Audio alternates between headphones and laptop at will. The headphones have been owned for almost two years, but hardly used at all. Please respond, Razer. They are unusable.

Reply