Peripherals (Mouse/Keyboard) disconnect many times | Razer Insider

Peripherals (Mouse/Keyboard) disconnect many times

Show first post
This topic has been closed for comments

179 Replies

From your message i can assume windows detext mouse but synapse dont ? In this case you try to remove all razer softwere then delete files that stay in appdata and programfiles reboot and download new fresh installer from razer website also try to remove mouse from device menager to force new driver installation then unplug mouse and reboot pc plug back you can do this two thigs together, If this dont help you can cheack if the same behawior is on difrent pc this give give more info in future to help you.

I just tried this and it worked, thank you!
I am having the same issue here with a BlackWidow Chroma V2, I am using this at work for programming with a notebook and a docking station. Connecting the keyboard to the docking station causes it to lose connection, connecting it to the notebook directly works. I simply think it draws too much power.

i agree...before i plug my BW Chroma to a docking station....even though the dock has an external power supply i think its not enough (you better make sure the adaptor has enough power and the dock is USB v.3 supported). My keyboard keeps intermittently go on and off. Now i switched to a smaller usb v.3 hub (4 ports) intermittent so far. 🙂
Userlevel 7
i agree...before i plug my BW Chroma to a docking station....even though the dock has an external power supply i think its not enough (you better make sure the adaptor has enough power and the dock is USB v.3 supported). My keyboard keeps intermittently go on and off. Now i switched to a smaller usb v.3 hub (4 ports) intermittent so far. :)

If it has external power then it shouldnt have issues supplying power to the keyboard. If it isnt powered then it would case the issue of disconnection.
(sorry for my english, im not a nativ) bought a new blackwidow elite 2 days ago, after games or waking up out of sleep mode, my keyboard is connecting and disconnecting over and over and over, the only solution every time is to use the small time-window between the reconnects to get to the profile manager in synapse an make an new empty profile and delete the actual profile ... this is really annoying! But sometimes this is also not working, so I have to kill all the Synpse-parts in the taskmanager, unplug an replug the keyboard and restart windows. I already tried the solution in this thread, nothing changes this behavior ... Without synapse 3, I dont have this problem. I really like the keyboard but if the software isnt working I have to give the Keyboard back to the reseller... cause its not working ! (and going to buy a corsair). So can you PLS fix your software razer? cause the keyboard is great but it's useless, when the software isnt working! thank you

edit: it also happens reproducible when my screen turned off and on again
I found out what i causes this behaviour in my case, if I activate the function that deactivates the keyboard led's automatically everytime when my display is turned off, then all this things that I described above will happen. If i turn it off or use the time function, everything is okay ...
I'm on Win 10 and have a similar issue. Keyboard dies all the time, never the mouse. Takes me 5-10 minutes of restarting, removing drivers and so until it pops up again... Really annoying!!!
So here are my new experiences:

  • Connected directly to my work notebook: Keyboard works
  • Connected to a USB switch to use the keyboard on multiple computers:
    If the switch is connected to the docking station, I experinece frequent disconnects
    If the switch is connected directly to the notebook, I experience rare disconnects
    If Synapse is not running, there are no disconnects
  • When I connect my mouse (A Corsair Scimitar Pro) to the keyboard, the disconnects increase
  • My Surface Book 2 and my Tower PC don't have any issues with the keyboard and the USB switch

So my conclusion, especially when having witnessed the increase of disconnects with the mouse connected: The keyboard draws a lot of power. My Surface Book 2 and Tower PC deliver enough power so the keyboard works, but my work notebook does not. When Synapse is not running and the Windows keyboard driver takes over, it uses a lower polling frequency which barely allows the keyboard to function without disconnects, but Synapse 3 does a lot more fancy stuff and stresses the USB a lot more which in turn causes the disconnects.

It's just what I suspect what is happening, maybe someone working at Razer can shed some light into this.

To reproduce this, use a Dell Latitude 5491 and the Dell WD15 USB-C Dock. Connect the keyboard to the dock, connect a mouse to the keyboard, run Razer Synapse and let it sit for a while. You will experience disconnects after a few minutes.
Then, connect the keyboard directly to the notebook, but do not attach a mouse, and let it sit for some minutes.
After that, add back the mouse and let it sit for some more minutes.
Another experience: My USB switch has an additional power input. I ran a USB cable from the docking station of my Surface Book 2 to this power input and it now disconnects far less frequently.
razer nunca mais
razer never again
As many other have done I connected my keyboard to an USB hub with external power. Since I did that I have had no problem at all with disconnects. This is strange as I have a 750w power supply in the computer were I have issues. I have 2 computers, 3 monitors and lots of other things connected to the same power outlet and have a power meter on that. Everything takes no more then 700w.
I had the same problem with my Razer BlackWidow Elite keyboard disconnecting and reconnectig all the time. The solution is very simple - look at macro tab in Synapse app and delete makros that are made by mistake or have 0 binded keys (in my case - all) and the device works perfect after that. I think the issue is that makros are not finished binding causing devices onboard memory not to sync properly and restarting device.
There are no excuses for this #Razer. I am a professional who uses a black widow chroma keyboard and naga epic chroma mouse. Ive been using them for 3 years. Over the last 18 months my mouse has gotten worse and worse. It constantly stops working and I have to unplug and replug into the USB port to get it to start working again. If I uninstall Synapse they work great, no problems, except that of course, I lose everything but basic functionality. I feel like I have given this company a lot of my money over the years regardless, expecting that a large company that commands the prices they do, would have a system in place that can identify problems and correct them.

In the mean time, I have a $10 battery powered logitech mouse (my backup for this one) that works better than my $100+ Razer mouse.

In the time its taken to write this, my mouse has gone out twice.

I had the same problem with my Razer BlackWidow Elite keyboard disconnecting and reconnectig all the time. The solution is very simple - look at macro tab in Synapse app and delete makros that are made by mistake or have 0 binded keys (in my case - all) and the device works perfect after that. I think the issue is that makros are not finished binding causing devices onboard memory not to sync properly and restarting device.

Do you mean "O" (letter) or "0" (zero)
Userlevel 2
So, I believe I just solved this issue.
I have been having the same issue since getting a new laptop. At first I thought my USB hub was bad. I replaced it. No go. Later I realized that after I rolled back to 2.0, the problem was much less frequent. But, it still occurred.
It's obviously a power issue. So, I was hoping that changing the power setting as suggested would fix it. No go.

Finally, I stated just going through EVERYTHING in device manager. And I found that there are OTHER PLACES where you need to uncheck "allow windows to turn this device off to save power".

First, I did everything already suggested in this thread. I went through all the USB devices and clicked the power management tab and unchecked the "allow the computer to turn off" boxes.
Then I went to the power management and usb settings and disabled the "usb selective suspend" for both on battery and plugged in.

FINALLY, I went back to device manager and went to Human Interface Devices. I clicked on every razer device there and unchecked "allow the computer to turn off" boxes on the power management tab.

So, you have to do it in the USB section, AND in the HID section where it shows your razer devices. I rebooted... and it hasn't done it as single time since. And I'm running synapse 3.0 again.

Hopefully this will help you. It fixed it for me. Kinda redic that I had to do this, and I am 100% positive that it has something to do with Razer's software because the issue DOES NOT OCCUR prior to installing synapse software.

So razer... get your ish together mang.... this is just stupid.
Userlevel 2
Scratch that. It's back to disconnecting constantly again today. I checked all the boxes, they are still unchecked (the power management boxes). Razer... Come on. You charge a small fortune for your crap, I really expect it to work better than this.

I have a question. How many in this thread that are having the issue are using laptops?
There is no real solution other than pluging into your USB ports on your laptop, clearly I think this is a software problem that complete makes all Razer products unusable on any usb hub powered even with 230w unless it's a Razer Core or an overprice TB3 hub. If it's a power problem, Razer should have had a warning that X product needs more power or just plain disable the lights automatically. I guess Synapse 3 still has the "bug" just to make you spend more without a solution.
I also have the same issue on a Lenovo laptop with a Lenovo docking station. I have an Ornata Chroma, a Mamba Tournament Edition and a Firefly Hard Edition. I am not a gamer, just liked the keyboard click and bought the mouse and mat for the "coolness" factor.

However, the user experience is awful. I have the same issues reported in the thread, tried the work-arounds suggested here and in other fora, opened a ticket with the Razer user support but at the end of three weeks email exchange I did not get a solution, only generic suggestions (update the OS, reinstall Synapse etc) and finally an invite to replace my docking station (it is brand new) or to connect the peripherals directly to the laptop. The most disappointing thing is that I did not get any sound technical explanation for those suggestions. And connecting two out of three devices to the laptop did not work either.

In any case, I do not think this is a power issue.

Assuming the technical specifications reported on the bottom of each device are accurate, the mouse rating is 5V at 250mA which gives 1.25W. The keyboard rating is 5V at 330mA which gives 1.65W. The mat rating is 5V at 150mA which gives 0.75W. Together they give 3.65W power consumption.

The docking station has a 90W power supply and according to the specs "Can charge mobile devices with 15W and 10.5W from USB-C port and USB3.0 always power-on port respectively". So there should be plenty of available power, assuming it is correctly delivered to the devices.

To me the issue looks more caused by a "creative" use of the USB protocols to allow the Synapse software to allow doing all the magic with the lightning and the devices' extreme configuration capabilities.

I suspect that in particular conditions (which could also include the hardware configuration, which USB controller is used etc) this might upset the USB driver causing continuous disconnection/reconnections. Or perhaps a IRQ conflict. Who knows.

Unfortunately I did not get any technical clarification from Razer despite I sent them the devices' logs and my availability to provide them with further system logs, USB dumps etc (as in the pic)

In my very personal opinion, this might be a known issue, possibly limited to a relatively small number of users, which they do not intend to fix especially if this possible "non-standard" use of the USB protocol is what actually enables the majority of systems to work as they do.

I would however love to be surprised and see the problem disappeared after a SW update at some point.
Hi Guys

I've got a Razer Ornata Chroma, Razer Mamba Tournament Edition and a Goliathus Chroma.

I have had this issue for awhile now and have tried every single solution on this forum including a reload of Windows, removing the driver files, reinstalling, etc. etc. etc..... to no avail.

I have tried both a Coolermaster laptop stand and a Deepcool, the Coolermaster modular stand allows for a 3.5v external PSU to be connected to the USB hub. With and without the external power the same issue occurs. Same thing with the Deepcool, however it became less frequent funnily enough, with just a back to back USB 2.0 cable. While the USB 3.0 cable as I understand it allows for more power to be drawn, still don't think its a power issue.

Are there any working solutions on the horizon @Razer??? Pretty ridiculous to get fully kitted out and then to have this issue.

I am even willing to buy a USB hub that will work at this point, any suggestions around that guys?

Will connecting it directly to the laptop help? I know its quite crude but anything is better than this.

Is it possible to downgrade your version of Synapse, it seems that an update creeped along towards the beginning of the year because for a few months there were no issues. May even be a Windows update, however I doubt that considering Synapse 3.0 has done far more updates than Windows.

I know its a ton of questions in one post but any help will be appreciated.

Hey all.
I am having the same issues as everyone else with a Blackwidow X Chroma Gunmetal Grey, Naga Trinity and Goliath Extended Chroma. Have Synapse (3.4.512.51410) , Cortex ( and Central ( installed

Random disconnects of all 3 products at any stage of using the PC; Gaming, office, unlocking to windows. I have also notice it disconnects when changing profiles (gaming to office based work)

Whilst the disconnect and reconnect are fairly instant, its fairly annoying as well. All 3 devices disconnect.

Whilst the software was installed i tried the fixes with Disabling USB Selective Suspend Setting In Power Options. In control panel -> device manager, disallowed any type of power management on all USB and Human Interface Devices.

Still disconnecting. Tried all combinations of USB ports both on PC and on USB Hub. Same thing happened.

Remove all stated Razer software and there are no more disconnects.

Oddly enough, i never saw as many disconnects as when i added the Razer Goliath Extreme. Prior top this when i only had the mouse and keyboard it was 1 or 2 a week. Once the mat was introduced, its probably 20 disconnects a day. I want to add some Razer headphones but have canned that idea as interrupted sound would be the ultimate annoyance.

I think i am more emotionally disappointed after researching and investing in Razer. It looks and behaves like a premium product. If only i had researched the underlyingsoftware issues, i would have thought twice about these products. COME ON RAZER. On my rig, its your software causing the issues.
And now it started again... As I wrote last time I added an external USB hub and the issues disappeared.
Suddenly yesterday the issues started again, just out of no were! I didn't update anything just playing my games as usual..
I'm thinking of just exchanging all my Razer products as this does not seams to be addressed/fixed!
I've tried every option listed here. USB selective suspend is disabled, Windows cannot turn off USB powers. Updated drivers, removed all un-needed software. deleted EVERY disconnected hardware piece in device driver. Uninstalled all RAZER Synapses programs (2 and 3).....and everything worked. As soon as I rebooted, Synapses re-installed....and all the issues came back.

I've currently got my Golaith and Mercury White Base stand unplugged, as soon as I plug them in, issues pop back up.
Userlevel 2
So, I had an interesting experience this weekend. I too my new laptop, the one I'm having a problem with, to my office. I was meeting up with some friends to play some games at my office. Normally, I just work on my workstation at my office. But, my workstation isn't a gaming rig. So, I brought my Predator Helios 500 with me. I actually set up at one of my other employee's cubicles. My brother set up in mine. The guy who works for me also has a razer keyboard. But, not the same chroma I have at home. He has the blackwidow. So, just the standard green lighting... no chroma effects.
I just figured I'd use his keyboard while I was there. Guess what. CONSTANT DISCONNECTS! Worse than at home with my Chroma keyboard.

So, I was doing some additional digging. I think I may have stumbled on to something. So, on my old laptop (an ASUS ROG), I tried to hook my chroma up through a USB3.0 hub, and had disconnects. But, if I jacked straight in... zero. On my new laptop, I have disconnects regardless, but far less when plugged straight in. When plugged straight in, I just get the windows notification noise, and the lights reset. When plugged into the HUB, I lose all connectivity for a solid 5-6 seconds. Here's the thing... my old ASUS ROG had a mix of USB2.0 and USB3.0 ports. When I was jacked straight in with my keyboard, I used the 2.0 ports. No disconnects. My new laptop ONLY HAS 3.0, and USBc ports (also 3.0 protocol iirc).

Other people on the net have been having issues with disconnects on 3.0 ports. So, my theory is... something in the way they use the protocol, or the devices themselves, are not 100% compatible with 3.0 USB ports. Now, if this is fixable or not, I do not know. It may also be their effort to force you to upgrade. All I know is, it's getting really really fast. If this cannot/will not be fixed, my next keyboard will NOT be razer. Matter of fact, I'd pretty much be done with their devices all around. This is absolute garbage support for a problem that is OBVIOUSLY theirs to fix. HIGHLY disappointing considering the cost of their devices.
Same issue here. Im using predator helios 500, tried every fix the internet can offer but still no luck. Tried replacing my usb 3.0 powered to usb 2.0 powered and still same results. Been doing these troubleshoot for a month and im tired of it, i might sell those and replace a corsair setup.

Heres my junk razers:
Huntsman elite
Tartarus v2
Firefly HE
Goliathus extended chroma
Base station chroma
Kraken pro v2
Mamba elite
I have open ticket for 3 months now and nobody from Razer Dev team replied. Support told me to wait for dev team to check my ticket. I provided all logs and did everything on my side. There is no fix for this. Synapse 3 cause all of these problems.


Going to live chat agent support told me just wait we dont have any information. Its total bs and whats funny nobody from razer even check these forums or reply to threads related to synapse 3.0.

I wanted to switch for logitech but their ghub is even more buggy then synapse 3.0.