Synapse won't open

Discussion in 'Razer Synapse' started by saboo.tage, Jul 28, 2018.

Tags:
Thread Status:
Not open for further replies.
  1. sotmead

    sotmead New Member

    Confirmed, it wants the 1903 feature update of win10 to work. I updated and now Synapse runs.

    Glad I found this keyboard at a garage sale.
     
    ARMOR_152 likes this.
  2. csills89

    csills89 New Member

    mine wont even install yet. since last june it quit responding with a error of mscorlib.dll error
     
  3. csills89

    csills89 New Member

    heres synapse 2 installed, and then 3 trying to install. I have the latest C++ visual studio installed and also reinstalled win10 over 15 times, with hardware swaps. Can you answer that one? Because my mouse requires drivers to use the DPI "IN GAME" especially when I PLAY FOR MONEY

    https://imgur.com/jVQ051A
    https://imgur.com/bnKdPQv
     
  4. webnebular

    webnebular New Member

    This thread sums up my whole experience with Razer. No response from support 4 days later. This is basically a how to guide on how to destroy your user base.
     
  5. csills89

    csills89 New Member

    Yep. I'm going to swap my psu and hopefully I won't get errors with the applications. Someone told me it could be it's dropping voltage from my 850w corsair. Yes it turns off and on fine but has anyone else experienced a psu causing applications to throw errors?
     
  6. XDFuZelXD

    XDFuZelXD New Member

    I closed everything on the task manager and finally after starting razer Synaps it opened
     
  7. KOBAPHbIU_KRAB

    KOBAPHbIU_KRAB New Member

  8. Marco4u

    Marco4u New Member

    hi to all
    when i download Razer Synapse 2.0 i need to login. after i have loged in i cant open the app. does anyone know how to fix this :slightly_sad:
     
  9. bussoloIvory677

    bussoloIvory677 New Member

    Same Problem here, with Razer Synapse 2.0.....
    If I won't find a fix, I will send the hardware back. I'm a software developer and I tried a few things to make it work :/
    I can start Razer Synapse 3, but this version doesn't support my Wolverint Tournament Controller, which is really sad.
     
  10. Silumi

    Silumi New Member

    Well, it is 2019, I just bought my mouse and I have the same problem without finding a solution.
    Everything just tells me to reinstall but that doesn't work. It never opened in the first place, not the Synapse 3.0 and also not the Synpase 2.0. Considering that I just spend 70 Euro or so on a mouse I would expect the software to work. After reinstalling like 5 times by now the Razer Central by the way also disappeared for unknown reasons so yeah..
     
  11. bussoloIvory677

    bussoloIvory677 New Member

    Well, I just contacted the support, and wrote what I already tried. Let's see what they answer.

    I reinstalled the software, removed all razer related folder and files.
    Installed with/without connected controller
    Let the software update / don't let the software update
    Run in several compatibility modes
    Run as Admin and with or without compatibility modes

    And of course did a couple of reboots inbetween those actions..
     
  12. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    For everyone whose problem relates to software issue, there are so many factors of troubleshooting. It sure can turn out a easy fix or a messy fix; if you are a windows user, try remove all RAZER applications, create a new administrator account and reinstall from it.

    Sometimes, purchasing new computer from well known brands like HP or Dell, they always come with pre-install softwares I like to call "patriotic absurd". The softwares they say "will protect your pc" but infact it is for their own brand advertising purposes, which can cause conflict with Synapse. Remove all of them.

    As a person who have been working on PCs for years, sometimes the best solution for any software related issues, is to reinstall the OS and start from scratch.
     
    ARMOR_152 likes this.
  13. bussoloIvory677

    bussoloIvory677 New Member

    Thanks for the hints. I tried a new administrator account. But it shows the same problem. I don't know if I do a fresh reinstall, since this is my development system, on which I would need to reinstall everything and reconfigure.
     
  14. bussoloIvory677

    bussoloIvory677 New Member

    For everyone with a Razer Wolverine Controller. You don't need Synapse 2.0 or 3.0. Just download "Razer Synapse for Xbox" from the Microsoft store. It runs fine on Windows 10 and you can configure the controller. Razer support helped me in that case.
     
  15. JoelJ444

    JoelJ444 New Member

    "As a person who have been working on PCs for years, sometimes the best solution for any software related issues, is to reinstall the OS and start from scratch."

    Re-formatting the hard drive and reinstalling Windows from scratch is really not a viable solution to what amounts to simple software issues. It's kind of like saying, "If your car's gas mileage is poor, replace your entire engine." There are better ways to troubleshoot driver and software issues than reinstalling windows. I'm not wiping my entire operating system just because of some irksome issues with my mouse and/or keyboard.
     
    CivilUnrest87 likes this.
  16. xARACHN1D

    xARACHN1D Well-Known Member

    You completely forgot the part where it might not be synapse. It might be you having other programs interfering with synapse. SO to your analogy, It would be more like "Oh I have something in the engines intake that I cannot get out. Now I have to replace the motor. And it will actually work"
     
    Sye_The-Vie likes this.
  17. JoelJ444

    JoelJ444 New Member

    I've always found the problems surrounding Synapse to be relatively minor and I've never been unable to fix them, and I've never even come close to wiping out my operating system to fix such minor problems. And for what it's worth, I've also never replaced a motor in my car ;)
     
  18. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    Learn about the regedit and OS source files
     
  19. moeverton1989

    moeverton1989 New Member

    Hi,

    I had this problem with Synapse2.0. I did everything just like you. today i found an old Synapse2.0 installer from 2018 on my computer. After remove the software, restart the pc, install this "old version" synapse2.0 and restart again everything runs OK now, my Blackwidow 2016 and my Orbweaver V1 (and the software itself) runs normally.
     
  20. SoggyToast115

    SoggyToast115 New Member

    I am having the same issue. I have only had my laptop since August of this year. Dissapointing since the laptop was almost $2K.I expected flawlessness for a few years.

    I also have an issue with the laptop lid not closing properly.
    The left corner, when closed, is not staying closed. It is about 1/4 of an inch above the base of the
    laptop. Essentially, it is leaving a gap because of the left side of the lid not wanting to stay closed. I'm assuming the magnets that are supposed
    to hold it down seems to have weakened or demagnetized. The right side of the lid's magnet has a much stronger attraction force when opening the lid.
    It was not like this when I first unpackaged the device.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >