System not receiving "Adequate Power" | Razer Insider
Question

System not receiving "Adequate Power"



Show first post

157 Replies

 

Took a entire month but they finally fixed, I just updated my Synapse and is working normal for me 

I installed the latest update that came tonight and I still getting same error about the power. 

same issue with my razor 15 base model, just summited a case 230630-000715  @Razer.Speedcr0ss 

Updated to version 20230704 and problem solved

Luck you guys who got latest update and issue was gone.

 

 

I updated to the latest Synapse 20230704 however I still have the issue on my Blade 15 2020 Base Model sadly too.

I restarted my computer and it worked so idk why it still occurs.

I restarted my computer and it worked so idk why it still occurs.

Did try that too just to be sure and even done a fresh removal/reinstall but still no luck

Last update solved the issue (blade 15 base model 2020)

Don’t know if this helps anyone but make sure you are running your laptop without any docks or anything that might have power-through USB-C - and only run your laptop on the Razer Charger. (to troubleshoot) 

I’m dealing with the same problem and have the latest updates, but I noticed I was getting this issue for two reasons:

  1. Either the laptop is deciding the USB-C is primary for power supply...or
  2. There is an issue with the charger/connection

After quite a few tries where the laptop did not recognise the charger even though everything pointed at it being in working order I got it to connect/charge constantly (so far) but when it gets to 100% windows keeps switching the icon from “on battery” to “Plugged in” and I can see the key lights reacting to that (so not just an animation issue). *Windows11

**by got it to connect I mean simple stuff. Left the battery to drain a bit and then charged it from the USB-C after which I performed a couple of restarts on both my OS that are on the machine. 

Userlevel 1

Update: Assumed mine was fixed since the error message went away with a factory reset. I was mistaken, the issue is still there and the error messages just go away until you install cortex again.

At this point I have;

  1. Completed the F9 factory restore 3 separate times and run benchmarks each time.
  2. Downloaded a NEW factory recovery image from Razer support and installed twice.
  3. Checked power delivery with HWinfo and other software (All check out good)
  4. Attempted Windows 11 upgrade after resetting to Windows 10 to see if that would help.
  5. Purchased a new 230w power supply.

This seems to be some sort of BIOS issue with how the power is perceived internally for the GPU. I am sure others have had performance gimped they just don’t know it if they don’t have cortex delivering the error messages or compare benchmarks.

 

 

Hmm I was wondering this.  I have my grand children visiting and not time to do full performance checks or game but there was an update this past week put our from razer and the message went away and in synapse I now show gaming mode.  Makes me smile to see that but I was wondering if it was a fix or just cover up to make the message go away.  I”ll run some tests in a couple weeks when I don’t have 4 children hanging out with me.  My grand children are all pretty happy with my new gaming desktop though. So it does let me set gaming again and I will take the time to measure other ratings.  The PC Benchmarks measure okay as expected.  I’m not a fan of the benchmark program as it skews results averages at times.

 

Userlevel 1

At this point all I can say is that I will not be purchasing another Razer device ever again. This was my 10th Razer branded laptop and the issues over the years have progressed exponentially with hardware and software failures. No with this one being a complete software / BIOS failure and a $3000+ PC that is essentially  a paperweight at this point I AM DONE. This is the type of failure that results in mass litigation & class action suits (Apple for example). Over a month with no fix, for a software update they released… F’ing REALLY?

 

 

I would advice you to check your power profile settings in Windows. Sometimes, incorrect power settings can limit the laptop's performance. Make sure the laptop is set to "High Performance" mode. To do this, right-click on the battery icon in the system tray, select "Power Options," and then choose "High Performance."

Userlevel 1

I would advice you to check your power profile settings in Windows. Sometimes, incorrect power settings can limit the laptop's performance. Make sure the laptop is set to "High Performance" mode. To do this, right-click on the battery icon in the system tray, select "Power Options," and then choose "High Performance."

 Been over that several times, and Razer knows the issue (See screenshot above) it’s something that was caused by the Razer software they just haven't prioritized a fix for it, so me and a multiple others are running laptops with NO functional GPU.

Another update came 20230731. Still didn’t fix my Blade 17 2022.
 

 

Userlevel 1

Another update came 20230731. Still didn’t fix my Blade 17 2022.
 

 

 

So after reading through all the messages I have from Razer support what appears to be happening is that the logic behind Synapse performance modes is checking the hardware and those of us that have “230W” power bricks are being handicapped. Since ALL the new Razer Blades come equipped with 280W & 330W power adapters the logic has those listed as the adapters required for the “Performance” modes.

 

Essentially this is what Apple did as planned obsolescence years ago with there iPhone battery's and lost a multi million dollar class action suit. As of now myself and a few others have sent this info to Linus Tech Tips & Gamers Nexus to do a story on this because it affects anyone who purchased a Razer Blade with a 230W power brick.

Oh wow, such a news. Well, I don't mind of razer would send everybody the 280W brick. 

Userlevel 1

Still ZERO resolution from Razer 

I just bought 280W charger and issue gone. End of story. Razer 🖕

Userlevel 1

I just bought 280W charger and issue gone. End of story. Razer 🖕

 

I might have to do the same thing just to sell it off… F’ing INSANE

Same issue using the Razer power adapter it came with. 

 

So after reading through all the messages I have from Razer support what appears to be happening is that the logic behind Synapse performance modes is checking the hardware and those of us that have “230W” power bricks are being handicapped. Since ALL the new Razer Blades come equipped with 280W & 330W power adapters the logic has those listed as the adapters required for the “Performance” modes.

I can confirm this. I have 230W supply with my Blade 17 2022 and same issue for months now. Before that it was another Synapse issue with constantly eating resources, making the laptop unusable for longer sessions. For such a premium you’d think you’d at least have basic use of the laptop with the advertised performance.  I’m not sure I will ever get a Razer again, probably first and last.

 

If they don’t do QA on their software releases with recent (not even old) hardware, that’s just bad cost cutting. And if they do it but miss such major issues, that’s even worse incompetence I’d rather not deal with.

 

they are working on a fix

 

 

@Razer.Speedcr0ss  @Razer Admin I don’t understand why you or any razer support has bothered to comment on this if I am being honest I see countless threads of users who are having the same issue across multiple laptop platforms and you guys have done nothing to update the userbase or anything. This is not just a one off problem. Don’t get me wrong I enjoy your laptop’s but I don’t enjoy nore does anyone else llike paying over close to 6 grand just for my “gaming” laptop to play games like a 200$ tablet, As countless users have said the gpu will not pull more than 40 watts , we also are not able to enable any gaming modes at all because it keeps saying “system not receiving adequate power” yet having orginial power supply’s , third party and replacements this makes gaming impossible and the money we spent worthless. I have seen countless posts , replies and comments about this. It is also happening to me as well. You say open a support ticket or PM you to contact support yet once we do contact support we get nothing to get ignored our tickets or cases closed or “We will release that in a further update” yet its been almost a year. I find this extremely upsetting and outright disrespectful. Do better razer or at least anknowlege us. Please help US.

Reply