Ryder Synapse 3 40 to 100% CPU usage WMI Provider Host | Razer Insider

Ryder Synapse 3 40 to 100% CPU usage WMI Provider Host

  • 22 December 2022
  • 95 replies
  • 4675 views


Show first post

95 Replies

No new version found when I check for update.

 

 

Same, no new version. I am in Italy

 

 

 

 

I didn't really download the so call new update. This are the software versions that I am currently using. It seems got to do with Razer side (not very sure).

Userlevel 2

 

I didn't really download the so call new update. This are the software versions that I am currently using. It seems got to do with Razer side (not very sure).

You are still on the old CPU hogging version 3.8.209.20311 Synapse

 

 

Try check for updates again guys. I just updated it with the latest version.

 

 

Userlevel 7
Badge +1

If I decide that the required logs are too privacy invasive and do not feel comfortable providing  them, the ticket will not be investigated.

You can unpack the Support file, as it’s zip archive containing a lot of txt files / logs. So you can check and decide if it’s privacy invasive or not :)

The WMI activity logs do indicate to below errors. There is possible resolution below.

 

https://learn.microsoft.com/en-us/troubleshoot/windows-client/system-management-components/wmi-activity-event-5858-logged-with-resultcode-0x80041032

 

I’ve attached screenshot of errors and also CSV export of WMI activity log in below link.

https://easyupload.io/m/25qk1o

 

I’ve researched and same problems have occured to other manufacturer software like Alienware, Asus. Even non gaming like VMware.

 

It is the way the software polls via WMI of the hardware. Whilst it may or may not be resolution. Certainly something Razer can look into.

 

It may be just that Windows itself is the problem since other manufacturers have faced same problem.

 

Alternatively just provide Razer update that simply allows turning off WMI requests after Razer services start because if I disable WMI service entirely I can still control lights, fans, macros, DPI etc without it. But I would rather not disable WMI service itself because it is still required by windows or other applications that rely on this. If can’t solve then it is a way around it. Disable WMI requests coming from Razer software after Razer services started because it certainly isn’t required afterwards to control RGB, cooling fans, macros, DPI on mouse etc. I’ve tested it.

 

This error can happen if the WMI application calls IEnumWbemClassObject::Next with a timeout value (lTimeout) that is not long enough to retrieve the object being queried, and is not checking for a return code of WBEM_S_TIMEDOUT (0x40004) in order to issue the request again.

Resolution
The WMI client application should be modified to issue calls to IEnumWbemClassObject::Next to retrieve the full result set, before releasing the IWbemContext object. If no objects are received, make sure that the timeout value (lTimeout) is greater than 0 and that WBEM_S_TIMEDOUT (0x40004) is not being returned.

 

@Razer.Zionzedd  I received an email from you on 20th Feb to use Razer Log Collector software. I re-created the WMI errors and used it to capture logs as per your request. I’ve attached in link below.

https://easyupload.io/qbjwac

 

Userlevel 2

But the timeline does not quite add up though.

 

The Microsoft KB is dated 09/23/2021, so this WMI change must have been changed a while ago.

 

In my own case, I did not have any Windows Update at all, I only had Razer update, then this CPU hogging issue started happening.

 

But the timeline does not quite add up though.

 

The Microsoft KB is dated 09/23/2021, so this WMI change must have been changed a while ago.

 

In my own case, I did not have any Windows Update at all, I only had Razer update, then this CPU hogging issue started happening.

 

The microsoft article states WMI client application, so in this case Razer software is sending WMI requests and causing constant loop.

  • If you Stop the WMI service completely.
  • Right click in services.msc and select "pause" then "stop"
  • Check WMI service still stopped
  • Now load up Synapse 3. Can still change RGB lighting, macros, cooling fan, mouse dpi and mouse poll rate.

https://devicetests.com/mouse-rate-test (To check poll rate. Only applies to Wireless dongle/wired mice as Bluetooth has 125hz limit)

However disabling WMI service completey causes problem only on next reboot. i.e. It only holds my mouse settings from last time and can't change on demand anymore, even after starting WMI service again.

So WMI service is still needed initially only, but not thereafer for Synapse to work.

I bet if everyone loads up their WMI activity log it will look like this: ResultCode=0x80041032

 

 

 

Also people can match the process ID in log to Razer process in task manager.

 

 

Userlevel 3

I’m seeing this too.

same here.

Uninstalled Razer Synapse immediatlly the CPU hogging is gone and CPU temp dropped 10 degrees. Is someone from razer is taking a look at this issue?

Userlevel 2

It seems both Razer Central and Razer Synapse are now updated.

Razer Central 7.9.1.485
Razer Synapse 3.8.228.22313
 

Userlevel 2

Someone has responded via a new thread here.

https://insider.razer.com/razer-synapse-29/synapse-3-high-cpu-wmi-provider-service-43747

Userlevel 3

and its fully functional on my end as well.

Happy to report the issue has been resolved for me as well.

This is what synapse does all the time in WMI, I've noticed. it repeats this loop all the time.

548452_36d5808365efb3054720db2128b6fccd.png548453_62e7f62df0d5079ec543c408359b3a10.png

 It is trying repeatedly to scan for PnP-devices and enumerate them … i.e. count and identify them if they are known or new... thus hogging CPU cycles as it never “completes”.  

Anyone in the same situation??? For me it’s not only the razer central service but wd discovery and nvidia share too…….

It’s funny because even with all the razer services stopped and the headset still working, I still having hicups and sound cuts randomly (it didn’t happen before the update playing the same games btw). Basically the update broke a lot of the CPU management for the device lol

Userlevel 7

Hey Peter8UKXRaiderV1XpolySandyBrownAPATITE018ivan.yupgtest70AchillesGR and Navylian! And yes, Razer is aware of the application’s behavior, and our devs are actively working on a fix that should be released via Razer Synapse updates in the future. We recommend checking for any available Synapse updates regularly. We also need your cooperation in submitting your Synapse logs and MSInfo to our Support Team through this link. Ensure to collate and upload the files to any online hosting sites and paste the shareable link in your message. Feel free to send me a ping or visit our self-help options should you have other questions or concerns.

Related links:

Razer Insider Thread: https://insider.razer.com/razer-synapse-29/synapse-3-high-cpu-wmi-provider-service-43747
Reddit Thread: https://www.reddit.com/r/razer/comments/118o9ok/synapse_3_high_cpuwmi_provider_service

Userlevel 3

@Razer.Speedcr0ss  already submitted my logs yesterday

Reply