Nanoleaf Pairing Tool - Broke Chroma.

Discussion in 'Razer Support' started by Zeaig, Nov 17, 2018.

Thread Status:
Not open for further replies.
  1. Zeaig

    Zeaig New Member

    So, a while back i had an issue where my Chroma had stopped syncing with games and apps i had no idea what caused it, Re-Installing Synapse 3.0, and various drivers seemed to have no effect fixing it so i basically lived with the fact for a good while that my Chroma would not sync with Overwatch or the audio visualizer for example.

    Fast forward months later, i reformatted my PC and everything was working again i hooked up my Hue Lights to sync with my Razer peripherals all was well, worked with Overwatch and the visualizer, i decided to install the Nanoleaf Pairing tool to see if i could Sync my Aurora panels, which did not work but caused a nasty side effect of Chroma no longer working just like before. I can change the lighting effects manually such as wave or spectrum cycle but any of the automated app related stuff will not work.

    Basically long story short, I am positive this is most likely what caused the issue both times. The Nano Sync tool makes chroma no longer work with apps and programs and i don't know how to fix it without reformatting my PC does anyone have any solution? Is there some sort of cache that the application has left somewhere causing a conflicting issue with Synapse? Re installing Synapse does nothing.

    I removed the Nanoleaf program i unpaired it from my PC it didn't work anyways.
     
  2. Razer.FirePenguin

    Razer.FirePenguin Keeper of the Flames, Bane of Sardines Staff Member

    Hi! Have you tried checking the Chroma Apps tab in Synapse? That would give you the option for turning app specific Chroma on or off.
     
    freakydoctor likes this.
  3. VizardXY

    VizardXY New Member

    Hey man, you are ABSOLUTELY on to something here.

    I have been working with tier 1, tier 2, and now directly with the Dev team for support on this issue for weeks if not months.

    Anytime I launch a Chroma App, it crashes the SDK. If I restart the SDK in services, then launch a Chroma App again, it crashes again. Overwatch will crash each time I try to start the game until I terminate the Chroma SDK service.

    I've also been unable to get Synapse 3 working on my computer at all. Here is my video of those symptoms:


    Here is what event log reports for when the Chroma SDK crashes:

    Faulting application name: RzSDKService.exe, version: 2.0.5.9, time stamp: 0x5a557afe
    Faulting module name: ucrtbase.dll, version: 10.0.17134.319, time stamp: 0xc1f0557a
    Exception code: 0xc0000409
    Fault offset: 0x000a24cb
    Faulting process id: 0x2898
    Faulting application start time: 0x01d48152735c882f
    Faulting application path: C:\Program Files (x86)\Razer Chroma SDK\bin\RzSDKService.exe
    Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
    Report Id: aabd6622-cc33-4978-9e2f-4f0ff34fcdba
    Faulting package full name:
    Faulting package-relative application ID:


    Here's more details that came with the crash:

    Fault bucket 1465443046259025242, type 5
    Event Name: BEX
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: RzSDKService.exe
    P2: 2.0.5.9
    P3: 5a557afe
    P4: ucrtbase.dll
    P5: 10.0.17134.319
    P6: c1f0557a
    P7: 000a24cb
    P8: c0000409
    P9: 00000007
    P10:

    Attached files:
    \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB6BE.tmp.mdmp
    \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB72D.tmp.WERInternalMetadata.xml
    \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB73D.tmp.xml
    \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB74D.tmp.csv
    \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB75E.tmp.txt

    These files may be available here:
    C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_RzSDKService.exe_5f781cabbd1e4529a2ee93f168b8fa448783584_72f2cf49_225dba87

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: 277ab2a8-87c8-4033-8971-c4f974bbfeac
    Report Status: 268435456
    Hashed bucket: d8c1cfd27511800164564cafb2d5e55a
    Cab Guid: 0



    I have gone back and forth with Synapse 2 and 3 so many times removing every trace of Synapse from my computer each time (reg keys, C:/ folders, drivers, etc), and nothing is seeming to fix this. Ran sfc /scannow to check for corrupt Windows files and everything reports normal.

    I wonder what the nanoleaf Pairing Tool does to your PC? Does it install something somewhere?
     
    Last edited: Nov 22, 2018
  4. VizardXY

    VizardXY New Member

    After doing an entire search of my C:/ drive for "nanoleaf" the only file that comes back is a log file that contains this:


    1,"fusion","GAC",0
    1,"WinRT","NotApp",1
    3,"System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089","C:\WINDOWS\assembly\NativeImages_v4.0.30319_32\System\ef92fd4410d6b1e5d4b768767ad05aaa\System.ni.dll",0
    3,"System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a","C:\WINDOWS\assembly\NativeImages_v4.0.30319_32\System.Drawing\08626441fe724b1934292c3f853032a6\System.Drawing.ni.dll",0
    3,"System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089","C:\WINDOWS\assembly\NativeImages_v4.0.30319_32\System.Windows.Forms\23d50fb89fbdff6e8c2eaf3fa5afb8e3\System.Windows.Forms.ni.dll",0
    3,"System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089","C:\WINDOWS\assembly\NativeImages_v4.0.30319_32\System.Core\80902f10241caeaa71d97ea6c88115a1\System.Core.ni.dll",0
    3,"System.Configuration, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a","C:\WINDOWS\assembly\NativeImages_v4.0.30319_32\System.Configuration\dabffeccb3ff451b4f21a9cfd08193d6\System.Configuration.ni.dll",0
    3,"System.Xml, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089","C:\WINDOWS\assembly\NativeImages_v4.0.30319_32\System.Xml\cc3865159952f5c1821a3af6916363b0\System.Xml.ni.dll",0


    I'm desperately trying to find out what the NanoleafPairingTool does to your PC when you run it.
     
  5. Razer.FirePenguin

    Razer.FirePenguin Keeper of the Flames, Bane of Sardines Staff Member

    Did the Dev Team already ask for the logs from you? I would highly recommend continuing to communicate with them as they are the ones who work specifically with this.
     
    freakydoctor likes this.
  6. VizardXY

    VizardXY New Member

    They should have the link to them, yes. But i haven't been notified that they have been downloaded yet.

    I haven't had any communication with any devs directly yet. I've reached out to chat support and they've reassured me the devs are looking into it and I should hear something within 24-48 hours but that came and went.

    Here are my logs:
    https://app.box.com/s/a3w3jnc0evm9igml62sgbq23myptmkkq

    Thanks.
     
  7. Razer.FirePenguin

    Razer.FirePenguin Keeper of the Flames, Bane of Sardines Staff Member

    I see. Thank you for sharing the link for the log files. I did a follow-up and the Dev team should be already in the process of reviewing it.

    Also, for security purposes and for your privacy, please edit your earlier post that contained the case number. :)
     
    freakydoctor likes this.
  8. VizardXY

    VizardXY New Member

    Alright. Thanks.
     
  9. Razer.FirePenguin

    Razer.FirePenguin Keeper of the Flames, Bane of Sardines Staff Member

    You are welcome! If you need assistance with anything else, give me a message. Cheers!
     
    freakydoctor likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >