New Razer Blackwidow v4 typing repeating issue | Razer Insider
Question

New Razer Blackwidow v4 typing repeating issue


All the keys are repeating sporadically when I type. Sometimes it has no response when depressed, such as the arrow keys or punctuation keys. I have to spend a lot of time checkingg the spelling and missing letters.

If there is any typo here it is because I gogt fed uup on correction.


63 Replies

Just chiming in to say i have the same issue, Black Widow v4 75%. This is ANNOYING as hell!! I saw they released new firmware for the other V4 boards just not this one and it REALLYY needs to be fixed!

Just chiming in to say i have the same issue, Black Widow v4 75%. This is ANNOYING as hell!! I saw they released new firmware for the other V4 boards just not this one and it REALLYY needs to be fixed!

I just sent back my second blackwidow v4. I can tell you that the firmware won’t do anything.
First keyboard had the a,e,i and enter spam,
The second had the a,e,i,y and backspace,
The firmware made the y go away but than the backspace started to spam.
With this it’s clearly a software issue but they lack the interest to fix it

All the keys are repeating sporadically when I type. Sometimes it has no response when depressed, such as the arrow keys or punctuation keys. I have to spend a lot of time checkingg the spelling and missing letters.

If there is any typo here it is because I gogt fed uup on correction.

Same issue here, specially letter “o”. It’s annoying!

same problem, seems to be getting worse by the day. the ‘a’ key repeats very often, and others are starting to repeaat as well (leaving typo as-is to show whats haappening). 

I aalso get a lot of issues with the enter key not registering when I press it, or it x2/x3 times registering. The keyboard is simply not usable :( such a shame for this expensive of a device. I regret the purchase big time. Anyone who runs into this, just stay away from the blackwidow v4 75% until the issue is clearly resolved if ever.

 

Does this also haappen with the larger blackwidow v4 and v4 pro?

Does this also haappen with the larger blackwidow v4 and v4 pro?

Yes I have the standard size V4 and had mainly T and I keys spamming. I noticed that pushing down on the T key and rolling my finger a bit on it would act like I was tapping it really quickly, like 15 times in barely a second - no other keys did this, and I had key repeating delay turned as low as possible in windows so I could test it properly.

So my guess is Razer’s switches are just crappy?

 

Anyway, I had a whinge on one of their facebook posts and in the end they sent me another one, which I’m using to type this now.

No double typing issues yet, but as everyone here knows it seems to develop over time, so I don’t have the highest hopes.

Wish the jerks would have just refunded me instead.

Had to sign in here, because I am experiencing something similar with my Huntsman 2 analog. However, I discovered something that may help all of you, I hope.  In the key board settings for synapse, under customize, I switched the typing mode from ‘custom profile’ to ‘typing mode’ It’s not always permanent, and I have to keep going back to switch it, but it stops the double input from all my key presses. 

 

I hope it helps someone out, and I hope it’s fixed! 

Had to sign in here, because I am experiencing something similar with my Huntsman 2 analog. However, I discovered something that may help all of you, I hope.  In the key board settings for synapse, under customize, I switched the typing mode from ‘custom profile’ to ‘typing mode’ It’s not always permanent, and I have to keep going back to switch it, but it stops the double input from all my key presses. 

 

I hope it helps someone out, and I hope it’s fixed! 

Dont see that option

 

I haave the same problem, and it also seems to be getting significantly worse.  New Blackwidow v4, green switches, I've only haad it a few months. The "a" "d" aand "/" keys are wworst, though aalso sometimes "w".

I've tried reinstalling Synapse, repaairing it, turning it off. I've tried changing polling raates. Aand I've tried chaanging Windows keyboaard settings. I've updated the firmware. Drivers/computer all up to date.  I've tried different usb ports, wwhich seemed to briefly make my "/" only go off once, but now it's repeaating again.

Wwhile the other keys just repeaat, the 'd' key often just fails to register at all.


All this to say, if I take the key caps off and type on the switches themselves like a heathen the keys work like they're supposed to and I'm losing my mind over it.

I tried swapping out the key caps with ones from my old Blackwidow chroma aand the issue returned.

I guess my next step is trying to clean the switches with alcohol.

I checked every single key on my board and found i only had 2 acting up. I had already ordered a new razer key switch set to just replace any bad keys but after locating the bad keyswitches i popped them out, poured 99% alcohol in them, dried them out and reinstalled and seem to be working fine now. I also have some Cherry Speeds coming in and i might just switch the whole board if i like them more. We will see. I think the issue is simply Razers key switches not a major board issue. 

Ended up switching my Letter keys to Razer Yelllows since i like them better for typing personally. One box is cheap enough that i dont mind the extra cost and i get to avoid the RMA circus. However i was able to fix the repeating keys by simply putting some IPA down them and working them up and down. Seems to fix switches that are repeating. 

Hi everyone again, I came back to share some more details about the bug, and my own vision why it happens
Till that time I have no problems with double typing

Quick recap, I bought a new switches, the same yellow ones, replaced buggy ones, and everything works correctly
BUT, sometimes even a new ones start doubling
And here is what I think:

The new switches are a little larger in plastic and in height
Because of this, they do not fall easily into the board, resulting in them being at the correct height when you press them
Therefore, even if new switches are installed and they fall a millimeter deeper, this bug starts again
I have to pick up the switch and put it back.
Then everything works.
This is a bug due to probably even less than a millimeter of depth

It may be caused by this switches are pre-lube, maybe, who knows
But anyway, I have no issue right now, and reinstall buggy switches I did maybe 3 or 4 times for a 2 months

And also after some usage, as you press the buttons, they getting be pushed into deeper
That’s why it happens after some time of an usage

I received my first Blackwidow v4 end of last December. After 3 weeks (!), I had some double typing/keys not responding issue.

I reached Razer support and manager to change for a new one, that I received early February.

Funny thing is that this second device is having exactly the same issues after 2 weeks. I can't replace my keyboard every month when these Blackwidow v4 obviously has some serious issues.

And now, Razer is neither willing to refund me or to upgrade me for something else, like Huntsman. Only replacing for, again, a new Blackwidow v4. 190eu for only problems with no commercial gesture.

Save yourselves, don't ever buy Razer again. Low quality with low customers services.

Reply