New Razer Blackwidow v4 typing repeating issue | Razer Insider
Question

New Razer Blackwidow v4 typing repeating issue


Userlevel 1

All the keys are repeating sporadically when I type. Sometimes it has no response when depressed, such as the arrow keys or punctuation keys. I have to spend a lot of time checkingg the spelling and missing letters.

If there is any typo here it is because I gogt fed uup on correction.


76 Replies

Just chiming in to say i have the same issue, Black Widow v4 75%. This is ANNOYING as hell!! I saw they released new firmware for the other V4 boards just not this one and it REALLYY needs to be fixed!

Just chiming in to say i have the same issue, Black Widow v4 75%. This is ANNOYING as hell!! I saw they released new firmware for the other V4 boards just not this one and it REALLYY needs to be fixed!

I just sent back my second blackwidow v4. I can tell you that the firmware won’t do anything.
First keyboard had the a,e,i and enter spam,
The second had the a,e,i,y and backspace,
The firmware made the y go away but than the backspace started to spam.
With this it’s clearly a software issue but they lack the interest to fix it

All the keys are repeating sporadically when I type. Sometimes it has no response when depressed, such as the arrow keys or punctuation keys. I have to spend a lot of time checkingg the spelling and missing letters.

If there is any typo here it is because I gogt fed uup on correction.

Same issue here, specially letter “o”. It’s annoying!

same problem, seems to be getting worse by the day. the ‘a’ key repeats very often, and others are starting to repeaat as well (leaving typo as-is to show whats haappening). 

I aalso get a lot of issues with the enter key not registering when I press it, or it x2/x3 times registering. The keyboard is simply not usable :( such a shame for this expensive of a device. I regret the purchase big time. Anyone who runs into this, just stay away from the blackwidow v4 75% until the issue is clearly resolved if ever.

 

Does this also haappen with the larger blackwidow v4 and v4 pro?

Does this also haappen with the larger blackwidow v4 and v4 pro?

Yes I have the standard size V4 and had mainly T and I keys spamming. I noticed that pushing down on the T key and rolling my finger a bit on it would act like I was tapping it really quickly, like 15 times in barely a second - no other keys did this, and I had key repeating delay turned as low as possible in windows so I could test it properly.

So my guess is Razer’s switches are just crappy?

 

Anyway, I had a whinge on one of their facebook posts and in the end they sent me another one, which I’m using to type this now.

No double typing issues yet, but as everyone here knows it seems to develop over time, so I don’t have the highest hopes.

Wish the jerks would have just refunded me instead.

Had to sign in here, because I am experiencing something similar with my Huntsman 2 analog. However, I discovered something that may help all of you, I hope.  In the key board settings for synapse, under customize, I switched the typing mode from ‘custom profile’ to ‘typing mode’ It’s not always permanent, and I have to keep going back to switch it, but it stops the double input from all my key presses. 

 

I hope it helps someone out, and I hope it’s fixed! 

Had to sign in here, because I am experiencing something similar with my Huntsman 2 analog. However, I discovered something that may help all of you, I hope.  In the key board settings for synapse, under customize, I switched the typing mode from ‘custom profile’ to ‘typing mode’ It’s not always permanent, and I have to keep going back to switch it, but it stops the double input from all my key presses. 

 

I hope it helps someone out, and I hope it’s fixed! 

Dont see that option

 

I haave the same problem, and it also seems to be getting significantly worse.  New Blackwidow v4, green switches, I've only haad it a few months. The "a" "d" aand "/" keys are wworst, though aalso sometimes "w".

I've tried reinstalling Synapse, repaairing it, turning it off. I've tried changing polling raates. Aand I've tried chaanging Windows keyboaard settings. I've updated the firmware. Drivers/computer all up to date.  I've tried different usb ports, wwhich seemed to briefly make my "/" only go off once, but now it's repeaating again.

Wwhile the other keys just repeaat, the 'd' key often just fails to register at all.


All this to say, if I take the key caps off and type on the switches themselves like a heathen the keys work like they're supposed to and I'm losing my mind over it.

I tried swapping out the key caps with ones from my old Blackwidow chroma aand the issue returned.

I guess my next step is trying to clean the switches with alcohol.

I checked every single key on my board and found i only had 2 acting up. I had already ordered a new razer key switch set to just replace any bad keys but after locating the bad keyswitches i popped them out, poured 99% alcohol in them, dried them out and reinstalled and seem to be working fine now. I also have some Cherry Speeds coming in and i might just switch the whole board if i like them more. We will see. I think the issue is simply Razers key switches not a major board issue. 

Ended up switching my Letter keys to Razer Yelllows since i like them better for typing personally. One box is cheap enough that i dont mind the extra cost and i get to avoid the RMA circus. However i was able to fix the repeating keys by simply putting some IPA down them and working them up and down. Seems to fix switches that are repeating. 

Userlevel 1

Hi everyone again, I came back to share some more details about the bug, and my own vision why it happens
Till that time I have no problems with double typing

Quick recap, I bought a new switches, the same yellow ones, replaced buggy ones, and everything works correctly
BUT, sometimes even a new ones start doubling
And here is what I think:

The new switches are a little larger in plastic and in height
Because of this, they do not fall easily into the board, resulting in them being at the correct height when you press them
Therefore, even if new switches are installed and they fall a millimeter deeper, this bug starts again
I have to pick up the switch and put it back.
Then everything works.
This is a bug due to probably even less than a millimeter of depth

It may be caused by this switches are pre-lube, maybe, who knows
But anyway, I have no issue right now, and reinstall buggy switches I did maybe 3 or 4 times for a 2 months

Userlevel 1

And also after some usage, as you press the buttons, they getting be pushed into deeper
That’s why it happens after some time of an usage

I received my first Blackwidow v4 end of last December. After 3 weeks (!), I had some double typing/keys not responding issue.

I reached Razer support and manager to change for a new one, that I received early February.

Funny thing is that this second device is having exactly the same issues after 2 weeks. I can't replace my keyboard every month when these Blackwidow v4 obviously has some serious issues.

And now, Razer is neither willing to refund me or to upgrade me for something else, like Huntsman. Only replacing for, again, a new Blackwidow v4. 190eu for only problems with no commercial gesture.

Save yourselves, don't ever buy Razer again. Low quality with low customers services.

Hi everyone again, I came back to share some more details about the bug, and my own vision why it happens
Till that time I have no problems with double typing

Quick recap, I bought a new switches, the same yellow ones, replaced buggy ones, and everything works correctly
BUT, sometimes even a new ones start doubling
And here is what I think:

The new switches are a little larger in plastic and in height
Because of this, they do not fall easily into the board, resulting in them being at the correct height when you press them
Therefore, even if new switches are installed and they fall a millimeter deeper, this bug starts again
I have to pick up the switch and put it back.
Then everything works.
This is a bug due to probably even less than a millimeter of depth

It may be caused by this switches are pre-lube, maybe, who knows
But anyway, I have no issue right now, and reinstall buggy switches I did maybe 3 or 4 times for a 2 months

 

I think you might be  on  to  something. I’ve been  switching around my ‘’affected’ switches becauuse  I tthought  that itt  was becauuse the switches themselves  that are faulty. But I’ve noticed  tthat all  the switches  that are having the  most  issues  are very ffirmly  set  intto the board, to the point where I  have to really puull  hard  on  them to get tthem out.  I  think tthe depth at which they’re set in tthe board is cauusing some sort of issue, as you said here. I’ve  tested it up  by pulling out  and puttting bback in the worst offffenders and it seems to bbe helping in some cases,  though not all (as you  can see lmao). I think all the  people talking here about cleaning their switches or switching them are inadvertently just puttting them back into the board at the right depth.  

Running into the same issue. Tab, C, and space bar so far for me. Not at all at once either, new keys are being added so I don’t expect it to get better. I started getting these issues at about 4 months of use. After going through this post it’s pretty disappointing to see that not only is there not an appropriate fix, but replacement boards start exhibiting the same problems after some time. I don’t really want to go without a board while I go through RMA just to end up in the same spot again downstream.

I’m lucky enough to be in a position with enough disposable income to regret my decision to purchase this keyboard and just purchase something else to replace it. It will make me hesitate to purchase Razer products in the future, and I am exactly the type of customer they would want to keep coming back to the pond.

It sucks, because the board makes an excellent first impression, and is reviewing well because of it. It’s making all kinds of positive press and then drops the ball far enough down the line that it’s not hitting any outlet’s radar.

Hello there, same problems after 5 months of usage.

What are the options here? Ask for refund from Razer? Or changing switches will help (recommend something tactile if you know)? I like the keyboard overall, but this issue is very hard to live through. Razer you should be ashamed.

Same problem here. Random typing errors with the buttons  with black widow 2016 edition. Its really annoying.

Same problem here. Random typing errors with the buttons  with black widow 2016 edition. Its really annoying.

8 years old keyboard. You expect it to work properly at that age?

Same problem here. Random typing errors with the buttons  with black widow 2016 edition. Its really annoying.

8 years old keyboard. You expect it to work properly at that age?

Why not.Its brand new keyboard with lowered price because of hold storage.No mater the fact the problem appeared after updating to latest version of synapse for me i think.

so I guess I waasn’t the only one with this issue??? I had my H key repeating over and over for a long time. then it magically stopped, aand now the AA and space bar are doing that insteaaad. sometimes D even.
this is my first mechanicaal keyboaard thata I bought aand its insane how many issues I had to face with it. it hasn’t even been months yet.
for the love of god razer, fix this.

Same problem full size Black Widow V4 Pro. 

I think we should all contact Gamers Nexus.

Although I don’t always agree with Steve on everything, he actually has a nice way of taking care of consumers.
Check out:
Contact GN | GamersNexus

If a GN rep reading this RN, thanks for being a beast.😎

-D 

Guess what guys sadly i have also fallen victim bought the razer blackwidow v4 pro green switch model 1 day old only and also having the same issues like what you all have told me some buttons unable to use and so on and i have decided to just return to the seller and proceed with a refund :( doubt if it helps if i decided to get the yellow switch version?

 

So I’m going to type this review without editting the mistakes (caused by the key spamming after this period). After only aabout onee monthh of having this keyboard, the a,e, keys have spammed horrendously. Typing for anything is now a hassle, and when im gaming (CS 2 eespecially), when i move left using the A key, the movement stops, becaause it thinks im spamming a or something. So frustrating, especially when gaming at aa higher level where small movements like that are important. So far my experience with this keyboard is awful. 2/10.

So I've refunded my green switch and gotten the yellow switch instead and received it today to my suprise the same issue persist even on a different keyboard switch LMAO. Goodbye razer not gonna buy anymore keyboards from your brand anymore so pricey but rubbish quality

same issue here, blackwidow v4 pro, noticing I and o doubling when typing, keyboard is not even 2 weeks old

Reply