[Consolidated] Sticking Blackwidow Chroma Stealth Keys?

Discussion in 'Keyboards' started by Phenrix, Jan 11, 2015.

Thread Status:
Not open for further replies.
  1. Hey everybody, had mine sent it, got it back with no fault, there must be a software issue as this is ridiculous. I really enjoy the keyboard and wish to use it in my competitive gaming. Lets see what happens.
     
  2. elite.ire

    elite.ire Active Member

    u got yours back and its fine ?, this mean hardware not software ?
     
  3. That's quite the answer we need at the moment.
    I am on the verge of RMAing mine soon.
     
  4. Mine's being returned for a refund. My Corsair replacement should reach me tomorrow. I don't know if it's lighting, or dirt on the key or what, but the lighting on the Enter key is messed up, the first half of Enter is really dim and miscoloured. I'll benefit of hte doubt and say it's room lighting, but no other key is affected
     
  5. emdoudar

    emdoudar New Member

    I have a blackwidow 2014 kb its only 3 months old and after playing with it sometime i realized the looping issue happens only when i press more than 1 key same time mostly in my case FN+f7 which is for next in playlist when playing music and after googling i found a lot of people complaining about the same issue which i btw dont think its a hardware issue because when it happens it stop when i press any key on keyboard which means the issued key isnt physically stuck no its something with the system mostly..

    lets hope for an official reply or a solution for this.. i have tried removing and installing synapse again but this doesnt solve it.
     
  6. It can still be hardware issue, to most of us that's how it happened, althou the other day I had the looping issue just pressing the single key it looped. It was too much odd. The key not getting stuck does not imply that hardware is flawless.

    Staying on the software issue thesis, a few question for everyone here:

    1. How many updates did you do to the drivers? Did you do the Win updates to the Razer drivers (optional ones) too?

    2. After which period (and if you can remember, update) the keyboard started to act strange?

    3. Do you use any kind of key/script binder other than Synapse? (Like for example AutoHotKey)

    4. For those who tested it without Synapse, did you also remove every other Razer driver/software?
     
  7. nekoxandu

    nekoxandu New Member

    I have done all the available updates to my drivers, including the Windows optional ones.

    I don't know which update it took before I started to have the issue, but it didn't start happening for me until around the 28th or 29th of April, and my keyboard was purchased on the 17th.

    I do not.

    I take my keyboard to work with me as a way to not have to use a membrane keyboard that I have at my desk, there is no Razer software on the machine at all. I simply plug in the keyboard and use it. No downloads or anything.
     
  8. emdoudar

    emdoudar New Member

    1- I didnt make any driver update through Windows update only updates from Razer

    2- Not really sure but it started like month or month and half ago i didnt face it when it was new

    3- nah i dont use any other keys just Synapse.

    4- i tried reinstalling the Synapse but that didnt solve it.

    5- I connected only one USB from the cables i thought to connect the one for the USB hub maybe its some how provide the kb with extra power and not only for hub.. till now no looping
     
  9. elite.ire

    elite.ire Active Member

    1. Just updated synapse when updates were available, had stuck/looping keys on every version tho
    2. Keyboard always has had this problem
    3. No
    4. All razer software was off, double checked task mgr
     
  10. As for these replies, stuff seems to be highly hardware related, correct me if I'm wrong.
     
  11. elite.ire

    elite.ire Active Member

    Yup seems like it to me, mine is going back for replacement tomorrow.I'll let ye guys know if the new one has same problems
     
  12. I'll probably follow the same route.
     
  13. The issue presented itself again, this time on the backspace key.

    If it's not software related then I have quite some faulty switches (how can that even be?).

    Any updates about your replacement, elite?
     
  14. Lightningrod140

    Lightningrod140 New Member

    I keep checking regularly to see how the replacement boards are. Elite I'm counting on you! Depending on what you report, I'm either going to send mine back or refund it and go for a different brand of keyboard. I heard the new switches were bad, but I went against my instincts and stuck with my brand loyalty. There is no excuse for a hardware issue for a 130$ board. The switches are mass produced and the tolerances for such a large scale production should be easily very tight. I am very disappointed in this if indeed it is a hardware/ key switch issue.
     
    Last edited: May 15, 2015
  15. elite.ire

    elite.ire Active Member

    Ya I know what you mean, support said synapse was the only software tho and that if it was happening with synapse off then it's hardware :/, I added a packet of haribo and added a note asking could they send me back a UK layout board Instead of the French layout that I returned :stuck_out_tongue_winking_eye:, curious to see if they do it for me :eek:
    Keyboard got collected on Tuesday, I'm thinking next Friday I may have it back but it could be longer, I will let ye know ASAP I know how frustrating this problem is :slightly_sad:. The keyboards are 200euro here or 229$ not just $130 :slightly_sad:
     
  16. Lightningrod140

    Lightningrod140 New Member

    I made a mistake. I paid 163$. 230 is outrageous! I'm sorry to hear about that :slightly_sad:. Hopefully your next board is what you should have received the first time :stuck_out_tongue_winking_eye:.
     
  17. emdoudar

    emdoudar New Member

    i am following up with you guys to see how the replacement thing gonna work although mine is hard to return since i bought it from another country pfff.

    anyone let me know if the new one works just fine.
     
  18. ETitus

    ETitus Active Member

    Looks like my post didn't come through. I have the BW Chroma Stealh

    I didn't have it at the beginning, when I got it from the CES sale, but lately I've been experiencing the problem as described. Mainly at the d key, but also at the comma and the backspace.

    A friend of mine who also got the BW chroma Stealth has the same problem.

    I really hope it's a driver/software issue!
     
  19. Update: Could be totally random, but since a few Win updates it's been two and a half days that I didn't get the looping.
     
  20. Lightningrod140

    Lightningrod140 New Member

    Weird. Can you add some additional information? I use Windows 8.1 x64 and I still get the looping. Do you have Razer Synapse installed? What were the windows updates that installed?

    This may just be a fluke. I was under the impression that, if razer synapse was installed then windows drivers or any other windows software would have no effect due to synapse drivers super ceding windows drivers. In Balmung's case it seems as though they were in conflict. Please update with more information on your windows and synapse specs/versions, as this could be a lead in the right direction.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >