Issues with Razer Kraken 7.1 V2 Mic Quality

Discussion in 'Audio' started by lobbster135, Dec 25, 2018.

Thread Status:
Not open for further replies.
  1. lobbster135

    lobbster135 New Member

    I just recieved a Razer Kraken 7.1 Headset as a Christmas present, but ive been having issues. While i can hear fine, be it in Discord or on other applications, when i speak in the Discord my audio is poor and sounds robotic, as if im talking over a radio. Ive been trying multiple solutions people have given over different forums but none seem to fix the issue. (By the way, yes i have set the headphones and microphone to default in my sound settings and Discord. I have also checked to make sure there are no enhancements enabled in configurations on the headset). Im open to any solutions. Does anyone know a possible fix?
     
    DRIFT_IT and 0V3R_K1LL like this.
  2. ShroniX

    ShroniX New Member

    Hi
    I had the same problem
    The solution is you have to change the quality in windows audio settings from 8000 kHz to 48000 kHz and then your mic will sound fantastic.
     
    Jnuttengr likes this.
  3. ReydanNL

    ReydanNL New Member

    I can only change it to 44100 Khz, how can you change it to the higher one?
     
  4. ShroniX

    ShroniX New Member

    I have 48000 Hz but the 44100hz will be good too
     
    Jnuttengr likes this.
  5. ReydanNL

    ReydanNL New Member

    Whenever I try to set it on 48000 Hz it says that the device is in use, I click yes to proceed but when I check to see if the setting it changed it still shows 44100 Hz. Something seems to be blocking it, no idea what.
     
  6. ShroniX

    ShroniX New Member

    Try to close all the applications that may use the mic (discord, ts, Skype etc.) and then change it
     
  7. Jnuttengr

    Jnuttengr New Member

    I'm having the same issue with the Nari Ultimate. Is it the same solution?
     
  8. ShroniX

    ShroniX New Member


    I'm not sure but give a try
     
  9. BlackFireDragon

    BlackFireDragon Well-Known Member

    Try to plug headset remove it from windows device menager reboot pc and connect again then try to change mic bitrate.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >