Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

No 2018 option at warranty registration

Discussion in 'Razer Gear' started by Tamarizz, Jan 18, 2018.

Thread Status:
Not open for further replies.
  1. Tamarizz

    Tamarizz Member

    Yesterday I bought a Razer Firefly Cloth Edition, it arrived today...
    It's freaking lit !! (literally lol)
    Anyways, I'm using a Mac so I connected the Firefly with the Razer Synapse 2.0 (no 3.0 on Mac yet) and when I tried to register the warranty, there's no 2018 option, so I'm not sure what to do?
    Help please?
     

    Attached Files:

  2. Jayorito

    Jayorito Well-Known Member

    Try using synapse 3.0 and see if it has 2018 if not wait for the update
     
  3. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Tamarizz likes this.
  4. Tamarizz

    Tamarizz Member

  5. Thorvarium

    Thorvarium New Member

    Same problem here mac 2018, I tried to use the warranty portal but on STEP 3 it dont let me click to finish... the button is read only for some reason and dont give-me any error message
     
  6. Tamarizz

    Tamarizz Member

    Really? I registered my product from the website and there was no problem /:
    have you tried again?
    what browser are you using? I did it on Google Chrome
     
  7. Thorvarium

    Thorvarium New Member

    Yeah, google chrome... just tried again no luck
     

    Attached Files:

  8. Tamarizz

    Tamarizz Member

    Wel.. you should contact Razer Support on twitter maybe, I don't know what else you could do
     
  9. Thorvarium

    Thorvarium New Member

    Hehe thanks, well ill just wait to register

    Maybe ill try later while on bootcamp
     
    Last edited by a moderator: Jan 29, 2018
  10. Toolboxdaily673

    Toolboxdaily673 New Member

    Hi did you register ?
    I can't register my 2 product in any of these try
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >