Razer Kraken Pro seems worn out after only a week of use?

Discussion in 'Audio' started by Sadbears, Jul 31, 2016.

Thread Status:
Not open for further replies.
  1. Sadbears

    Sadbears New Member

    I just got the Razer Kraken Pro about a week ago. Sounded great when I first got them but now they sounds pretty bad. They crackle when bass hits and don't even hit some of the bass they were hitting a week ago everything also just sounds a bit flatter. Is anyone else having this problem or have a solution?

    Sidenote: I do have bass boost turned on 100% in Razer Synapse but EQ is still default and I have used them pretty heavily the whole week.
     
  2. Milliardo5

    Milliardo5 Member

    Try the headphones on another computer or device. If it still has the same issue then speakers are probably defective and you should return it.
     
  3. RZYao

    RZYao Member

    I've seen threads about the bass crackle issue, maybe look at those?
     
  4. Vivulux

    Vivulux Active Member

  5. gaykob7

    gaykob7 Well-Known Member

    That doesn't seem normal, mine are just fine even after a couple of months
    If you can't find a solution contacting the support would be the best option
     
  6. Sadbears

    Sadbears New Member

    I plugged them into 3 different devices the issue persisted. I just decided to return them and I am interested in maybe trying another Razer headset but I am not sure which ones are really worth the price.
     
  7. Badgertista

    Badgertista Well-Known Member

    If you live in Canada, the Kraken Chroma is currently 99$ at Bestbuy/Amazon.

    I'm probably going to grab one after work
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >