Razer Nari Ultimate rapidly disconnecting | Razer Insider
Question

Razer Nari Ultimate rapidly disconnecting

  • 22 February 2023
  • 105 replies
  • 14819 views

Userlevel 3

Having the same issue as many others here - Razer Nari Ultimate worked fine for a long time now all of a sudden is rapidly disconnecting/reconnecting on PC/PS5 - causing playback issues and of course forcing me to use 3.5mm jack - reached out on twitter troubleshooted everything from the recovery tool to having my case escalated to “advanced support” but its been 5 days without reply

USB ports work for anything else just the headset keeps cutting out and its infuriating - please assist as this is my third locale for support


105 Replies

I have the same problem. Randomly started to connect/disconnect rapidly 3 days ago. Freshly installed windows, basically setup a whole new PC but the problem reappeared. I used the pairing utility tool but it didnt fix it. I then connected my old Kraken 7.1 and ran the pairing tool again. Since then the Nario ultimate wouldnt be recognized by Synapse but it works normal again. If I unplug the Kraken it start connecting/disconneting again so i doubt its a hardware error but the software is at fault. I don’t want to have my Kraken connected all the time as i just hate unnecessary cables. If this wont be resolved soon I will change to another company and just never buy Razer products again. This is just too annoying and the problem seems to exist for a while now.

Hello,

 

Same problem for me, after 1,5 year without any problems.

I tried all of the following procedures, none worked:

I see that this problem is not recent and that no fix has been made by Razer.
So I think I'm not going to wait for a fix and send back for warranty...

I was having the same problem.  The solution that fixed my problem was executing Nari Dongle recovery tool and executing the Nari Ultimate pairing utility tool (that is the headset I have, there are other utility tools depending on the style you may have).

How long did the recovery tool take to recover the dongle?

Hello our headset dongle is disconnecting / re-connecting itself rapidly. We ran the dongle repair tool but the problem is still happening.

The P/N on the dongle is RC30-026702

Userlevel 3

Hey! I have the same damn problem as everybody. The headset was working great for almost 3 years until it suddenly stopped working ideally. It is disconnecting and trying to reconnect rapidly. When connected, it disconnects when any sound is played at all. This is so infuriating. Please help us out Razer! This definitely seems to be a software issue because the headset works fine when it is connected via the 3.5mm jack.

Latest update to razer synapse(as of 21/08/2023) didn’t help either. Can you please at least send a replacement dongle for this, since the current one bricked.

Same issue started yesterday, fresh start of windows, runed the dongle recovery tool and did not work.

Anyone in this post fix it?

 

Still in warranty for the next 3 weeks.

 

Thank’s 

I have the same problem. Came with a year of use.

I tried to solve it in all possible ways, even without the driver and Sinapse software installed, the problem persists, it keeps disconnecting and reconnecting when playing some media.

Same problem here, worked fine for 8 months until 2 weeks ago.
Headset start rapidly disconnecting and reconnecting when I try to use the microphone, tried the recovery tool for dongle but it get worse, now i cannot connect anymore.

Userlevel 3

Same, my issue is worsening as well. The dongle isn’t connecting anymore.

After owning this headset since release, I just started having this issue a few days ago. Its driving me nuts with the constant beeping. Hopefully there’s a fix for it soon

same problem here, though im out of warranty, bought it more than 3 years ago
 

I just got this issue to and its really frustrating that it doesnt work.

I still have the original packaging with serial nummer is there away that i can get help with this or there is nothing more to be done.
 

The first of this headset the support team said to take back, as I would turn it on and it would turn off, now I have the replacement and have had it for a month now and I realized its the USB Dongle the whole time.  I have the dongle on the LED light Razer headset stand and when the USB Dongle drops it causes power to the device to drop, Any USB Port I plug it into it causes a voltage loss and then comes back.  How do I get a replacement fixed Dongle?

 

P/N RZ04-02670100-R3U1

Wireless USB  Transceiver P/N RC30-0267

S/N 862135D09100221

 

SAME ISSUE I CONTACT TODAY THE PM razer guy, lets see what happens.

Exact same problem as everyone else on here. My Razer Nari Ultimate has worked completely fine for almost 2 years now, but as of today it keeps dropping out, trying to reconnect, and then fails in the end… Tried dongle in multiple ports but the problem is with the dongle :( What can be done to fix it? Is there software update or is it a hardware malfunction?

Same problem here. I opened a support ticket. Let’s see what happens.

 

I also tried both the Pairing Utility and the Dongle Recovery tools and both seemed to fix it at first but as soon as you set the headset as your sound device and start something that plays sound like a Youtube video it immediately goes back into the “pairing” mode and keeps connecting and reconnecting.

After years of use with no issues my razer now also started to randomly disconnect after a few minutes of use, is it the dongle, and if so, what can/should I do to replace it? Currently living in Belgium.

 

Hi..

I am having the same issue and this is after 7 months..


It will connect for a while, with sound, and then all of a sudden disconnect..
It will then go through the connect / disconnect cycle continuously for about 2 minutes..


Connecting it to another USB port repeats the above process..

 

I have tried the recovery process mentioned, which was painful due to having to try run it multiple times due to connection, BUT the issue was not resolved.. :(

@Razer.Zionzedd - can I pm you my S/N, etc?

I have just started having this problem today. 11/13/23. My Razer Nari Ultimate just keeps disconnecting and reconnecting as soon as audio starts playing in it. I’ve tried the dongle recovery, the firmware update and there doesn’t seem to be a problem. I went to Youtube and Reddit to find solutions, but nothing seems to work. Is it over???

Hello I have the same Razer nari ultimate headset and recently the headset does not work through the dongle

it shows up for a few seconds in my audio control pannel but when trying to select/use it , it dissapears and nothing happens

 

i too atempted the dongle repair app , but it made no difference

I think i bought the headseds about two years ago .

is there a solution to this that helps fix it 

 

Same. When I try to hookup up my Razer Nari’s to my PS5 Slim, they will work for a bit and then randomly disconnect. Then when I replug it, it starts to reconnect and then disconnect back and forth until it won’t connect anymore. 

This just started happening to mine now. I think I have had it for a year? I thought I was going crazy. It would even kill everything else on my USB hub. Yes. I tried just using it on the hub and just using it on any plug on my desktop same thing. On and off on and off. 

i have same issues did you guys find any fix for this? 

I paid 200 eur for this headset and out of warranty since few weeks.. 😥

Having the exact same issue as everyone else. Just started today.

Tried to pairing tool = no success
Tried the dongle repair = no success

Trying to PM support now.

 

So this is happening to me to now, of course out of warrnty. Dongle repair doesnt work, reinstalling doesnt work either, it seems at this point this should have been a mass recall for a defective product with how many are havving this issue.

 

Whats going to be done for us? am i out 200$? my wife has the same headset and its starting to happen to hers as well… slight disconnects here and there, just her dongle still shows as a razi nari ultimate not some random avnera av6301 device.

Pretty fed up by having to run the dongle recovery tool and the pairing utility over and over again. Can anyone please reply if PM-ing the razer guy did actually help?

Reply