Blade 15 GTX 1060 Issue

Discussion in 'Systems' started by Marold684, Aug 13, 2018.

Thread Status:
Not open for further replies.
  1. Marold684

    Marold684 New Member

    Hello !
    I have my Blade 15 with 144hz screen since two weeks and I'm very happy with it !

    I've played Fallout New Vegas on incredible conditions, but today, I wanted to play at Fallout 4 and it didn't go as expected : My GPU is working at max 20% and my game don't go over 20 FPS event in very low quality.

    It was working smoothly with a GTX 970M but didn't work with a 1060 Max Q..
    I've tried to put the 1060 as the main GPU, I've tried to play at 720p, but still, 20 fps and my GPU just chilling...

    If anyone have a solution I'll be very happy because having a "gaming" laptop that can only run old games is totally useless..
     
    pancholr likes this.
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    Do you have latest nvidia driver? If yes try another older driver.
     
  3. Marold684

    Marold684 New Member

    Yes, I've tried with drivers from August (the latest), then from July and June and still, 20 FPS and 20% of usage
     
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    From FPS it sounds you don’t use 1060 dgpu, but iGPU (intel UHD630), is it really showed in game setting gtx1060 with 6gb vram? Don’t play fallout so idk the setting menu. Are you using afterburner in game monitor to check gpu usage?
     
  5. Predator5

    Predator5 Well-Known Member

    That certainly doesn't sound right.
    Go to Nvidia Control Panel and check settings, there could be something wrong.
    Also, I'd like you to download MSI Afterburner, and turn on the On Screen Display, and display the CPU Usage, CPU Temp, GPU Usage, GPU Temp and RAM Usage.

    Please report those statistics and if you can screenshot them and post it here.
     
  6. Marold684

    Marold684 New Member

    Hi everyone / Thanks for your help I found a solution !

    I disabled the 144Hz, and play in windowed borderless, my fps are now at 60 at max details !
     
    Predator5 likes this.
  7. Joikansai

    Joikansai Well-Known Member VANGUARD

    If it’s okay for you then fine. Honestly to me it’s not really solution, seems there’s compatibility issues with Blade software or driver. I remember on my Blade 14 i had similar issue that pushed me to play on borderless window mode, it was on For Honor, contacted Ubisoft and Razer ended up with replacement unit (different model, late 2016 to 2017, since it was just released), beside that issue I had also Fan noise issues that at that time the EC update wasn’t released yet. Playing on borderless windows could reduce some FPS compared to full screen.
     
  8. ChiefNieth

    ChiefNieth Active Member

    Sounds like your nvidia settings are by default drawing off of Intel integrated graphics. Try going into Geforce, then 3D properties, and setting the draw to only the GPU. Should be able to get 144hz
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >