Flashing green power light RBP 2016

Discussion in 'Razer Support' started by defmetal, Apr 5, 2018.

Thread Status:
Not open for further replies.
  1. defmetal

    defmetal New Member

    I have a Razer Blade Pro 2016 GTX 1080 edition

    I just got it back from being RMA'd where the motherboard was replaced and the battery.
    For some reason when I power the laptop on, I just get a blinking green light and nothing else.

    Any ideas? It's out of warranty (although I would hope if I have to RMA they would fix it for free since I just got it back from them 2 weeks ago). I do not mind taking it apart and I have all the tools but I wouldn't know what I'm doing.

    Any tips here? Sometimes it turns on after hitting the power button about (no joke) 30 times and when its on, it stays on. But if it turns off for any reason (off) its back to blinking light. Yes, I plan on opening a support ticket but hey maybe the public knows or maybe the solution I find helps someone else.

    Bios 05.01

    Things I've done:
    Erase raid, reinstall raid (forfeited recovery partition :slightly_sad: )
    Reinstall windows
    Update bios
    Restore factory defaults
     
    Selyca likes this.
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    Try this resetting way
    > > Press and hold the power button for 10 seconds.
    > > While still holding the power button, unplug the charger.
    > > Release the power button. Leave the system sitting for a few seconds before plugging the charger again and attempt to power it back on.
     
  3. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Yo!

    I sent you a PM so I can help you out with your Blade Pro 2016. Moving this to the support forum for visibility.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >