Latest Synapse update issues

Discussion in 'Razer Support' started by Lysanya_Willow, Dec 4, 2018.

Thread Status:
Not open for further replies.
  1. Lysanya_Willow

    Lysanya_Willow New Member

    Hello,
    I've upated my Razer Synapse 3.0 version 3.3.1128.112711 today.
    When I launched up my PC before updating it everything was working fine and I had the notification to update my software.
    I've launched the update and installed it and everything worked accordingly untill I noticed that my Razer Naga Chrome wasn't added to connected devices so it's basically not showing the colours and setting that I'm used to have.
    I've tried the following :
    - Killed all tasks through task manager from razer such as I know everything shut down completely, launched it back up and still not showing up in my list. while both my firefly and black widow do.
    - Restarted my PC completely : also didn't help
    - Checked my warranty devices on the website, surprise surprise it is linked still (obviously)

    So for what I know is that it's not receiving the correct data from my warranty list into my application and that is since the update.

    Kind regards,
    Lysanya W.
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hi Lysanya W.

    Please check if the mouse is properly detected on the Device Manager. If your Naga Chroma appears as an HID, try to reinstall the mouse drivers and reboot. Do send me a PM with a link to this thread for reference so I can help you isolate the issue.

    PS. Please change your Name as it appears to be a legit serial number.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >