Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Lights for deathadder 1800dpi not wowrking

Discussion in 'Mice and Surfaces' started by bleachandbread, Apr 14, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. pulseTaupebase024

    pulseTaupebase024 New Member

    at first when i plugged the mouse in everything worked fine but right after i installed synapse the lights for the logo stopped working, and will not turn on, i know the light works because it lights up for a split second when i plug it into my computer. I tried reinstalling synapse but nothing seems to work as well as trying to change my profile in synapse. is this common or is it just me?
     
  2. FunkySkill

    FunkySkill Member

    I would suggest you to wait some time and maybe restart your pc.
    Oh and I have another question to this topic : sometimes the Leds of my mouse are still on after I shutted my PC down and then I have to pull out the power thing out of the wall to get it out. Not a big problem but I wanted to say that.
     
  3. FiszPL

    FiszPL Well-Known Member

    Did you try to plug mouse on other PC? If no - try to check if LED lights are working. If not, maybe try to update your DA Firmware (if applicable).
     
  4. pulseTaupebase024

    pulseTaupebase024 New Member

    there should be an option called "Switch all device lighting to off when display is turned off" turn that on
     
  5. pulseTaupebase024

    pulseTaupebase024 New Member

    tried already and that dosen't seem to work :slightly_sad:
     
  6. FiszPL

    FiszPL Well-Known Member

    If you tried that, most probably your Led lights just died...
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >