Poweroff after boot on Blade Stealth Late 2019 GTX FHD

Discussion in 'The Linux Corner' started by Metatron2k2, May 10, 2020.

Thread Status:
Not open for further replies.
  1. Metatron2k2

    Metatron2k2 New Member

    Hi all,
    I hope you can help me on figuring out what is going on. I'm trying to install Linux on my Late 2019 Blade Stealth.

    When I boot via Live-USB (tryed on Archlive, Manjaro, Kubuntu) the system starts booting. After systemd starts a lot of services fine it begins shutting down again and powering off. Same thing happens on all three tried live USBs. I also tried different brands of USB sticks.

    Of course there is also no log of the boot, as there is no persistent storage at this point. My best guess is that some speciality of the hardware makes linux think it should shut down via acpi event.

    Any idea on trying to find the problem would be highly apreciated.

    Best,
    Metatron
     
  2. Metatron2k2

    Metatron2k2 New Member

    Short update. I managed to record the output. Actually it is tripping a thermal shutdown during boot.
    thermal_zone1 is reporting 198C. It is always the same temp und the notebook itself is running just fine in windows. Hmon also does not show any weird temps.
     
  3. rnd_ash

    rnd_ash New Member

    That is normal. Its due to a faulty implementation of the thermal sensors driver within Linux

    Plus, if the machine runs fine under Windows, then thermal issues are not your problem.

    Can you share the full output during boot?
     
  4. Metatron2k2

    Metatron2k2 New Member

    Hi Ash,
    sorry I can not provide any further info on the issue. Everythin was running through to fast (i could only see on slowmo video at all).
    I did exchange it for a new one through Amazon. On the new one the issue is not there. I also believe the fans are spinning up less in Windows.
    Both were an identical model and even had the same production month. Therefore I believe it was an isulated issue.
    Best,
    Stefan
     
  5. judgedeath2

    judgedeath2 New Member

    Just got my Late 2019 Stealth. Try the latest Linux Mint beta (LM 20), working quite well on mine.
     
  6. Scimpey

    Scimpey New Member

    I am experiencing the same issue on my new'ish 2020 Stealth.

    I have been dual booting Windows10 & Manjaro with no issues for the last couple of months without issue. Suddenly however I am seeing this problem, when booting I get the message:

    thermal thermal_zone: critical temperature reached (238 C), shutting down

    I have tried booting install media for several flavours of Linux, all give the same or similar output. I was able to boot one by successfully by disabling acpi however. I have tried sever temperature monitoring programs in Windows, all of which shown completely normal temperatures.

    Any thoughts?
     
  7. Metatron2k2

    Metatron2k2 New Member

    Hey Scimpey,
    during debugging I tried a distri without systemd, because everything was happening to fast. I tried Artix: https://artixlinux.org/ it is basically Arch without systemd.
    For me it was the ony distri that booted. Even more interestingly after booting Atix Manjaro was also booting again for me.
    I also had the exact same 238C.
    I imagine that there must be some corner case where the Sensors have bad initialization values while systemd tries to read the temp.
    Please boot the Atix Live image and let me know the results.
     
  8. Scimpey

    Scimpey New Member

    Thanks for the suggestions.

    Sadly both Artix and a couple of other non-systemd distributions I've just tried show exactly the same behaviour, at some point during the boot process they pick up this nonsensical temperature value and then shut down as fast as they possibly can.
     
  9. Metatron2k2

    Metatron2k2 New Member

    Sadly I have no other suggestion, nor could I find a way to tell the kernel to ignore this.

    Even worde, now I have the same issue again. This time on a 2020 GTX model. Any ideas?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >