Razer Blade 2015 GTX 970M Fan

Discussion in 'Systems' started by awro, May 13, 2017.

Thread Status:
Not open for further replies.
  1. hitcampCoolBlack683

    hitcampCoolBlack683 New Member

    Hi Everyone (and especially Razer),

    I've had problems with the fans spinning up excessively since I got my Razer Blade 2015 GTX 970M (RZ09-01301E22) early in 2016. I imagine it is similar to what the Razer Blade 2016 GTX 1060 people are experiencing.
    The fan often spins up to full speed often for no reason (no load on CPU/GPU) and even often from a fresh boot, with the computer at low temperature.
    I am frustrated that the recent Firmware update only works for the GTX 1060 versions.

    Please make this update available for all Blade users!
     
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    It will be better if you contact Razer support, i owned QHD+ 2015 till November 2016, it was far quiter than my old late 2016 (Skylake, but i heard it is solved by update) in idle but it's only on Skylake version 1060, i am feeling that Kabylakes (own now) CPU Fan behavior which is silent on idle is quite same with Blade 2015 that I owned. Maybe some of setting are changed after you installed some programs. Try to recover it to time before you have those problem or maybe factory resetting?
     
  3. vistar

    vistar Active Member

    Have been monitoring you CPU temps when the fans kick in?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >