Razer Blade Stealth Boot Loop **SOLVED**

Discussion in 'Systems' started by F3RR37, Jan 25, 2017.

Thread Status:
Not open for further replies.
  1. F3RR37

    F3RR37 New Member

    My father has had a RBS for 4-5mo now and this is the 2nd or 3rd time he has complained about it going into a boot loop. He is unable to force it to power off, but it eventually gets out of the loop and starts working again just fine.

    It happened again this evening and he sent me a text about it. I asked him a few questions including if he's tried holding down the power button to force it to shutdown fully. He then noticed that the power button was actually depressed. It appears that the power button tilts enough when it is depressed that it can get stuck under the aluminum chassis and causes the RBS to get locked into a boot loop until it is un-tilted when it is pressed multiple times.

    If this is what is happening, it might be that on a few systems there is just barely enough clearance for the button to get stuck under the chassis.

    I saw a few others on here that have had a similar issue that hasn't been resolved and hope that this resolved the issue for them.

    FYI, my Blade (2016-970m) has been rock solid. :)
     
    xDarkSiderxx and RChaos11 like this.
  2. Sorry to hear about the issue with your dad's RBS. Has he contacted our Support team at rzr.to/help yet? They will be able to assist him further on this if the issue is still persisting. Thank you.
     
    RChaos11 likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >