Razer Core doesn't even turn on

Discussion in 'Systems' started by Soujiro89, Nov 13, 2016.

Thread Status:
Not open for further replies.
  1. Soujiro89

    Soujiro89 New Member

    Hello. After several months of struggle I finally got my Razer Core. I followed the steps of installation and when the moment of truth came, the Razer Core didn't even turn on. It's dead, no lights, no charging sent to my laptop, nothing.

    More details:
    • Razer Blade Stealth 256gb model.
    • Asus Strix 1070 nVidia GeForce GTX 8GB.
    Also, I'm located in Argentina where the power delivery is 220v. I checked the PSU and it says that it should accept anything from 100v up to 240v. So, in theory, the PSU should handle the current.

    What I have already tried:
    • Bending the rail as explained in other threads, in order to get the magnet to contact the rail.
    • Changing the wireless settings to 5.0ghz.
    • Contacting Support: still no answer due to being a sunday 12 am...
    Rant:
    For obvious reasons RMAing is close to impossible... I ordered the Core in june, and went through hell to get this down to my country. First, I tried to smuggle it due to our customs being really messy. Then that failed and had to ask my parents who went to Miami to fly with the Core (yeah, 6kg metal box is quite complicated to get through TSA). When I picked them up at the airport today all I was thinking was on getting home and plugging the Core. You can see no now that I'm quite frustrated. Either this works or I'm pretty much screwed.


    Are there any ways to test if the PSU is working properly? Can I bypass the magnet thingy and make it work without it? Are there any videos on troubleshooting the Core?
     
  2. Jaisani

    Jaisani Cat

    Hey @Soujiro89 could you contact me directly as I would like to assist you on this issue.

    I'll be locking this thread now. Just a friendly reminder, Razer Insider is not a support forum..

    Peace.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >