Razer Mamba TE issues?

Discussion in 'Mice and Surfaces' started by Turtleman52, Sep 25, 2016.

Thread Status:
Not open for further replies.
  1. Turtleman52_no_id

    Turtleman52_no_id New Member

    This is my first full day using the mamba TE and it has been great, I started playing team fortress 2 on steam and it was fine but after a while of play then going off then going back onto the game there was an issue, the sensitity was fine but sometimes when moving the mouse left to right (or the opposite direction) it would go super far (turn 180 degrees) this would only happen sometimes and I checked the mouse acceleration and it's on 0 in game and in synapse, also I checked 2 other games and they seem to be fine. I redownload synapse and it's still messed up and I tried playing with a different mouse and it's fine. Any help?
     
  2. Gr8orangeone

    Gr8orangeone Active Member

    have you contacted razer support ti see if they have any clue
     
  3. Turtleman52_no_id

    Turtleman52_no_id New Member

    No I don't have a phone number, which is mandatory :slightly_sad:
     
  4. Gr8orangeone

    Gr8orangeone Active Member

    make a google voice if you need to they are free and easy. you also probably wont be called anywasy
     
  5. Dylan_Ma

    Dylan_Ma Member Staff Member

    Hi @Turtleman52, could you kindly drop a message to our Support Team and they will be able to assist you with this issue.

    I'll be locking this thread, if you require any further assistance, do feel free to contact me directly.

    Do note that Razer Insider is not a support forum.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >