Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Synapse 3.0 "Failed to Start"

Discussion in 'Razer Synapse 3 Beta' started by iPhail86, Mar 28, 2018.

Thread Status:
Not open for further replies.
  1. iPhail86

    iPhail86 New Member

    Last week, I bought the Cynosa Chroma keyboard (not the pro). It arrived on Friday in perfect condition and the keyboard feels really good to use. There is just one fairly major problem: Synapse 3.0 will not start at all.

    Firstly, I have no idea why the keyboard won't work through synapse 2.21 (I have a Razer Nage Hex V2 that uses it). Because of this issue of "older" devices not being supported on the new Synapse and "newer" devices not being supported on the old Synapse, I have to have 2.21 and 3.0 running at the same time, which might be causing conflicts.

    So far, I have had to spend about 2 hours A DAY to get Synapse 3.0 to work. I have tried over 5 pages of google search results (searched for "Razer Synapse 3.0 Failed to Start") and nothing seems to actually fix it. I am aware of the issue with the Razer SDK Chroma Service issue and have implemented that "fix". I have done over 10 complete fresh installs (including clearing cache and registry of all things Razer), I've lost count of how many times I have tried to use the "Repair" function of the installer, I've made sure windows is up to date, reconnected my devices into different USB slots.

    Currently, I'm running Windows 10 (64-bit), i6700k, 16GB DDR4 ram, 1080Ti. If I can't get this heap of trash program to work, there's no point in me keeping hold of the keyboard and I sincerely doubt that I will be buying ANY Razer products in the future.
     
  2. Grimmwor

    Grimmwor Active Member

    Is that an error message or just your description of Razers' rollout strategy?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >