Ubuntu versions I have tried on Blade Stealth 13 (2019)

Discussion in 'The Linux Corner' started by JvlaOtur, Feb 13, 2019.

Thread Status:
Not open for further replies.
  1. JvlaOtur

    JvlaOtur New Member

    I have done some testing during the course of the day.. This is what I found(in short). I did all my tests before actually installing the linux OS through the live boot function that you get when booting to a Ubuntu distro over a USB stick.
    tl:dr : The only distro that worked without a problem was the 18.04.01 of both Ubuntu and Budgie Ubuntu. The newer ones 18.10 and 19.04(pre-release) showed problems with the track-pad, locking it up after connecting to my wifi connection(or at-least about at the same time).


    OS i tried: (all 64 bit versions)
    Ubuntu 18.04.01
    Ubuntu 18.10
    Ubuntu 19.04

    Budgie Ubuntu 18.04.01
    Budgie Ubuntu 18.10
    Budgie Ubuntu 19.04


    I tried all OS's through 2 different USB sticks since I first thought there was a problem with one of the sticks themselves. Eventually I noticed that it was connected to the OS version, and not the USB sticks.

    So, once I installed Budgie Ubuntu 18.04.01, this was what I noticed that I needed to 'fix' or install extra besides the actual OS.

    1: open up a terminal, run this command to install the gnome tweak application.

    sudo apt install gnome-tweaks

    This will install the gnome tweak tool that is written about on this page.
    https://itsfoss.com/fix-right-click-touchpad-ubuntu/

    Apparently, Gnome/Ubuntu have changed the default function on how to listen to a right click on the touch-pad. They changed it to a 2 finger touch which triggers a 'right' click. I did not get that to work, so I installed the gnome-tweak tool instead, and according to the article linked above, i went back to a right click on the bottom right side of the touch-pad.

    I have now run the OS for roughly 2 hours, with any problems, I don't get any crackling sounds from the speakers(like I get in windows10) and the speed of the OS is great.

    So, Ubuntu 18.04.01 works fine on my machine, the newer once did not seem to work as good, since the live boot versions showed problems with the touch-pad etc.
     
  2. nomtat

    nomtat New Member

    Did you test it with other LTS versions of Linux? Maybe Razer only supports those ones.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >