Blade 15/17 Pro 9th gen Intel Ubuntu Drivers/Support

Discussion in 'The Linux Corner' started by quickgun13, Jun 22, 2019.

  1. quickgun13

    quickgun13 New Member

    this is my current status:
    Ubuntu 19.04
    Intel AX200 - working with intel driver and kernel 5.1
    RTX 2070 Max-Q - working with nvidia-430 driver(xorg only, no wayland)
    multiple monitors - wayland only, xorg has issues(see my post)
    I'm having some issues with gnome crashing on wake from sleep on battery
    touchpad(no smooth scrolling)

    post your system's current status. I think we would all like to get our systems stable in Ubuntu
     
  2. alxfu

    alxfu New Member

    hey there ... i got a blade 15 advanced (mid 2019) and Kubuntu 18.04 had (still has) some issues ... I installed the backport drivers from Intel for Wifi and upgraded the kernel to 5.1 and even 5.2.x ... BUT it will not even detect my rtx 2070 max-q ... was that working -at least the standard driver (not nvidia)- on 19.04? Via additional driver repsectively the KDE equivalent there is just nothing ...
     
    Last edited: Jul 27, 2019
  3. GreatAttractor

    GreatAttractor New Member

    Hi guy, I am looking forward to buy a new Blade but the situation you depict is grim.

    Something is not clear to me:

    The Display is connected directly to the NVIDIA GPU or to the Intel GPU?

    Do you need bumblebee?

    Do you have any temperature issues?
     
  4. ReversePanda

    ReversePanda New Member

    My experience so far with mid 2019 9th gen intel, 2070 max-q:

    Manjaro Gnome dual boot with Windows:
    - Intel AX200 Wifi drivers are not available out of the box, only on specific kernels, bump the kernel version
    - Used bumblebee to run CUDA apps (deep/machine/whatever learning stuff); while running default in Intel
    - Suspend was working nicely
    - Battery life was quite good
    - Could not get the external display to work :frown_:

    Ubuntu 19.04 dual boot with Windows:
    - Intel AX200 Wifi drivers are not available out of the box, only on specific kernels (had to bump the kernel, bumped kernel is unsigned - so bye bye dual boot Windows with Bitlocker enabled :frown_: )
    - Used Nvidia optimus to switch graphics to run CUDA apps, but less convenient than bumblebee for my workflow
    - Could not get the external display to work, black screen output through HDMI when on Nvidia, no signal on Intel :frown_:

    TLDR. So far still cannot get the setup that I'd like to have on this hardware.


    EDIT: Got the display working by following this AskUbuntu answer. :wink_:
     
    Last edited: Sep 9, 2019 at 10:17 AM
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >