Blade Stealth problem with Windows April Update

Discussion in 'Systems' started by KxS85, May 30, 2018.

Thread Status:
Not open for further replies.
  1. KxS85

    KxS85 New Member

    Hi,
    Since I updated my Blade Stealth (2015), the volume is much lower than before and the microphone stopped working until I reboot. Every time I want to Skype I need to restart my laptop which is not convenient. And overall, the laptop feels less responsive. Is anyone else having these problems? And is there a fix (besides rolling back to the previous version)?
     
    DRIFT_IT and LeMinh97 like this.
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    Did you mean Blade stealth v1, early 2016? There’s no Blade Stealth 2015, it was first published on CES 2016 in January. Try updating the drivers especially that with date from 2018, if it doesn’t work try manually updating all intel drivers like igpu (could be reason for that less responsiveness) or related software that has issue like Skype.
     
    LeMinh97 likes this.
  3. KxS85

    KxS85 New Member

    Yes, I meant v1 2016. My mistake. On the drivers page you posted there are no new drivers. But I will try manually updating Intel and Realtek drivers.
     
  4. KxS85

    KxS85 New Member

    I updated the Intel graphics drivers but that did not help. So I went and get drivers directly from Realtek after which I had no sound at all and the Realtek Audio Manager disappeared from my system. I went back and installed the audio drivers from Razer and now I have both the audio and microphone working again. But I had to manually to make internal and external output devices playback simultaneously and separate all input jacks as independent input devices in order to have everything working again. I have manually switch between speaker and headphone when I plug the headphones in. At least I have sound and microphone back.
     
  5. Joikansai

    Joikansai Well-Known Member VANGUARD

    I actually rolled back to 1709, on my stealth v2. I couldn’t load save game on two different games, it just crashed, and I was too lazy checking gpu drivers like from intel or nvidia (for my gpu inside the core), TB3 driver etc. Can’t not load my games save was a huge deal breaker on 1803 for me, and happy after came back to 1709, that weird issue is gone.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >