Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Computer keeps crashing when using turbo click

Discussion in 'Razer Support' started by LeNoeru, Jun 10, 2018.

Thread Status:
Not open for further replies.
  1. LeNoeru

    LeNoeru New Member

    I have a razer lancehead tournament edition that I purchased a few months ago.
    I have started using the turbo click for Razer synapse, and I use it in games.
    When I toggle it, it works fine for about 10 minutes, then my computer crashes.
    "Windows has ran into an error and needs to restart."
    Stop code: DPC_WATCHDOG_VIOLATION.

    I thought it was just my computer, so I tried it on my sister's laptop, and it also crashed.
    My friend has a naga hex, and he tried it on his computer, and it also crashed.
    How do I fix this? I tried updating drivers, repairing registry, but nothing works.
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello! Sent you a PM. Get back to me when you can.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >