Connecting to monitor causes unlocked frame rate on Blade 1060

Discussion in 'Systems' started by techheadRedBrown677, Nov 21, 2017.

Thread Status:
Not open for further replies.
  1. techheadRedBrown677

    techheadRedBrown677 New Member

    I've got a Blade (1060), and I just got a new monitor,

    https://www.bestbuy.com/site/dell-s...c-monitor-piano-black/5996200.p?skuId=5996200

    whenever i connect to it via HDMI, it causes the frame rate to go above 60. Normally, when playing on the laptop, i have V Sync turned in, and no problems there, games are locked to 60fps. When i connect to the monitor, bam, all games run at way more than 60. I dont change any settings when connecting, not sure whats going on.
     
  2. jaseow

    jaseow Active Member

    That is because the monitor you bought is 75hz while the Blades monitor is 60hz
     
  3. Joikansai

    Joikansai Well-Known Member VANGUARD

    There’s similar question on main thread recently, seems you have to resetting vsync off on and FPS (if there’s any in game) again after connecting to external monitor to get your desired setting.
     
  4. jaseow

    jaseow Active Member

    Dont have to reset. Its just cos the blade and the new monitor he bought has different refresh rates.

    Its the same case when im out playing and its locked to 60fps on the blade. But when I get home on my 144hz monitor the framerates go above 60.

    You can set your external monitor to 60hz refresh rate instead of 75hz default as well if it bothers you that much. But otherwise its working as intended.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >