Core keeps disconnecting

Discussion in 'Systems' started by AJsRanger, Jul 4, 2016.

Thread Status:
Not open for further replies.
  1. AJsRanger

    AJsRanger Member

    I won't bother with support until tomorrow because of the holiday, but has anybody else been having issues with the Core disconnecting?

    I plug it in and my RBS will recognize it for a second and then disconnect, and then recognize it again, and then disconnect again, etc. This has been going on for a few hours now. It's making it impossible to play any games with it. As I'm typing right now, it says it's connected, but the Chroma lighting isn't turning on.

    I've checked all the drivers to make sure everything is up to date, done a few resets, so on. Have yet to uninstall everything and then install it again. Any recommendations as to what to do next or what's going on? Given that I had to wait 40 billion years to get it in the first place, I'd prefer to not have to RMA or return it.
  2. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    Did you update your intel iGPU? Are you on a blade or stealth? You'll need to disable your internal nvidia GPU and update its drivers before plugging in the core.
  3. Mines doing the same exact thing on my blade 2016 + core + 1080. I can be sitting at the desktop idle and off/on/off/on , sometimes it cycles off chroma lighting all together sometimes it comes back on with it.
  4. squeeze88

    squeeze88 Active Member

    and my impression was it only happens to non-razer laptop / systems... tsk...
  5. I have a RBS and core as well, and mine is holding a steady connection between the two. I didn't have to do any debugging to get the Core recognized. Other than updating the drivers, i believe there was a popup regarding thunderbolt devices - I was lazy and put to always approve.
  6. Hmm after reading some other threads and messing with mine it seems directly related to the hinge / tab magnetic connection that I guess tells the enclosure that it is closed up. If I pull mine out and push it all the way in with the handle in the closed position I get the "power click" and note that it stays on without rebooting.

    If I push it all the way in and then click down the handle I sometimes get the click. I tested with it plugged in the blade and the blade turned off, would work on the stealth too off. When you move it around you should hear the "click", i noticed that when it was fully seated and closed I would get the click if I really pushed or moved the part.

    Probably has that magnetic part just far enough or not touching to cause it to come on and then cycle on and off if it's really weak. Just my guess so far with it sticking out a hair from the enclosure it's working without reboots.

    Dang looks like an RMA unless Razer can tell us how to adjust that latch.
  7. AJsRanger

    AJsRanger Member

    Definitely just tried that. Seems to be solving the problem so far though. Just wasn't seated in properly, but since I pushed it back a little further, nothing bad has happened yet. Hoping it stays that way.
  8. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    Wow. That could explain the totally random connection issues I've been having with my core. Would be very annoying if this was another rushed job botched by Razer "QC".
  9. Blockmonster57

    Blockmonster57 Active Member

    After reading this, I think I'll just leave my RBS as an ultrabook and build a rig instead
  10. OMG!

    I had the same exact issue! A little bending of the rail (just slighly pushing it in) fixed this issue, but I would have to power cycle my Core if I disconnected my Core for a little bit before it would be recognized by the PC. I tried everything, but no luck...Ended up RMA'ing it... :slightly_sad:
  11. I was trying to figure out what needed "bent" to get it to connect everytime? Is it the actual whole rail it slides down that acts as the "magnetic sensor"? I see a long silver piece that is snapped on / connected to the rail on one side? I really hate RMA'ing this thing since it took so long to get one.

    Did they give you anytime time frame on your replacement dyeLucky?
  12. rb6freak

    rb6freak New Member

    I'm having the same issue. Haven't done anything about it yet though.
  13. vampirivan

    vampirivan Well-Known Member

    not good not good... but finally you say is "only" a problem on the cable rigth? a little not very well secured?
  14. I kind of have this issue, but for me, when I plug in the core to my stealth, the core cannot be detected by the stealth. It can charge the laptop, just the laptop won't detect it.
  15. If you power cycle the core while it is connected to your laptop, will it recognize it?
  16. For me at least, the laptop didn't recognize the core, I even did a system restore to see if it was driver related, I don't know what was happening, I have sent the core back to razer now
  17. So after coming to the conclusion that the disconnect / reboots (fan spin, chroma lights reset, sometimes no lights on reboot) are all directly related to a poor connection on the magnetic sensor. I did start the RMA process which hasn't gotten any further than "thanks for submitting your serial / info, escalated" which started yesterday at 9:15am PDT (11:15am CST).

    In the meantime I did decide that I could go ahead and band-aid the issue Macgyver style in the meantime since bending / flexing the rail didn't seem like the best thing to have to do on a brand new $400 ($500) dollar premium product. I shouldn't have to Macgyver it either but that's beside the point, my $0.01 cent paper clip with some slight modifications and added electric tape on the tips (not pictured) has seemed to do the trick, no more reboots / fan spins.


    Now the new problem is that my nvidia display driver stops responding randomly (not sure if still core related) and does not recover as it did previously when the Core itself would power cycle / reboot. When it does stop responding it switches to the Microsoft Basic driver, also note in device manager Intel HD graphics is running Microsoft Basic driver. If I attempt to disable / re-enable the Core graphics I get a BSOD.
    LittleTime626 likes this.
  18. Hey man,

    Glad you figured it out! Sorry for not getting back to you on what I did....

    Seems like you have experienced the same issues I have, except you don't have to power cycle the Core while connected to the RBS to get the Core to be recognized.

    In regards to the Intel HD graphics, go to Intels site and upgrade to the latest 520 graphics driver. I noticed mine my nvidia driver would randomly crash while I was playing a game (Naruto Shippuden Ninja Storm 4), but this could be game related since I left Fallout 4 running for an hour with no issues...

    Good luck!
  19. So spent the better part of last night working on this and determined that no matter what the Core is faulty / bad. I ran through the entire gamut of possibilities to get this working 100% optimal.

    1. Used MacGyver trick with $0.01 cent paper clip to get good contact with magnetic sensor (problem one).
    2. Ran DDU to completely clean uninstall all graphics drivers including the Intel Drivers and Nvidia drivers. Rebooted on each clean-up, reinstalled the latest 4463 intel drivers rebooted, installed yesterday's 368.69 drivers fresh with core hooked up detected both 970m and 1080 installed without any issues, went ahead and rebooted though I didn't get prompt.
    3. Ran through settings first disabling 970m, then setting nvidia control panel global to "always prefer high performance nvidia" and setting the power mode to "maximum performance".
    4. Verified windows power plan "high performance" was default settings, ensured "link state power" for PCI-express was set to "off".

    After all this not long after on desktop I got a BSOD, ended up getting another one at some point. I thought maybe nvidia graphics driver was not responding to something timely so I added the registry value for "TdrDelay" which is timeout detection / recovery delay. Default in windows is 2 seconds, I bumped it to 8 seconds which didn't seem to help at first since I got another BSOD.

    After another reboot seemed to be good for awhile, I ran 3dmark firestrike and firestrike ultra no issues, played some HTC Vive games for about 30 minutes no issues. Went back to the desktop and went to update some steam games and about 5-10 minutes in got the blank on both screens though core lights / fans still running, laptop chroma still cycling, etc. I waited it out for some time and after almost 90 seconds the windows disconnect sound came in and flashed to the laptop display and then reconnect sound came and core display came back. Usually I shutdown the PC thinking it's frooze / BSOD'd for reboot, noticed my external drive hooked up directly to the core was still flashing like it was writing files from steam downloads, chroma was cycling on keyboard so I assume it was still doing something. 90 seconds it came back.

    After letting those updates finish I went ahead and started a 3dmark firestrike 1.1 loop and monitored off and on over the hour before I went to bed, no issues so far up to that 1 hour. Woke up later in the night like an hour and a half later to feed the baby and noticed it was sitting at the desktop with 3dmark just saying "starting next test" with the 3dmark window in the background like it stopped or the driver cycled like earlier with the blank / black screen and back. I restarted it from here no issues and went back to bed.

    Woke up this morning 4-5 hours later and noticed laptop mirrored display same on blade and monitor with 3dmark showing "stopped test unexpectedly). Noticed when setting to show only on monitor 2 the blade display was still on with backlight, looked at device manager and noticed intel driver was running microsoft basic driver with the exclamation mark (intel driver crashed at some point).

    At this point I'm not sure, I assume it's a faulty Core. I have a bad magnetic sensor or bad connection / rail not touching but also sounds like my Core is flaky. I took 3 minidumps from the BSOD's yesterday and dumped my event viewer logs for application / system to sent on to Razer from last night at 8pm until this morning.
  20. Just wanted to update everyone that over the weekend I went ahead and removed the paper clip since it did a power cycle on me once still and just slightly press the rail inward on the end to ensure good contact with the magnetic sensor. Low and behold I have not had a single issue since! Sounds like the flaky connection issue the whole time was the rail just not getting optimal contact with the magnetic sensor inside the case.

    I've spent the entire weekend gaming on it, left it running all night on Overwatch looping no crashes / reboots. Saturday night I left DOOM single player running over night and into the next day until after lunch no issues / crashes / reboots. I've played a ton of HTC Vive and Oculus Rift without any issues on either one of those as well. I went ahead and canceled my RMA for the time being, thing that's all the issue was. I did go through and DDU all my display drivers, install the latest Intel beta drivers for the HD 530 along with the latest nvidia 368.69 drivers again fresh as well. Cheers!
    Lost Dreamer and dyeLucky like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >