Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Huntsman Elite Not Functioning Correctly

Discussion in 'Razer Support' started by Tarquin37, Oct 13, 2018.

Thread Status:
Not open for further replies.
  1. Tarquin37

    Tarquin37 New Member

    I recently purchased a huntsman elite and it worked just fine for awhile, but I have been having problems recently where when I press a key once it writes that key multiple times, this happens when both usb cords are plugged in. Oddly enough when just he one usb cord is plugged in this doesn't happen anymore, instead there is a huge delay after keypresses and sometimes some presses don't even register. Opening or closing Synapse doesn't fix this, nor does uninstalling and reinstalling, sometimes restarting my computer with the keyboard unplugged fixes the problem, sometimes I have to restart multiple times. All my drivers are up to date, so I don't know what the problem is, anyone experienced this before and have any solutions.
     
  2. FirePenguin

    FirePenguin Well-Known Member

    Hello!
    Does this still happen when Synapse is not running? Also, have you tried switching USB ports?
     
    freakydoctor likes this.
  3. GasparYap

    GasparYap New Member

    I'm an Osu Mania player, so I'm very sensitive about the key register problem.
    My huntsman elite has the same problem as yours. When I press the key, it doesn't register and it screws up my game experience.

    The problem I found is with the Wrist rest USB port.
    There are 2 solutions:
    1. Unplug the USB for the wrist rest. (But u will lose the RGB for the wrist rest and the surrounding of the keyboard)
    2. Try plugging in the USB to other port (not the keyboard one). If this solution doesn't work, just use the first solution. Unless Razer found the problem and fix it.

    Hope this will help you :)
     
  4. FirePenguin

    FirePenguin Well-Known Member

    Hi @GasparYap . Are you still having problems with keys not responding when the wrist rest is connected? If so, send me a PM with the serial and product number of your Huntsman Elite and I might have a fix for you. :)
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >